problem mit KDE nach xfce

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 10:19

hallo,

ich habe ne problem mit meinem Linux rechner und weiß echt nicht weiter.

also erstmal grundlegendes.
1. es ist debian 4.0 drauf
2. der server hatte KDE und einen VNC server installiert (

ich habe folgendes gemacht:
ich habe versucht "RDP-Server für Linux mit xrdp" zu installieren.
dafür hatte ich ein tut hier gefunden.

an diesem bin ich aber gescheitert.

also ich dann den vnc server wieder gestartet hatte stellte ich fest ich habe auf einmal xfce als benutzeroberfläche drauf (kannte es vorher nicht :( ).

so nun will ich es wieder loswerden
was sich für mich schwerer als befürchtet gestaltet.
ich habe folgendes schon gemacht:
apt-get --purge remove xfce4
apt-get --purge remove xserver-xfree86 x-window-system-core xfce4
apt-get --purge remove xfce4-panel
apt-get --purge remove xfdesktop
apt-get --purge remove xfce4-menu-plug
apt-get --purge remove xfwm4

da dann aber immernoch dieses xfce geladen wurde habe ich aus verzweifelung folgendes gemacht:

Code: Select all

apt-get --purge remove xserver-xfree86 xlibs xbase-clients icewm xfree86-common x-window-system
apt-get --purge remove discover mdetect read-edid  
apt-get --purge remove kde kde-i18n-de 
also alles wieder weg...
so dann:

Code: Select all

aptitude install xserver-xfree86 xlibs xbase-clients icewm xfree86-common x-window-system discover mdetect read-edid kde kde-i18n-de
dann wollte ich KDE mal starten.

Code: Select all

server:~# startkde
xsetroot:  unable to open display ''
xset:  unable to open display ""
xsetroot:  unable to open display ''
startkde: Starting up...
ksplash: cannot connect to X server
xprop:  unable to open display ''
usage:  xprop [-options ...] [[format [dformat]] atom] ...

where options include:
    -grammar                       print out full grammar for command line
    -display host:dpy              the X server to contact
    -id id                         resource id of window to examine
    -name name                     name of window to examine
    -font name                     name of font to examine
    -remove propname               remove a property
    -set propname value            set a property to a given value
    -root                          examine the root window
    -len n                         display at most n bytes of any property
    -notype                        do not display the type field
    -fs filename                   where to look for formats for properties
    -frame                         don't ignore window manager frames
    -f propname format [dformat]   formats to use for property of given name
    -spy                           examine window properties forever

kdeinit: Aborting. $DISPLAY is not set.
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server
ERROR: Couldn't attach to DCOP server!
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
xprop:  unable to open display ''
usage:  xprop [-options ...] [[format [dformat]] atom] ...

where options include:
    -grammar                       print out full grammar for command line
    -display host:dpy              the X server to contact
    -id id                         resource id of window to examine
    -name name                     name of window to examine
    -font name                     name of font to examine
    -remove propname               remove a property
    -set propname value            set a property to a given value
    -root                          examine the root window
    -len n                         display at most n bytes of any property
    -notype                        do not display the type field
    -fs filename                   where to look for formats for properties
    -frame                         don't ignore window manager frames
    -f propname format [dformat]   formats to use for property of given name
    -spy                           examine window properties forever

startkde: Done.
so und nun bin ich verzweifelt.
ich bin auch KEIN Linux pro deshalb habe ich ka mehr was ich machen soll.

könnt ihr mir da helfen?
Last edited by viperdriver2000 on 2007-06-14 13:58, edited 1 time in total.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: problem mit KDE nach xfce

Post by Joe User » 2007-06-14 11:11

Da Du kein "Linux pro" bist, solltest Du Dich von Deinem Vorhaben schnellstens trennen. Siehe Suchfunktion->KDE

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 11:18

mh...das ist schade.
weil es lief ja mal.
nur jetzt eben net mehr.

meine letzte alternative wäre das ich das alles neu installiere.
also server mit image neu inst usw.
das will ich aber nicht weil so werde ich nie erfahren was es war.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: problem mit KDE nach xfce

Post by Joe User » 2007-06-14 11:39

Also nochmal: Wozu benötigst Du ein GUI auf dem Server? Sicherheitslücken kann man auch eleganter verursachen...

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 12:37

weil ich mit der gui auf ihm arbeiten möchte?

aber ich wollte eigentlich auch keine diskusion zu "warum kde auf einem server".
ist nicht persönlich gemeint.

mfg

elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: problem mit KDE nach xfce

Post by elch_mg » 2007-06-14 13:44

auf rootservern arbeitet man in der Regel per Shell. Ungefähr alles, was du per GUI veranstalten würdest, geht per Shell eleganter, schneller, und verursacht weniger unnütze Last und ist vorallem kein Sicherheitsrisiko allererster Güte.

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: problem mit KDE nach xfce

Post by flo » 2007-06-14 13:54

Wie kommt Ihr eigentlich darauf, daß das ein Rootserver ist?

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 13:55

viperdriver2000 wrote:aber ich wollte eigentlich auch keine diskusion zu "warum kde auf einem server".
ist nicht persönlich gemeint.
ich möchte eigentlich nur das DAS GUI wieder läuft...

edit:
weil sich "Joe User" durch die bezeichnung scheinbar irritiert war/ist.
Last edited by viperdriver2000 on 2007-06-14 14:27, edited 2 times in total.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: problem mit KDE nach xfce

Post by Joe User » 2007-06-14 14:17

viperdriver2000 wrote:ich möchte eigentlich nur das sie wieder läuft...
Es heisst das GUI nicht die GUI. Abgesehen davon: Hast Du Dir mal die bisherigen Threads zum Thema KDE<->RootServer durchgelesen und eine Lösung gefunden, die damit verbundenen Sicherheitslücken zu beheben ohne die Benutzbarkeit einzuschränken? Falls ja, würde mich/uns die Lösung wirklich sehr interessieren, man lernt ja nie aus.
Wie Du es "zum Laufen" bekommst, steht im Manual Deiner Distribution, wie Du es absicherst allerdings nicht...

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: problem mit KDE nach xfce

Post by Roger Wilco » 2007-06-14 14:24

viperdriver2000 wrote:dann wollte ich KDE mal starten.
Das Skript startkde setzt einen laufenden X-Server voraus.

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 14:26

@Joe User
tut mir leid aber ich werde hier in diesem topic deine antworten ignorieren.
weil irgendwie willst du mir nicht helfen (musste ja auch nicht).

und ich will mich auch nicht mit dir streiten.

@Roger Wilco
also bei startx kommt:

Code: Select all

server:~# startx
xauth:  creating new authority file /root/.serverauth.14756

X: warning; process set to priority 0 instead of requested priority 1

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux h1180603 2.6.8-3-686 #1 Tue Dec 5 21:26:38 UTC 2006 i686
Build Date: 04 April 2007
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 14 11:13:26 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) AIGLX: Screen 0 is not DRI capable
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
        No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"
    xkb_keycodes             { include "xfree86+aliases(qwertz)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+de(de)" };
    xkb_geometry             { include "pc(pc104)" };
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "de" in the include file "de"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
No core pointer

Fatal server error:
failed to initialize core devices
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
Last edited by viperdriver2000 on 2007-06-14 14:30, edited 1 time in total.

sledge0303
Posts: 695
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: problem mit KDE nach xfce

Post by sledge0303 » 2007-06-14 14:29

Joe User wrote: Wie Du es "zum Laufen" bekommst, steht im Manual Deiner Distribution, wie Du es absicherst allerdings nicht...
@Threadstarter
Dann lese mal nach wie das geht und was die Absicherung angeht, an der Lösung bin ich auch interessiert. ;)

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 14:32

@sledge0303
sei mir nicht böse, aber mich interessiert die sicherheit im moment kein stück.
im moment läuft ja nicht mal was.

erstmal muss SIE (danke Joe User) wieder laufen.

elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: problem mit KDE nach xfce

Post by elch_mg » 2007-06-14 14:37

viperdriver2000 wrote:sei mir nicht böse, aber mich interessiert die sicherheit im moment kein stück
ists ein öffentlich erreichbarer Server mit fester IP und guter Anbindung?

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 14:40

@elch_mg
das ist für die lösung meines problemes vollkommen uninteressant

@all
können wir bitte wieder zum topic zurück kommen!?

elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: problem mit KDE nach xfce

Post by elch_mg » 2007-06-14 14:43

viperdriver2000 wrote:@elch_mg
das ist für die lösung meines problemes vollkommen uninteressant
Und wie es das ist. Wenn demnächst wieder eine Spam-Welle reinkommt, hab ich schonmal wieder einen Verdächtigen mehr.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: problem mit KDE nach xfce

Post by Joe User » 2007-06-14 14:46

viperdriver2000 wrote:

Code: Select all

(EE) AIGLX: Screen 0 is not DRI capable
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
        No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"
    xkb_keycodes             { include "xfree86+aliases(qwertz)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+de(de)" };
    xkb_geometry             { include "pc(pc104)" };
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "de" in the include file "de"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
No core pointer

Fatal server error:
failed to initialize core devices
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
Ist doch eindeutig, Deine xorg.conf ist kaputt.
viperdriver2000 wrote:tut mir leid aber ich werde hier in diesem topic deine antworten ignorieren.
Oh, sorry, dann ignoriere obigen Hinweis bitte.
viperdriver2000 wrote:weil irgendwie willst du mir nicht helfen
Richtig, ich möchte nicht für einen gecrackten Server verantwortlich sein.
viperdriver2000 wrote:und ich will mich auch nicht mit dir streiten.
Streit ist etwas Anderes. Ich versuche lediglich Dich vor einer grossen Dummheit zu bewahren, auch wenn Du glaubst es sei Keine...

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: problem mit KDE nach xfce

Post by Roger Wilco » 2007-06-14 14:46

viperdriver2000 wrote:also bei startx kommt:
Du startest X als root. Das ist bäääh. Außerdem stehen in der Ausgabe von startx doch alle Angaben, die du brauchst. Das Präfix (EE) kennzeichnet Fehler.
Kleiner Tipp: Ein Root-Server zeichnet sich i. d. R. dadurch aus, dass keine Peripherie angeschlossen und keine Grafikkarte verbaut ist...

sledge0303
Posts: 695
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: problem mit KDE nach xfce

Post by sledge0303 » 2007-06-14 15:00

viperdriver2000 wrote:@sledge0303
sei mir nicht böse, aber mich interessiert die sicherheit im moment kein stück.
im moment läuft ja nicht mal was.

erstmal muss SIE (danke Joe User) wieder laufen.
Ich bin dir nicht böse, wieso auch?

Du scheinst dir nicht im klaren zu sein wie schnell deine Kiste als Beute von Skriptkiddies herhalten wird und was die damit alles anstellen werden.
Du wärst nicht der erste der Besuch vom Staatsanwalt bekommt, weil alles was darüber abläuft geht zu deinen Lasten und da wird niemand einen 12jährigen 'Hacker' in Rio verantwortlich machen weil DU verantwortungslos den Server 'installiert' hast.

Lies dir nebenbei erwähnt noch den Hinweis von Roger Wilco betreffs der GK durch ;)
GK, Soundkarten etc sind auf einem Rootserver sinnfrei oder du musst dir einen Anbieter suchen der Windoofs als OS anbietet.

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 15:22

@elch_mg
ja ist okay.

@Joe User
na das ist doch mal ne antwort mit der man leben kann. danke.
Joe User wrote:Ich versuche lediglich Dich vor einer grossen Dummheit zu bewahren, auch wenn Du glaubst es sei Keine...
danke. trotzdem möchte ich es laufen haben.

@Roger Wilco
du meinst ich sollte dafür nen extra user machen?
okay.das ist auch ne guter hinweis!
Roger Wilco wrote:Kleiner Tipp: Ein Root-Server zeichnet sich i. d. R. dadurch aus, dass keine Peripherie angeschlossen und keine Grafikkarte verbaut ist...
nur was du mir damit sagen willst verstehe ich nicht ganz...

@sledge0303
okay danke.


ich möchte auch mal folgendes hervorheben:
flo wrote:Wie kommt Ihr eigentlich darauf, daß das ein Rootserver ist?
diese frage lasse ich trotzdem weiter im raume stehen.
weil es ist für die lösung des problemes vollkommen egal ist ob es ein homeserver ist der garkein inet hat oder ob es ein rootserver in einem RZ ist.

sledge0303
Posts: 695
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: problem mit KDE nach xfce

Post by sledge0303 » 2007-06-14 15:26

diese frage lasse ich trotzdem weiter im raume stehen.
weil es ist für die lösung des problemes vollkommen egal ist ob es ein homeserver ist der garkein inet hat oder ob es ein rootserver in einem RZ ist.
Die Frage ist einfach zu beantworten: hier in diesem Forum geht es um dedizierte Rootserver. Wer sich beim anmelden die Rules durchgelesen hat, wird es festgestellt haben :lol:

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 15:31

@sledge0303
und deshalb kann man hier keine frage stellen die mir einem nicht dedizierte Rootserver zu tun hat?
aha...

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: problem mit KDE nach xfce

Post by EdRoxter » 2007-06-14 15:36

viperdriver2000 wrote:sei mir nicht böse, aber mich interessiert die sicherheit im moment kein stück.
im moment läuft ja nicht mal was.
Der Server läuft. Und wenn es ein öffentlich erreichbarer Server mit fester IP ist, wovon man ausgehen darf, _weil du in diesem Forum postest_, dann musst du dir um die Sicherheit schon Gedanken machen, bevor du überhaupt den Vertrag unterschreibst, das Ding aufzustellen.

Auch, wenn du nichts drauf installiert hast - du glaubst nicht, wie schnell auf einem ungesicherten Rootserver was drauf ist, was da eigentlich gar nicht hingehört. Und ab da bist DU voll verantwortlich für alles, was passiert. Wenn deine Kiste genutzt wird, um Warez zu verteilen, bist DU strafrechtlich belangbar. Wenn deine Kiste munter das Provider-Netzwerk zu Tode DoSt, bist DU dran schuld.

Wieso fehlt eigentlich so vielen Menschen das kleine Bisschen Weitsicht zu kapieren, dass ein kompromittierter Server nicht nur mein eigenes Problem ist, sondern mit großer Wahrscheinlichkeit auch noch das von 20-30% meiner Servernachbarn?

viperdriver2000
Posts: 33
Joined: 2006-06-07 23:40
Location: Berlin

Re: problem mit KDE nach xfce

Post by viperdriver2000 » 2007-06-14 15:44

@EdRoxter
warum versteht ihr nicht das es hier nicht um das thema sicherheit geht?!

ich möchte ne lösung für das problem was ich hier habe.

aber scheinbar ist ja keiner von euch in der lage mir da weiterzuhelfen.
sonder klugscheißt alle nur das alles sicher sein muss.

ich glaube das bringt hier echt nix.
leider.

ist schon traurig.

aber naja.

falls jemand noch was zum thema (also das wirkliche) zu sagen hat dann freue ich mich sehr. den rest werde ich geschickt ignorieren...

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: problem mit KDE nach xfce

Post by EdRoxter » 2007-06-14 15:57

Wenn dein Problem nicht mit einem dedizierten Root zu tun hat, bist du hier falsch. Wenn doch, haben alle, die dir was von Sicherheit erzählen, recht. Ende.

Es gibt genügend linuxforen (hint!), bei denen dir andere Leute sicherlich gerne helfen werden, auch wenn es sich um eine private Box handelt.