Glaube php läuft nicht!? Was tun?

Apache, Lighttpd, nginx, Cherokee
paykoman
Posts: 86
Joined: 2006-07-16 14:18

Glaube php läuft nicht!? Was tun?

Post by paykoman » 2007-06-09 12:05

Hallo, ich hoffe mal das ich hier richtig binn, weil ich denke es ist nur nen Administrations fehler xD

Also ich habe nen suse linux 10.2 64bit server.

Das Problem ist das ich irgentwo was übersehen habe oder etwas nicht funktioniert.

Meine Clanseite http://www.crazysportz.de wird nur weiß dargestellt! Ich dachte erst das er den mysql Server erst gar nicht erreicht, darauf hin habe ich mal ein falsches PW angegben doch dan kam wie erwartet die Fehlermeldung das er die DB nicht erreicht.

Das heißt also das er mysql findet und Connectet.

Aber was ist das Problem?
Kan er die db nichht richtig lesen oder woran liegt das?

php5 und php-gd ist installiert, aber obs funktioniert weiß ich nicht.

Ich habe kein Webspace programm wie Confixx am laufen, abgesehen von Webmin.
Habe nen user über yast angelegt der auch in den richtigen Gruppen geordnet ist da er ja zu db connectet. Zusätzlich habe ich phpmyadmin installiert da ich erst dachte es wäre vllt. nen Problem von webmin mit MySql.

Ich denke das php noch nicht richtig läuft...
den ich kann auch die info.php nicht aufrufen. http://www.crazysportz.de/inc/info.php

Wäre echt nett wenn mir da jmd. sagt wie ich das ans laufen bekomme!

MFG: Payko
PS: freue mich auf eure Unterstützung

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: Glaube php läuft nicht!? Was tun?

Post by dtdesign » 2007-06-09 12:45

@Mods: Bitte verschieben nach "Webserver - Installation und Konfiguration"

@Topic:

Hallo Paykoman,

nur mit irgendwelchen undeutlichen Beschreibungen des Problems, sowie einer Präsentation von leeren, aussagekräftigen *g* Seiten, können wir dir leider nicht weiterhelfen.

Ich gehe mal davon aus, dass du einen root-Server besitzt. In dem Falle poste bitte relevante Logauszüge (etwa die Apache error-Logs) bzw. stelle testweise die Option 'display_errors' in deiner php.ini wieder an. Eventuell treten 'Fatal Error' auf, werden jedoch nicht angezeigt. Oder PHP läuft gar nicht erst.

Gruß
dtdesign

paykoman
Posts: 86
Joined: 2006-07-16 14:18

Re: Glaube php läuft nicht!? Was tun?

Post by paykoman » 2007-06-09 12:48

Hi,

danke für deine Antwort..
Das Topic war zu erst anders...
Aber kam halt gerade drauf das php warscheinlcih garnicht läuft und habe deshalb den Thread aktualisiert.

Ich bin in roots noch nen anfänger, habe zwar soweit geschnallt was ich machen soll aber wie bekomme ich aus putty den text kpiert? Bei strg + c wird ja alels abgebrochen xD


würde mich auch über eine schritt für schritt anleitung für php freuen, sprich wo was liegt und wo was hin muß, wo welche einträge gemacht werden müßen.

MFG

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: Glaube php läuft nicht!? Was tun?

Post by dtdesign » 2007-06-09 12:52

Dann mach folgendes:

PuTTY starten -> In dieser vertikalen Navigation gehst du auf "Window" -> "Lines of Scrollback" stellst du auf "2000".

Dann connectest du dich zu deinem Server, gehst ins Logverzeichnis, dann ein 'clear'. Anschließend bei PuTTY über das Programmicon im offenen Fenster (oben links) auf "Clear Scrollback".

Und nun das ganze einfach mit cat ausgeben, ansonsten (falls vorhanden bei SuSE) kann ich dir nano empfehlen, der bricht da nicht ab und vim glaub ich auch nicht.

Gruß
dtdesign