Schwierigkeiten mit SSL nach Serverumzug

Apache, Lighttpd, nginx, Cherokee
twisterchen
Anbieter
Posts: 233
Joined: 2005-07-14 14:13

Schwierigkeiten mit SSL nach Serverumzug

Post by twisterchen » 2007-05-29 13:01

Hallo

So nun muss ich mich doch an euch halten nachdem ich nicht weiterkomme.
Habe heute Nacht meine Domains auf einen neuen Server migriert von Plesk zu Plesk alles wunderbar Domains funktionieren auch alle.
Nur dass auf dem neuen Server in der error.log nun dies steht SSL server IP/port conflict.

Code: Select all

You should not use name-based virtual hosts in conjunction with SSL!!
Hiermit komm ich nicht ganz klar auf dem altem server war es ja auch so und da kommt die Fehlermeldung nicht.
Das ganze sind zwar nur warnings aber ich möchte die Ursache beheben vielleicht könnt ihr mir da einen TIP geben muss ja funktionieren wenns auf dem altem Server auch ging.

Gruss
Twisterchen und danke schonmal für eure Tips

Code: Select all

[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom1.de:443 (/home/httpd/vhosts/dom1.de/conf/httpd.include:12) vs. dom2.de:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom3.de:443 (/home/httpd/vhosts/dom3.de/conf/httpd.include:12) vs. dom2:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom4.de:443 (/home/httpd/vhosts/dom4.de/conf/httpd.include:12) vs. dom2.de:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: forum.dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:277) vs. subdom.dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:344)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: demoserver.dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:186) vs. gog-clan.dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:344)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:12) vs. subdom.dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:344)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom6.com:443 (/home/httpd/vhosts/dom6.com/conf/httpd.include:12) vs. dom2.de:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom7.de:443 (/home/httpd/vhosts/dom7.de/conf/httpd.include:12) vs. dom2.de:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: default-127-0-242-158:443 (/etc/apache2/conf.d/zz010_psa_httpd.conf:188) vs. dom2.de:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: default-127-0-242-155:443 (/etc/apache2/conf.d/zz010_psa_httpd.conf:169) vs. gog-clan.dom5.de:443 (/home/httpd/vhosts/dom5.de/conf/httpd.include:344)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: default-128-1-198-216:443 (/etc/apache2/conf.d/zz010_psa_httpd.conf:131) vs. webmail:443 (/etc/apache2/conf.d/zz010_psa_httpd.conf:253)
[Tue May 29 12:44:22 2007] [warn] Init: SSL server IP/port conflict: dom8.de:443 (/home/httpd/vhosts/dom8.de/conf/httpd.include:12) vs. dom2.de:443 (/home/httpd/vhosts/dom2.de/conf/httpd.include:12)
[Tue May 29 12:44:22 2007] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by Roger Wilco » 2007-05-29 13:13

Für HTTPS auf dem Standardport ist pro Domain eine eigene IP-Adresse notwendig. Oder du prügelst alle Domainnamen in das SSL-Zertifikat.

twisterchen
Anbieter
Posts: 233
Joined: 2005-07-14 14:13

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by twisterchen » 2007-05-29 13:27

Hi Roger danke mal für deine Antwort
Roger Wilco wrote:Für HTTPS auf dem Standardport ist pro Domain eine eigene IP-Adresse notwendig.
Das ist mir schon klar, das ich für jede domain eine eigene IP brauchen würde. Nur warum die Fehlermeldungen jetzt auf einmal auf dem neuen Server erscheinen und auf dem alten waren sie nicht ( war auch nur eine IP ) ist mir unklar .?
Oder du prügelst alle Domainnamen in das SSL-Zertifikat.
Wie soll ich das verstehen ?

Code: Select all

*.dom1.de;dom2.de;*.dom3.de

Gruss
Twisterchen

twisterchen
Anbieter
Posts: 233
Joined: 2005-07-14 14:13

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by twisterchen » 2007-05-29 15:43

Ich versteh das nicht !!! ich versteh zwar das ich für jede domain eine eigen IP brauche um für jede Domain ein Zert. erstellen zu können.

Aber warum diese Warnings die waren vorher auch nicht kann es daran liegen das der Apache eine neuere Version hat und die nun mit den Warnings auftauchen ?

Demzufolge das es IP Hosting ist kann ich die Warnings getrost ignorieren ?

twisterchen
Anbieter
Posts: 233
Joined: 2005-07-14 14:13

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by twisterchen » 2007-05-29 18:40

So nach einer 3 Stündigen suche bin ich immernoch erfolgslos

http://httpd.apache.org/docs/2.0/ssl/ss ... en#vhosts2

das sagt mir eigentlich nur das was ich schon weis

Vielleicht könnt ihr mir einfach nur das mal beantworten
Aber warum diese Warnings die waren vorher auch nicht kann es daran liegen das der Apache eine neuere Version hat und die nun mit den Warnings auftauchen ?

Demzufolge das es IP Hosting ist kann ich die Warnings getrost ignorieren ?

Vielen Vielen Dank
Twister

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by dtdesign » 2007-05-29 21:58

Twisterchen wrote:Diese Warnings die waren vorher auch nicht kann es daran liegen das der Apache eine neuere Version hat und die nun mit den Warnings auftauchen ?

Demzufolge das es IP Hosting ist kann ich die Warnings getrost ignorieren ?
Wenn du eine 100%-ige Kopie deines Systems hast, dann werden genau die selben Fehlermeldungen gekommen sein oder dein altes System ist mächtig kaputt. Hast du eventuell nicht jedem Domain SSL bereitgestellt und tust dies auf einmal für jeden einzelnen?

Ein wenig mehr Informationen bzgl. der unterschiedlichen Konfiguration würden hier helfen. Ansonsten, für SSL braucht jeder Domain seine eigene IP. Dies ist so und wird sich leider mit sehr hoher Wahrscheinlichkeit auch nicht in ferner Zukunft ändern. Seh es als "Gegeben:" an.

Gruß
dtdesign

twisterchen
Anbieter
Posts: 233
Joined: 2005-07-14 14:13

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by twisterchen » 2007-05-30 11:18

dtdesign wrote: Wenn du eine 100%-ige Kopie deines Systems hast, dann werden genau die selben Fehlermeldungen gekommen sein oder dein altes System ist mächtig kaputt. Hast du eventuell nicht jedem Domain SSL bereitgestellt und tust dies auf einmal für jeden einzelnen?
Nein eigentlich nicht dasalte System war ein Plesk 8.0.1 auf Suse 9.3
Das neue System ein Suse 10.1 mit Plesk 8.1.0
dtdesign wrote: Ein wenig mehr Informationen bzgl. der unterschiedlichen Konfiguration würden hier helfen. Ansonsten, für SSL braucht jeder Domain seine eigene IP. Dies ist so und wird sich leider mit sehr hoher Wahrscheinlichkeit auch nicht in ferner Zukunft ändern. Seh es als "Gegeben:" an.
Mach ich wie ich schon gesagt habe ist mir das bereits vollkommen klar, dann müsst ihr ja teilweise auch die Fehlermeldungen in euren error.logs haben wie ich, kann mir nicht vorstellen das ihr eure domains alle auf einer eigenen IP hostet.


Code: Select all

NameVirtualHost <ip>:80
NameVirtualHost <ip>:80
NameVirtualHost <ip>:80
NameVirtualHost <ip>:80
NameVirtualHost <ip>:80
NameVirtualHost <ip>:80
NameVirtualHost <ip>:443
NameVirtualHost <ip>:443
NameVirtualHost <ip>:443
NameVirtualHost <ip>:443
NameVirtualHost <ip>:443
NameVirtualHost <ip>:443
ServerName name
ServerAdmin email

DocumentRoot /home/httpd/vhosts/default/htdocs

<IfModule mod_logio.c>
LogFormat "%h %l %u %t "%r" %>s %O "%{Referer}i" "%{User-Agent}i"" plesklog
</IfModule>
<IfModule !mod_logio.c>
LogFormat "%h %l %u %t "%r" %>s %b "%{Referer}i" "%{User-Agent}i"" plesklog
</IfModule>
<Directory "/home/httpd/vhosts">
	AllowOverride All
	Options SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
	<IfModule sapi_apache2.c>
	php_admin_flag engine off
	</IfModule>
	<IfModule mod_php5.c>
	php_admin_flag engine off
	</IfModule>
</Directory>

<Directory "/usr/lib/mailman">
	AllowOverride All
	Options SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
	<IfModule sapi_apache2.c>
	php_admin_flag engine off
	</IfModule>
	<IfModule mod_php5.c>
	php_admin_flag engine off
	</IfModule>
</Directory>

<IfModule mod_userdir.c>
	UserDir disabled
</IfModule>


<VirtualHost 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			>
	ServerName default
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/htdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	<IfModule mod_ssl.c>
		SSLEngine off
	</IfModule>
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/htdocs>
	<IfModule sapi_apache2.c>
		php_admin_flag engine on
		php_admin_flag safe_mode on
		php_admin_value open_basedir "/home/httpd/vhosts/default/htdocs:/tmp"
	</IfModule>
	<IfModule mod_php5.c>
		php_admin_flag engine on
		php_admin_flag safe_mode on
		php_admin_value open_basedir "/home/httpd/vhosts/default/htdocs:/tmp"
	</IfModule>
	</Directory>
</VirtualHost>


<IfModule mod_ssl.c>

<VirtualHost <ip>:443 >
	ServerName default-<ip>
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

<VirtualHost <ip>:443 >
	ServerName default-<ip>
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

<VirtualHost <ip>:443 >
	ServerName default-<ip>
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

<VirtualHost <ip>:443 >
	ServerName default-<ip>
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

<VirtualHost <ip>:443 >
	ServerName default-<ip>
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

<VirtualHost <ip>:443 >
	ServerName default-<ip>
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

</IfModule>

<VirtualHost 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			>
	DocumentRoot /usr/share/psa-horde/
	Alias /horde/ /usr/share/psa-horde/
	Alias /imp/ /usr/share/psa-horde/imp/
	ServerName webmail
	ServerAlias webmail.*
	UseCanonicalName Off
	<Directory /usr/share/psa-horde>
		<IfModule sapi_apache2.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/tmp:/var/log/psa-horde:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		<IfModule mod_php5.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/tmp:/var/log/psa-horde:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		Order allow,deny
		Allow from all
	</Directory>
</VirtualHost>


<IfModule mod_ssl.c>

<VirtualHost 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			>
	DocumentRoot /usr/share/psa-horde/
	Alias /horde/ /usr/share/psa-horde/
	Alias /imp/ /usr/share/psa-horde/imp/
	ServerName webmail
	ServerAlias webmail.*
	UseCanonicalName Off
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /etc/apache2/httpd.pem
	<Directory /usr/share/psa-horde>
		<IfModule sapi_apache2.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/tmp:/var/log/psa-horde:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		<IfModule mod_php5.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/tmp:/var/log/psa-horde:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		SSLRequireSSL
		Order allow,deny
		Allow from all
	</Directory>
</VirtualHost>


</IfModule>

<VirtualHost 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			<ip>:80 
			>
	DocumentRoot /home/httpd/vhosts/default/htdocs
	ServerName lists
	ServerAlias lists.*
	UseCanonicalName Off
	ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
	Alias /icons/ /usr/lib/mailman/icons/
	Alias /pipermail/ /var/lib/mailman/archives/public/
	<Directory /var/lib/mailman/archives/>
		Options FollowSymLinks
		Order allow,deny
		Allow from all
	</Directory>
</VirtualHost>


<IfModule mod_ssl.c>

<VirtualHost 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			<ip>:443 
			>
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ServerName lists
	ServerAlias lists.*
	UseCanonicalName Off
	ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
	Alias /icons/ /usr/lib/mailman/icons/
	Alias /pipermail/ /var/lib/mailman/archives/public/
	<Directory /var/lib/mailman/archives/>
		Options FollowSymLinks
		Order allow,deny
		Allow from all
	</Directory>
</VirtualHost>


</IfModule>

Include /home/httpd/vhosts/domain1.de/conf/httpd.include

Include /home/httpd/vhosts/domain2.de/conf/httpd.include

Include /home/httpd/vhosts/domain3.de/conf/httpd.include

Include /home/httpd/vhosts/domain4.com/conf/httpd.include

Include /home/httpd/vhosts/domain5.de/conf/httpd.include

Include /home/httpd/vhosts/domain6.de/conf/httpd.include

Include /home/httpd/vhosts/domain7.de/conf/httpd.include

Include /home/httpd/vhosts/domain8.de/conf/httpd.include

Include /home/httpd/vhosts/domain9.de/conf/httpd.include

Include /home/httpd/vhosts/domain10.de/conf/httpd.include
und hier mal eine httpd.include auszug

Code: Select all

<VirtualHost <ip>:443>
	ServerName   domain1.de:443
	ServerAlias  www.domain1.de
	UseCanonicalName Off
	SuexecUserGroup         ftp_05 psacln
	ServerAdmin email
	DocumentRoot /home/httpd/vhosts/domain1.de/httpdocs
	CustomLog  /home/httpd/vhosts/domain1.de/statistics/logs/access_ssl_log plesklog
	ErrorLog     /home/httpd/vhosts/domain.de/statistics/logs/error_ssl_log
<IfModule mod_userdir.c>
	UserDir /home/httpd/vhosts/domain1.de/web_users
</IfModule>
	ScriptAlias  /cgi-bin/ /home/httpd/vhosts/domain1.de/cgi-bin/
	Alias  /plesk-stat /home/httpd/vhosts/domain1.de/statistics/
	<Location  /plesk-stat/>
		Options +Indexes
	</Location>
	<Location  /plesk-stat/logs/>
		Require valid-user
	</Location>
	Alias  /webstat /home/httpd/vhosts/domain1.de/statistics/webstat
	Alias  /webstat-ssl /home/httpd/vhosts/domain1.de/statistics/webstat-ssl
	Alias  /ftpstat /home/httpd/vhosts/domain1.de/statistics/ftpstat
	Alias  /anon_ftpstat /home/httpd/vhosts/domain1.de/statistics/anon_ftpstat
	Alias  /awstats-icon /usr/share/apache2/icons/awstats/icon
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/cert-hKUZmI
	<Directory /home/httpd/vhosts/domain1.de/httpdocs>
	<IfModule mod_perl.c>
	<Files ~ (.pl$)>
		SetHandler perl-script
		PerlHandler ModPerl::Registry
		Options ExecCGI
		allow from all
		PerlSendHeader On
	</Files>
	</IfModule>
	<IfModule sapi_apache2.c>
		php_admin_flag engine on
		php_admin_flag safe_mode on
		php_admin_value open_basedir "/home/httpd/vhosts/domain1.de/httpdocs:/tmp"
	</IfModule>
	<IfModule mod_php5.c>
		php_admin_flag engine on
		php_admin_flag safe_mode on
		php_admin_value open_basedir "/home/httpd/vhosts/domain1.de/httpdocs:/tmp"
	</IfModule>
		SSLRequireSSL
		Options +Includes +ExecCGI
	</Directory>
	<Directory "/home/httpd/vhosts/domain1.de/statistics">
		AuthType Basic
		AuthName "Domain-Statistiken"
		AuthUserFile /home/httpd/vhosts/ew-hosting.de/pd/d..httpdocs@plesk-stat
		require  valid-user
	</Directory>
	<Directory "/home/httpd/vhosts/domain1.de/httpdocs/seitencheck">
		AuthType Basic
		AuthName "Seiten Check"
		AuthUserFile /home/httpd/vhosts/domain1.de/pd/d..httpdocs@seitencheck
		require  valid-user
	</Directory>
	Alias "/error_docs" "/home/httpd/vhosts/domain1.de/error_docs"
	ErrorDocument 400 /error_docs/bad_request.html
	ErrorDocument 401 /error_docs/unauthorized.html
	ErrorDocument 403 /error_docs/forbidden.html
	ErrorDocument 404 /error_docs/not_found.html
	ErrorDocument 500 /error_docs/internal_server_error.html

Include /home/httpd/vhosts/domain1.de/conf/vhost.conf
</VirtualHost>
in der include vhost.conf sind nur die Eintragungen für suPHP vorhanden.


So sah das ganze auch af dem alten System aus und da wahren keine Warnings im System und das alte System lief ohne Probleme und ausfählle schon seit 2 Jahren

Habt ihr nun auch die Warnmeldungen oder nicht ?


Vielen Dank
Twister

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: Schwierigkeiten mit SSL nach Serverumzug

Post by dtdesign » 2007-05-30 16:52

Irre ich micht oder habe ich dein Ausschwärzen der IP eventuell misstverstanden: Hat dort jeder Host mit SSL seine eigene IP? Tatsache ist, dass die Fehlermeldung vom Indianer korrekt sind und auch kommen sollen, da sich die VHosts auf Port 443 überlappen, das sagt ja auch die Fehlermeldung!

Auf dem Root-Server den ich betreue, liegen mehrere Kundenpräsenzen, da allerdings nur 2 Kunden je SSL benötigen, haben wir dort ergo auch "nur" 2 IP-Adressen. Die restlichen laufen alle über eine bzw. die andere.

Ich würde mich an deiner Stelle auch nicht mehr sonderlich groß mit dem Problem beschäftigen, sondern es lösen. Wer SSL braucht, bekommt eine eigene IP. Eine andere Möglichkeit fällt mir jetzt leider nicht ein ;)

Gruß
dtdesign