php4 defunct [suPHP] nach update apt-get

Apache, Lighttpd, nginx, Cherokee
tischi
Posts: 215
Joined: 2003-10-26 17:57

php4 defunct [suPHP] nach update apt-get

Post by tischi » 2007-05-21 19:53

Guten Abend,

Ich hatte gestern ein Update meiner Pakete mittels apt-get vorgenommen:

Code: Select all

apt-get update
apt-get upgrade
dort wurde auch php von Version 4.3.10 auf 4.3.10-20 geupdated.
So alles lief wunderbar, keine Probleme... auch die Websiten laufen wunderbar. Heute seh ich aber in meinem graphen, dass des öfteren Zombis, vorallem bei vielen zugriffen auftauchten.
Image

Ich habe dann in der px festgestellt, dass [php4] defunct oft vorkam, aber bei jedem ps mit neuer pid...

Ich habe darauf hin mal:

Code: Select all

top -u web0 -d 1
in der konsole laufenlassen und eine website unter web0 sehr schnell hintereinader aktualisiert. jedesmal tauchte ein [php4] defunct auf.

das gleiche habe ich ann zum testen auch mit web1 gemacht, selbes spiel.

Auch die ausgabe:

Code: Select all

<?php
echo phpinfo();
?>
erzeugt jedesmal [php4] defunct....

Hat jemand eine ahnung was das sein kann?

PHP 4.3.10-20
Apache/2.0.54 (Debian GNU/Linux) mod_perl/1.999.21 Perl/v5.8.4
Debian Sarge 3.1

tischi
Posts: 215
Joined: 2003-10-26 17:57

Re: php4 defunct [suPHP] nach update apt-get

Post by tischi » 2007-05-22 20:16

könnte es am suPHP liegen?
hab irgendwo gelesen, dass suPHP nicht den Exit oder so übergibt.!!?!

tischi
Posts: 215
Joined: 2003-10-26 17:57

Re: php4 defunct [suPHP] nach update apt-get

Post by tischi » 2007-05-26 13:48

mhhh???? :idea:

tischi
Posts: 215
Joined: 2003-10-26 17:57

Re: php4 defunct [suPHP] nach update apt-get

Post by tischi » 2007-05-29 19:05

führe ich auf der bash direkt php phpfile.php aus, kommt kein defunct.