apt will php-pear und php5-cli installieren trotz php5-cgi

Apache, Lighttpd, nginx, Cherokee
top44
Posts: 9
Joined: 2007-02-07 20:02

apt will php-pear und php5-cli installieren trotz php5-cgi

Post by top44 » 2007-05-10 02:44

Hallo Leute,

ich weiß nicht ob des ein Problem darstellt.

Apt, will bei mir trotz php5-cgi, php5-cli installieren, ist das Normal ?
Wo Liegen die Unterschiede zwischen cgi und cli. ?

hier ma nen auszug :
cmp:/etc/lighttpd/conf-available# apt-get install php-pear
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
php5-cli
Suggested packages:
php5-dev php4-dev
The following NEW packages will be installed:
php-pear php5-cli
The following held packages will be changed:
php5-cli
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 2703kB of archives.
After unpacking 7561kB of additional disk space will be used.
Do you want to continue [Y/n]?
Ich fahre, Lighttp+php5-cgi als fcgi.
OS ist Debian 4.0

grüße

kase
Posts: 1031
Joined: 2002-10-14 22:56

Re: apt will php-pear und php5-cli installieren trotz php5-cgi

Post by kase » 2007-05-10 08:30

php5-cli ist die PHP-Version für die Command-Line, diese wird von php-pear benötigt. Das entsprechende Binary sollte dann unter /usr/bin/php5 zu finden sein. Das php5-cgi Binary liegt unter /usr/bin/php5-cgi und dient einem Webserver (Apache, lighty, ...) als cgi oder fcgi Binary.

top44
Posts: 9
Joined: 2007-02-07 20:02

Re: apt will php-pear und php5-cli installieren trotz php5-cgi

Post by top44 » 2007-05-10 21:45

Danke ..