RAID Platte raus --> Server hängt.

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
snowball
Posts: 218
Joined: 2004-09-15 10:14

RAID Platte raus --> Server hängt.

Post by snowball » 2007-05-03 13:52

Hallo zusammen,

ich bin grade dabei mich in meiner Testumgebung ein Bisschen mit mdadm und Software RAID 1 zu beschäftigen. Funktioniert auch ganz gut. Was ich allerdings nicht verstehe ist, das mein Server einfriert wenn ich eine Festplatte im Betrieb aus dem System ziehe. Ein Kumpel hat mir den Hinweis gegeben, das es nicht am RAID liegt, sondern am ATA Bus. Wenn ich die Platte wieder einbaue, läuft der Server dann auch ganz normal weiter.

Jetzt zu meiner Frage:
Gibt es eine Möglichkeit, eine Platte im laufenden Betrieb auszuhängen? Ich will einfach nur testen, ob das System danach weiter arbeitet.
Ich hatte an sowas wie hdparm gedacht, aber ich finde nicht den richtigen Parameter um die Platte anzuhalten geschweige denn, sie danach wieder zu starten.

Vielen Dank für Eure Hilfe.

Jochen

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: RAID Platte raus --> Server hängt.

Post by captaincrunch » 2007-05-03 14:15

(P)ATA-Platten sind grundsätzlich nicht hot-pluggable.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: RAID Platte raus --> Server hängt.

Post by snowball » 2007-05-03 14:17

CaptainCrunch wrote:(P)ATA-Platten sind grundsätzlich nicht hot-pluggable.
Danke für den Hinweis, wusste ich nicht.
Aber in meinem sind SATA-Platten drinn. Die auch nicht?

elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: RAID Platte raus --> Server hängt.

Post by elch_mg » 2007-05-03 15:08

Theoretisch ab SATA 2 möglich, praktisch unterstützen es nicht alle Controller IIRC.

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: RAID Platte raus --> Server hängt.

Post by captaincrunch » 2007-05-03 15:18

Nicht umsonst nimmt man für "echte" Server SCSI. ;)

SCNR
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: RAID Platte raus --> Server hängt.

Post by snowball » 2007-05-03 15:23

Autsch.
Das hatte ich wohl verdient :wink:

Aber mal zurück zu meinem Problem.
Ich habe mir eben mal die Mühe gemacht und auf den Lieferschein geschaut, weil es mich ein wenig gewundert hat, das die Platten an einer Backplane hängen und da steht was von Hotplugable... Ist das jetzt in Verkaufsgag??? :?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: RAID Platte raus --> Server hängt.

Post by captaincrunch » 2007-05-03 15:25

In dem Fall wären Angaben zur verwendeten Hardware sicherlich unumgänglich.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: RAID Platte raus --> Server hängt.

Post by elch_mg » 2007-05-03 15:27

CaptainCrunch wrote:Nicht umsonst nimmt man für "echte" Server SCSI. ;)

SCNR
Oder SAS, SCSI soll ja sterben ;)

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: RAID Platte raus --> Server hängt.

Post by snowball » 2007-05-03 15:50

Ich versuche mal die wenigen Infos zusammen zu fassen die ich habe.

Es ist ein Fujitsu Siemens Primergy RX100 S4
2X 250 GB SATA Platten (Western Digital)
1 GB RAM
Intel Chipsatz

An Welche Angaben dachtest du denn genau? Ich weiß grade ehrlich gesagt nicht welche Infos relevant sein könnten. Eigentlich soll es ja nur so ein besch*** Software RAID werden :(

Vielen Dank schonmal für Eure Hilfe.

Jochen

openftp
Posts: 8
Joined: 2007-04-22 19:27

Re: RAID Platte raus --> Server hängt.

Post by openftp » 2007-05-03 17:52

ruf bei FSC an und frag ob der kram hotplug-fähig ist ;)

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: RAID Platte raus --> Server hängt.

Post by snowball » 2007-05-04 12:35

So,
ich habe endlich des Rätsels Lösung. Das Zauberwort heist: ahci

Der Controller des Servers stand auf native SATA und das war der Grund, warum er nach dem Platte ziehen eingefroren ist. Nach umstellen auf ahci und laden des entsprechenden Kernel Moduls kann der Server jetzt auch Hotplugging.

Vielen Dank an Euch alle für die wertvollen Tipps in die richtige Richtung.

Cheers,

Jochen