Apache 2 meldet Fehler, brauche da mal bitte hilfe

Apache, Lighttpd, nginx, Cherokee
holly
Posts: 26
Joined: 2004-05-13 16:26
Location: HH

Apache 2 meldet Fehler, brauche da mal bitte hilfe

Post by holly » 2007-05-01 23:00

Hallo Leute,

ich habe heute versucht das mod_rewrite Modul zu aktivieren. Habe ein Rootie bei s4y mit Suse 9.3. Nach Info von s4y soll man so vorgehen:

Auf SuSE Distributionen mit apache2 muß rewrite in /etc/sysconfig/apache2 in die Variable APACHE_MODULES eingetragen werden. Nach einem Neustart mit "rcapache2 restart" ist das Modul dann geladen.

Das habe ich so gemacht und bekomme nach rcapache2 restart bekomme ich diese Meldung:

bravoxx:~ # rcapache2 restart
: command not foundhe2: line 14:
: command not foundhe2: line 30:
: command not foundhe2: line 80:
: command not foundhe2: line 109:
: command not foundhe2: line 119:
: command not foundhe2: line 135:
: command not foundhe2: line 151:
: command not foundhe2: line 168:
: command not foundhe2: line 178:
: command not foundhe2: line 187:
: command not foundhe2: line 195:
: command not foundhe2: line 225:
: command not foundhe2: line 237:
: command not foundhe2: line 247:
: command not foundhe2: line 257:
: command not foundhe2: line 265:
Warning: no MPM found. Some modules are dependant on the type of MPM.
Module "cgi" is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
" is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
Warning: no MPM found. Some modules are dependant on the type of MPM.
from APACHE_CONF_INCLUDE_FILES not found. Ignored.
Warning: no MPM found. Some modules are dependant on the type of MPM.
from APACHE_CONF_INCLUDE_FILES not found. Ignored.
httpd2-prefork: could not open document config file /srv/www/r

Dann habe ich die Zeile wieder in Urzustand gesetzt und trotzdem bekomme ich immer wieder die Meldung.

Hat da mal einer ein Rat?

Bis dann Holly

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache 2 meldet Fehler, brauche da mal bitte hilfe

Post by Joe User » 2007-05-02 08:48

Mit welchem Editor hast Du die Datei bearbeitet? Hast Du nach dem Bearbeiten der /etc/sysconfig/apache2 ein `SuSEconfig --force` ausgeführt?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

holly
Posts: 26
Joined: 2004-05-13 16:26
Location: HH

Re: Apache 2 meldet Fehler, brauche da mal bitte hilfe

Post by holly » 2007-05-02 21:56

Hallo,

nein ein SuSEConfig --force habe ich nicht durchgeführt. Habe mir das aber wieder hingefummelt. Frag mich aber nicht wie. :lol: Aber trotzdem, danke für dein Hilfsangebot...


Bis dann

Holly