Apache 1.3 Problem nach der Aktualisierung

Apache, Lighttpd, nginx, Cherokee
dmj
Posts: 8
Joined: 2005-08-31 15:53

Apache 1.3 Problem nach der Aktualisierung

Post by dmj » 2007-04-29 13:45

Ich habe gerade meinen Server aktualisiert.
Nach dem Versuch Apache (1.3) neu zu starten bekomme ich die Fehlermeldung:

Code: Select all

Configuration syntax error detected. Not reloading.

Syntax error on line 1071 of /etc/apache/httpd.conf:
Invalid command 'php_admin_value', perhaps mis-spelled or defined by a module not included in the server configuration
Daraufhin habe ich

Code: Select all

apt-get install libapache-mod-php4
ausgeführt. Danach bekomme ich die Meldung:

Code: Select all

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
  libapache-mod-php4: Hängt ab: apache-common (>= 1.3.34) aber 1.3.33-6sarge3 soll installiert werden
E: Kaputte Pakete
Kann mir bitte jemand verraten, wie ich das Problem löse ?

Übrigens zum System: VServer, Debian 3.1 und Apache 1.3

Vielen Dank im Voraus

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Apache 1.3 Problem nach der Aktualisierung

Post by Roger Wilco » 2007-04-29 13:49

Du hast den Apache httpd von Debian Sarge installiert und willst damit mod_php aus Debian Etch benutzen. Das geht nicht. Entweder alles aus Etch oder alles aus Sarge, aber keine Mischung.

Vermutlich steht irgendwo in deiner sources.list noch "stable" anstatt "oldstable" oder "sarge", so dass die neuen Pakete von Etch, das mittlerweile stable ist, installiert werden.