Postfix leitet Mail intern weiter, MX Record für Domain wird dann natürlich ignoriert

dippe
Posts: 21
Joined: 2003-07-06 11:38
Location: Reichelsheim/Odenwald

Postfix leitet Mail intern weiter, MX Record für Domain wird dann natürlich ignoriert

Post by dippe »

Hallo,

auf meinem Root Server mit SUSE 8.1 und Confixx Professional 2.x habe ich eine Domain mxdomain.tld, deren MX-Record auf einen fremden Mailserver zeigt. Das funktioniert einwandfrei, jedoch nicht, wenn eine Mail von einem Mail-Konto einer anderen Domain, die auf o.g. Server gehostet wird, an ein Mailkonto von mxdomain.tld abgeschickt wird. In diesem Falle versucht postfix, diese Mail intern zuzustellen.

Ich habe jetzt versucht, die mxdomain.tld aus der Datei Liste /etc/postfix/confixx_localDomains zu entfernen, dann mit postmap /etc/postfix/confixx_localDomains und rcpostfix reload neu zu hashen, aber das funktioniert nicht, postfix stellt immer noch intern zu. Ausserdem legt Confixx die Domain mxdomain.tld sowieso immer wieder neu in /etc/postfix/confixx_localDomains an, so dass dieser Weg eine Sackgasse ist.

Weiß jemand, ob das mit Plesk 8.1 besser funktioniert und wenn ja, wie?
Oder hat jemand einen Tipp, wie ich das mit Confixx2.x in den Griff bekomme?

Hier noch meine config:

Code: Select all

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical command_directory = 
/usr/sbin config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
default_privs = autoresp
fast_flush_domains = $relay_domains
in_flow_delay = 0
inet_interfaces = all
local_recipient_maps = $alias_maps unix:passwd.byname
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_size_limit = xxxxx
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
maps_rbl_domains = xxxxxxx.xxx xxxxxxxxxxxxx.xxx
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains = mydomain.de
masquerade_exceptions = root
message_size_limit = 20000000
mydestination = $myhostname, localhost.$mydomain, $mydomain,
smtp.$mydomain
mydomain = mydomain.de
myhostname = pxxxxxxx.pureserver.info
mynetworks_style = host
newaliases_path = /usr/sbin/sendmail
queue_directory = /var/spool/postfix
queue_minfree = 100000000
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtpd_banner = $myhostname ESMTP $mail_name smtpd_client_restrictions 
= smtpd_recipient_restrictions = permit_sasl_authenticated,
reject_unauth_destination, reject_maps_rbl
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/cacert.pem
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
virtual_maps = hash:/etc/postfix/virtual,
hash:/etc/postfix/confixx_virtualUsers,
hash:/etc/postfix/confixx_localDomains
Gruß Rainer
Top

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Postfix leitet Mail intern weiter, MX Record für Domain wird dann natürlich ignoriert

Post by flo »

Die Localdomains sind eins der Probleme von Confixx - das saubere virtual-Format von Postfix sollte das Problem von alleine lösen - Nachteil ist, daß die Dateien vorher bearbeitet werden müssen, wenn man Automatismen einsetzt.

Hintergrund waren bei mir ca. 10.000 bis 30.000 Nachrichten am Tag, die durch "Sendmail-Style virtual" erst bei der Auslieferung gebounced wurden, anstatt schon beim SMTP-Dialog, weil es die Adressen nicht gab.

Ich hab mir in Confixx-Zeiten dafür mal ein kleines Script geschrieben:

Code: Select all

#!/bin/bash -e

SOURCEVIRTUAL="/etc/postfix/confixxvirtual"
#LOCALDOMAINS="/etc/postfix/real_localdomains"
LOCALDOMAINS="/etc/postfix/confixx_localDomains"

REALVIRTUAL="/etc/postfix/maps/virtual"
POSTFIXBINDIR="/usr/sbin/"
DATESTRING=`date +"%Y%m%d"`

#
# File initialisieren
cp $REALVIRTUAL $REALVIRTUAL.old
echo "# geaendert: $DATESTRING" > $REALVIRTUAL

cat $LOCALDOMAINS | while read line
        do
        SEARCHDOMAIN=`echo $line | awk '{print $1 }'`
        echo "Suchdomain: $SEARCHDOMAIN"
        echo "$line "

        echo "$line" >> $REALVIRTUAL
        echo "postmaster@$SEARCHDOMAIN     postmaster" >> $REALVIRTUAL
        grep "$SEARCHDOMAIN" $SOURCEVIRTUAL >> $REALVIRTUAL
        echo "" >> $REALVIRTUAL

done

/usr/sbin/postmap -r $REALVIRTUAL
/etc/init.d/postfix reload
Über die Domain-Datei kannst Du steuern, welche Domains in die virtual aufgenommen werden, den localdomain-Eintrag kannst Du rausschmeißen. Bitte teste, ob das mit Deiner sehr bewährten SuSi auch funktioniert.

flo.
Top

dippe
Posts: 21
Joined: 2003-07-06 11:38
Location: Reichelsheim/Odenwald

..geht immer noch nicht

Post by dippe »

Hallo flo,

habe mittlerweise den Rootserver upgedatet auf SUSE 10.1 mit Plesk 8.2. Leider existiert das Problem hier immer noch.

Wer hat eine Idee, die zu Plesk kompatibel ist?

Gruß Rainer
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix leitet Mail intern weiter, MX Record für Domain wird dann natürlich ignoriert

Post by Roger Wilco »

Plesk -> Domains -> example.com -> E-Mail -> Disable/Deaktivieren

Dann stellt qmail die E-Mails an den korrekten MX Host zu.
Top

aubergine
RSAC
Posts: 475
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

Re: Postfix leitet Mail intern weiter, MX Record für Domain wird dann natürlich ignoriert

Post by aubergine »

Plesk verwendet qmail und nicht postfix.

Wenn du auf Hosting Setup der Domain gehst und dort das E-Mail Feature für die Domain komplett deaktivierst sodass dies dann rot angezeigt wird, sollte eine externe Zustellung möglich sein. (Jedenfalls bei mir)
Top

dippe
Posts: 21
Joined: 2003-07-06 11:38
Location: Reichelsheim/Odenwald

Re: Postfix leitet Mail intern weiter, MX Record für Domain wird dann natürlich ignoriert

Post by dippe »

:P Jawoll, so funktionert das!

Vielen Dank, ich mail euch ein Bier durch... :-D
Top

GFEMajor
Posts: 1
Joined: 2011-05-10 12:56

Re: Postfix leitet Mail intern weiter, MX Record für Domain

Post by GFEMajor »

Ich habe das gleiche Problem mit Ubuntu und Plesk 10.

Leider bringt es nichts die Emailfunktion der Domain zu deaktivieren. Es kommt immer noch die Meldung
"User unknown in virtual alias table"


Muss ich noch irgendwas neu starten oder eine konfig neu einladen, damit das geht???
Top