suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Apache, Lighttpd, nginx, Cherokee
tomotom
Posts: 330
Joined: 2006-09-22 13:37

suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by tomotom » 2007-04-25 17:51

Ich bekomme es nicht hin, dass die Probleme, die durch suhosin verursacht werden, vernünftig zu protokollieren bzw. zu orten.

suhosin.simulation ist auf on aber trotzdem gibt es Reihe von Meldungen wie:
Notice: Undefined variable: ...
welche zur Folge haben das viele Spripte nicht mehr laufen.

1. Kann man suhosin auch komplett abschlaten?
2. Ist eine Protokollierung möglich, die sagt welcher suhosin-Schalter für die Fehlermeldung verantwortlich ist und in eine separate datei logt?

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by cirox » 2007-04-25 18:45

Wenn Du die Extension als "shared" gebaut hast, dann deaktiviere sie einfach in der php.ini.

Hier ist alles beschrieben -> DOKU

Ansonsten halt wenn Du Suhosin nutzt erstmal nichts in der php.ini eintragen, also alles default lassen, und dich dann mit einzelnen Einträgen rantasten. Dabei immer wieder auf "suhosin.simulation = on" umschalten.

tomotom
Posts: 330
Joined: 2006-09-22 13:37

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by tomotom » 2007-04-25 18:59

Erledigt, sorry, danke ...
Ich hatte da etwas übersehen, display_error war auf on und das verursachte einen Reihe von Fehlern, wie es auch das Ausführen von verschiedenen Schripten verhinderte. Eigenartiger Weise laufen die scripte wenn display_error = Off ist. Ich hatte das nicht bemerkt und gedacht es läge an suhosin weil es das ist was ich geändert hatte. Nur hatte ich display_error auch auf On gesetzt.

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by dtdesign » 2007-04-25 21:23

Oh, das selbe Phänomen habe ich bei einem PHP 4.0.4 bemerkt. Kaum wurden Fehler ausgegeben, ging nichts mehr ;)

Welche Version setzt du denn ein :P

PS: display_errors sollte auf Produktivsystemen, falls nicht vom Kunde anders gewünscht, IMMER deaktiviert sein. Ein ini_set('display_errors',true) bzw. über .htaccess bewirkt Wunder ;)

Gruß
dtdesign

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by cirox » 2007-04-25 21:26

Tja, dass mit den display_errors würde ich auch gern lösen. Wenn einer weiss, wie das per .htaccess oder ini_set('display_errors',true) bei FCGI funnzt dann nur bitte her mit der Lösung.

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by dtdesign » 2007-04-25 21:52

Hallo,

ob als Servermodul, als CGI oder als FCGI. Es ändert sich nicht, die Funktion ist unabhängig davon! Bei der .htaccess geht dies über die php_admin_flag, entsprechendes findet man a) im Handbuch b) im Forum c) bei Google.

Gruß
dtdesign

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by cirox » 2007-04-25 22:07

php_admin_flag und FastCGI ? Ähm das geht doch nicht.

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by dtdesign » 2007-04-25 22:08

Ich rede ja auch von folgendem:

Code: Select all

<?php
error_reporting(E_ALL);
ini_set('display_errors', true);
?>
Und dies funktioniert auch bei FCGI, ist eine native Funktion von PHP ;)

Gruß
dtdesign

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by cirox » 2007-04-25 22:21

jo, so sollte es sein, es funktioniert bloss nicht. Aber das ist ja das eine, ich such ja vor allem ne Möglichkeit per .htaccess und das geht auch nicht.

User avatar
daemotron
Administrator
Administrator
Posts: 2635
Joined: 2004-01-21 17:44

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by daemotron » 2007-04-25 23:44

Per .htaccess kannst Du nur Dinge machen, die Du auch direkt in der Apache-Konfiguration machen könntest. Sprich: Bei FastCGI kannst Du das mal gepflegt vergessen, nur bei mod_php kannst Du über eine .htaccess Einfluss auf die PHP-Konfiguration nehmen.

Bei FastCGI kannst Du aber vor dem Spawnen der FastCGI-PHP-Prozesse die Variable PHPRC exportieren:

Code: Select all

PHPRC="/pfad/zur/ini/"   # Nur Pfad, nicht die Datei!
export PHPRC
So kannst Du jedem virtuellen Host eine eigene php.ini spendieren, so dass eine Regelung über php_admin_[flag|value] überflüssig wird.

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by cirox » 2007-04-25 23:46

ja so ist es ja auch und da ist dann das Problem mit den "vhostlern" ;), die gerne error_reporting per .htaccess einschalten wollen, weils ja im Produktivbetrieb aus ist von Grund auf. Und da es nicht geht muss man wohl doch nur die php.ini ändern. Genial wäre hier ein php.ini Editor. Aber das kann ich nicht proggen. Erst Recht in in Anbetracht der Security Problems.

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by Roger Wilco » 2007-04-26 00:07

cirox wrote:Genial wäre hier ein php.ini Editor. Aber das kann ich nicht proggen. Erst Recht in in Anbetracht der Security Problems.
http://pecl.php.net/package/htscanner

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by cirox » 2007-04-26 13:27

sieht gut aus.
    "The configuration file htscanner needs to scan for php_* directives"

tomotom
Posts: 330
Joined: 2006-09-22 13:37

Re: suhosin demo - So einstellen, dass alles läuft und "Anschläge" ins log gehen

Post by tomotom » 2007-04-28 19:09

dtdesign wrote:Oh, das selbe Phänomen habe ich bei einem PHP 4.0.4 bemerkt. Kaum wurden Fehler ausgegeben, ging nichts mehr ;)

Welche Version setzt du denn ein :P

PS: display_errors sollte auf Produktivsystemen, falls nicht vom Kunde anders gewünscht, IMMER deaktiviert sein. Ein ini_set('display_errors',true) bzw. über .htaccess bewirkt Wunder ;)

Gruß
dtdesign
php-fcgi 5.2.1
display_errors ist bei mir eigentlich auch aus, hatte es nur für Testzwecke angeschaltet und mich dann gewundert das das der Grund für nicht laufende scripte ist.