Probleme nach update auf php 5.2.1

Apache, Lighttpd, nginx, Cherokee
macwild
Posts: 4
Joined: 2007-04-21 14:17

Probleme nach update auf php 5.2.1

Post by macwild » 2007-04-23 14:00

An alles schlauen Köpfe hier im Forum!


Ich bin ein ziemliches Greenhorn und erst sehr sehr kurz mit einem Root Server zugange.

Auf diesem läuft die Suse 10.1 und php 5.1.2

war so konfiguriert von Hetzner.

Nun habe ich da Problem, das ich eine Seite laufen habe wo nicht alle php´s funktionieren.

Ich habe eine fertige Seite von einem Debian mit php 5.2.1 übernommen, da lief sie fehlerfrei. Nun meine Frage!

Was kann da falsch sein.

Ich habe versucht über Yast ein Update auf php 5.2.1 einzuspielen was mir auch gelungen ist. Zuvor den Apache auf 2.2.4 und dann php 5.2.1!!!
Alles hat auch scheinbar funktioniert. Allerdings konnte ich danache keine php mehr ausführen.

Nur weiße Seiten oder ein Angebot diese zu downloaden.


Vielleicht weiß einer von euch ja Rat!


Gruß



Mac

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: Probleme nach update auf php 5.2.1

Post by dtdesign » 2007-04-23 16:35

Du must eventuell PHP erst wieder dem Apache beibringen. Installationsanweisungen als Servermodule findest du in der PHP.net-Dokumentation. Ansonsten hilft ein Blick in das DebianHowTo, da die Schritte für die Installation von PHP als FCGI/FastCGI identisch mit SuSE ist.

Gruß
dtdesign

macwild
Posts: 4
Joined: 2007-04-21 14:17

Installation

Post by macwild » 2007-04-23 17:04

Dann mache ich mich mal auf die Suche!

macwild
Posts: 4
Joined: 2007-04-21 14:17

Re: Probleme nach update auf php 5.2.1

Post by macwild » 2007-04-23 17:09

Ein bisschen genauer hast du es nicht für mich, oder?


Denn ich will ja php nicht als fastCGI sondern als Modul!

Das war ja yuch über Yast kein Problem.

War ja alles aktualisiert. Nur wollen die php´s eben nicht!

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: Probleme nach update auf php 5.2.1

Post by cirox » 2007-04-23 22:47

Mal davon abgesehn, dass ich dir eher zu Debian raten würde, wie wärs mal mit Logs anschauen? und error_reporting in der php.ini aktivieren.

Openbasedir, include etc .. alles richtig gesetzt? Überprüf mal die Pfade in deiner php.ini.

macwild
Posts: 4
Joined: 2007-04-21 14:17

Re: Probleme nach update auf php 5.2.1

Post by macwild » 2007-04-23 23:31

Ja das klingt alles gut, plausibel und logisch.

Allerdings bin ich noch lange nicht so weit das alles zu kapieren.

Wie gesagt ich bin ja ein Anfänger.

Aber ich danke dir dennoch für deinen Hinweis und Rat!

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: Probleme nach update auf php 5.2.1

Post by dtdesign » 2007-04-24 18:54

Ich hab dir doch bereits gesagt, wie du PHP als Apache Modul einbinden kannst...
dtdesign wrote:Du must eventuell PHP erst wieder dem Apache beibringen. Installationsanweisungen als Servermodule findest du in der PHP.net-Dokumentation. (..)
Hier der exakte Link aus der Dokumentation von PHP.net [1], ab Schritt 14 wird es für dich interessant.

Gruß
dtdesign

[1] http://de.php.net/manual/de/install.unix.apache2.php