MySQL Installationsfehler

Apache, Lighttpd, nginx, Cherokee
indy0130
Posts: 23
Joined: 2005-08-27 16:08

MySQL Installationsfehler

Post by indy0130 » 2007-04-21 12:45

Hi Leute, brauche dringend Hilfe. Kriege MySQL nicht neu installiert, nachdem ich die 5.1 installieren wollte. Hier der Fehler:

Code: Select all

root@beta:/# apt-get install mysql-server
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  libdbd-mysql-perl libmysqlclient15off mysql-client-5.0 mysql-common
  mysql-server-5.0
Suggested packages:
  tinyca
The following NEW packages will be installed:
  libdbd-mysql-perl libmysqlclient15off mysql-client-5.0 mysql-common
  mysql-server mysql-server-5.0
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/34.4MB of archives.
After unpacking 89.7MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
Selecting previously deselected package mysql-common.
(Reading database ... 27500 files and directories currently installed.)
Unpacking mysql-common (from .../mysql-common_5.0.32-7etch1_all.deb) ...
Selecting previously deselected package libmysqlclient15off.
Unpacking libmysqlclient15off (from .../libmysqlclient15off_5.0.32-7etch1_i386.deb) ...
Selecting previously deselected package libdbd-mysql-perl.
Unpacking libdbd-mysql-perl (from .../libdbd-mysql-perl_3.0008-1_i386.deb) ...
Selecting previously deselected package mysql-client-5.0.
Unpacking mysql-client-5.0 (from .../mysql-client-5.0_5.0.32-7etch1_i386.deb) ...
Setting up mysql-common (5.0.32-7etch1) ...
(Reading database ... 27598 files and directories currently installed.)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.0.32-7etch1_i386.deb) ...
Aborting downgrade from (at least) 5.1 to 5.0.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.0_5.0.32-7etch1_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Selecting previously deselected package mysql-server.
Unpacking mysql-server (from .../mysql-server_5.0.32-7etch1_all.deb) ...
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-server-5.0_5.0.32-7etch1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Sobald ich die 5.1 manuell per dpkg wieder installiert habe, kommt, dass die Datei mysqld.sock nicht gefunden werden kann! Hiiiiiilfe!

dtdesign
Posts: 391
Joined: 2006-09-05 21:12
Location: Berlin

Re: MySQL Installationsfehler

Post by dtdesign » 2007-04-21 14:16

Deinstallier den mal vollständig:

Code: Select all

$> apt-get remove --purge mysql-server-5.0
$> apt-get clean
$> apt-get install mysql-server-5.0
Vielleicht schafft das Abhilfe. Eventuell mal auf die Dependencies achten (Abhängigkeiten von anderen Paketen).

Gruß
dtdesign