mails an webmaster@gui

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
schnere
Posts: 64
Joined: 2006-08-15 17:28

mails an webmaster@gui

Post by schnere » 2007-04-19 16:36

Hi!

Aus irgendeinem Grund bekomme ich in /var/log/mail.log alle paar Minuten folgende Meldung:

Code: Select all

Apr 19 16:11:41 server01 postfix/qmgr[27176]: 15884524E30: to=<webmaster@gui>, relay=none, delay=58648, delays=58618/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Was kann das sein?

MfG schnere

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: mails an webmaster@gui

Post by Roger Wilco » 2007-04-19 18:13

Da liegt eine E-Mail an einen ungültigen Empfänger (webmaster@gui) in eurer Mail-Queue (`mailq`). Die solltest du löschen, sobald du herausgefunden hast, wie sie überhaupt da reingekommen ist.

-> Logs und `man postsuper` lesen.

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-19 18:51

Zuerst hab ich mir gedacht, dass das vielleicht von der php.ini kommt:
Maybe change the sender of mails sent by the control panel: in both php.ini from "webmaster@gui" to something suitable... restart apache2
hab ich von hier:
http://www.isp-control.net/ispcp/wiki/u ... stallation

Aber das is es anscheinend nicht.
Hab schon einige configs danach abgesucht, aber nichts gefunden...

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-21 22:51

Ok, habs gefunden.
Das Problem war, dass ich in /etc nichts finden konnte, weil es in einer php.ini in /var/www/fcgi war.

hab jetzt webmaster@gui durch meine Mail-Adresse ersetzt.

Dafür habe ich jetzt folgendes Problem:

Code: Select all

ping gui
zeigt mir leider ein Ergebnis, es gibt eine Domain zu "gui".
Da bei jedem Einloggen auf mein CP anscheinend mehrere Mails an webmaster@gui gesendet wurden habe ich nun das Problem, dass ich nun mit dem Server auf einer Greylist stehe.

Meine Frage:
Werde ich automatisch nach einiger Zeit wieder von Greylists gelöscht?
Das Problem ist nämlich, dass nicht einmal mehr Mails an GMX senden kann.
Was muss ich tun, damit ich so schnell wie möglich von greylists entfernt werde?

MfG schnere

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: mails an webmaster@gui

Post by adjustman » 2007-04-22 02:57

schnere wrote:.. anscheinend mehrere Mails an webmaster@gui gesendet wurden ..
wohin? was denkst du, wo die hingehen?
schnere wrote:Was muss ich tun, damit ich so schnell wie möglich von greylists entfernt werde?
welches Greylisting denn? Dein eigenes?
P.S. man wird nicht gelöscht aus dem Greylisting, darum heisst es ja
"Grey" listing ;)

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 09:35

Code: Select all

ping gui
PING www.goowy.com (209.126.247.210) 56(84) bytes of data.
Auszug aus den Logs (mail.log):

Code: Select all

Apr 22 09:00:06 server01 postfix/qmgr[2448]: 3731A524E11: from=<>, size=2568, nrcpt=1 (queue active)
Apr 22 09:00:06 server01 postfix/qmgr[2448]: 01C87524E17: from=<>, size=2596, nrcpt=1 (queue active)
Apr 22 09:00:06 server01 postfix/qmgr[2448]: EDD05524E47: from=<>, size=2706, nrcpt=1 (queue active)
Apr 22 09:00:06 server01 postfix/qmgr[2448]: E80CE524E49: from=<>, size=2601, nrcpt=1 (queue active)
Apr 22 09:00:06 server01 postfix/qmgr[2448]: 1250D524E48: from=<>, size=2707, nrcpt=1 (queue active)
Apr 22 09:00:36 server01 postfix/smtp[20548]: connect to gui[209.126.247.210]: Connection timed out (port 25)
Apr 22 09:00:36 server01 postfix/smtp[20545]: connect to gui[209.126.247.210]: Connection timed out (port 25)
Apr 22 09:00:36 server01 postfix/smtp[20546]: connect to gui[209.126.247.210]: Connection timed out (port 25)
Apr 22 09:00:36 server01 postfix/smtp[20547]: connect to gui[209.126.247.210]: Connection timed out (port 25)
Apr 22 09:00:36 server01 postfix/smtp[20549]: connect to gui[209.126.247.210]: Connection timed out (port 25)
Apr 22 09:00:36 server01 postfix/smtp[20545]: BC86E524E02: to=<webmaster@gui>, relay=none, delay=293600, delays=293569/0.04/30/0, dsn=4.4.1, status=deferred (connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/smtp[20548]: 80E0A524E03: to=<webmaster@gui>, relay=none, delay=293367, delays=293337/0.03/30/0, dsn=4.4.1, status=deferred (connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/smtp[20546]: BBA86524E01: to=<webmaster@gui>, relay=none, delay=293367, delays=293336/0.03/30/0, dsn=4.4.1, status=deferred (connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/smtp[20549]: 8B55A524E12: to=<webmaster@gui>, relay=none, delay=292948, delays=292918/0.03/30/0, dsn=4.4.1, status=deferred (connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/smtp[20547]: BAE97524E25: to=<webmaster@gui>, relay=none, delay=292309, delays=292278/0.03/30/0, dsn=4.4.1, status=deferred (connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 8CDC1524DFE: to=<webmaster@gui>, relay=none, delay=293593, delays=293563/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 77526524E05: to=<webmaster@gui>, relay=none, delay=293367, delays=293337/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 77D91524E1D: to=<webmaster@gui>, relay=none, delay=292455, delays=292425/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 70ECF524E1C: to=<webmaster@gui>, relay=none, delay=292455, delays=292425/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: C6E38524E14: to=<webmaster@gui>, relay=none, delay=292990, delays=292959/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: C36B7524E06: to=<webmaster@gui>, relay=none, delay=293367, delays=293336/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 42D46524E1E: to=<webmaster@gui>, relay=none, delay=292313, delays=292283/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 45C13524E4B: to=<webmaster@gui>, relay=none, delay=174375, delays=174345/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 29F52524E18: to=<webmaster@gui>, relay=none, delay=292456, delays=292425/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: 2764F524E1F: to=<webmaster@gui>, relay=none, delay=292314, delays=292283/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Apr 22 09:00:36 server01 postfix/qmgr[2448]: DD100524E1B: to=<webmaster@gui>, relay=none, delay=292314, delays=292283/30/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to gui[209.126.247.210]: Connection timed out)
Und ich dachte, es wäre weg, aber nichts da...
Ich habe in /etc und /var/www/fcgi alles mit "webmaster" gesucht, aber nichts weiter gefunden. Wo kann das denn noch sein?


Ok, das mit dem Greylisting war vielleicht ein falscher Gedanke.
Ich weiß schon, dass eine Mail innerhalb von 15 Minuten 2 mal gesendet werden muss, damit sie ein mal angenommen wird...

Aber trotzdem verstehe ich nicht, warum ich an gmx erst wieder mails schreiben konnte, nachdem ich mich selbst auf die Whitelist bei GMX gesetzt habe...
This is the mail system at host server01.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<ich@gmx.at>: host mx0.gmx.net[213.165.64.100] said: 550-5.7.1 {mx066}
Sorry, your helo has been denied. 550 5.7.1 (
http://portal.gmx.net/serverrules ) (in reply to RCPT TO command)



Reporting-MTA: dns; server01
X-Postfix-Queue-ID: 1C40D524E41
X-Postfix-Sender: rfc822; ich@server01
Arrival-Date: Sat, 21 Apr 2007 22:42:27 +0200 (CEST)

Final-Recipient: rfc822; ich@gmx.at
Original-Recipient: rfc822;ich@gmx.at
Action: failed
Status: 5.7.1
Remote-MTA: dns; mx0.gmx.net
Diagnostic-Code: smtp; 550-5.7.1 {mx066} Sorry, your helo has been denied. 550
5.7.1 ( http://portal.gmx.net/serverrules )

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: mails an webmaster@gui

Post by adjustman » 2007-04-22 14:15

schnere wrote:Diagnostic-Code: smtp; 550-5.7.1 {mx066} Sorry, your helo has been denied. 550
das ist doch eindeutig. :wink:

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 14:52

Ja, das hab ich schon gemerkt, aber es stellt sich die Frage: wieso?
Ich hab ja schließlich keinen Spam an gmx geschickt?
Ich hab nur mails an webmaster@gui in den logs und die wurden von haus aus denied...

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: mails an webmaster@gui

Post by adjustman » 2007-04-22 14:56

schnere wrote:Ja, das hab ich schon gemerkt, aber es stellt sich die Frage: wieso?
weil dein HELO falsch ist wird es laut RFC abgewiesen

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 15:38

Aha, und was muss ich machen, damit ich ein richtiges Helo bekomme?
Woran liegt es, dass es falsch ist?
Ich hatte den Mailserver doch vorher mit der gleichen Config laufen, da gabs dieses Problem nicht....

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: mails an webmaster@gui

Post by adjustman » 2007-04-22 15:45

schnere wrote:Aha, und was muss ich machen, damit ich ein richtiges Helo bekomme?
postconf -n und master.cf OHNE Kommentare zeigen
doch vorher mit der gleichen Config laufen, da gabs dieses Problem nicht....
was erfahrungsgemäß zu bezweifeln wäre

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 15:58

postconf -n

Code: Select all

alias_database = hash:/etc/aliases
append_at_myorigin = yes
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
inet_interfaces = all
local_destination_recipient_limit = 1
local_recipient_maps = unix:passwd.byname $alias_database
local_transport = local
mail_spool_directory = /var/mail
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = $myhostname, $mydomain
mydomain = bluevisiontec.local
myhostname = bluevisiontec
mynetworks_style = host
myorigin = $mydomain
setgid_group = postdrop
smtpd_banner = $myhostname ISPCP 1.0 Priamos Managed ESMTP 1.0.0 RC2 OMEGA
smtpd_recipient_restrictions = permit_mynetworks,                               permit_sasl_authenticated,                               reject_unauth_destination                               check_policy_service inet:127.0.0.1:60000
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = permit_mynetworks,                               permit_sasl_authenticated,                               reject_unauth_destination
transport_maps = hash:/etc/postfix/ispcp/transport
virtual_alias_maps = hash:/etc/postfix/ispcp/aliases
virtual_gid_maps = static:8
virtual_mailbox_base = /var/mail/virtual
virtual_mailbox_domains = hash:/etc/postfix/ispcp/domains
virtual_mailbox_limit = 0
virtual_mailbox_maps = hash:/etc/postfix/ispcp/mailboxes
virtual_minimum_uid = 1000
virtual_transport = virtual
virtual_uid_maps = static:1000
master.cf

Code: Select all

smtp      inet  n       -       -       -       -       smtpd
587       inet  n       -       -       -       -       smtpd
   -o smtpd_client_restrictions=permit_sasl_authenticated,reject_unauth_destination
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       -       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
amavis    unix  -       -       n       -       2       smtp
   -o smtp_data_done_timeout=1200
   -o smtp_send_xforward_command=yes
   -o disable_dns_lookups=yes

localhost:10025 inet  n -       n       -      -        smtpd
   -o content_filter=
   -o local_recipient_maps=
   -o relay_recipient_maps=
   -o smtpd_restriction_classes=
   -o smtpd_client_restrictions=
   -o smtpd_helo_restrictions=
   -o smtpd_sender_restrictions=
   -o smtpd_recipient_restrictions=permit_mynetworks,reject
   -o smtpd_override_options=no_address_mappings
   -o mynetworks=127.0.0.0/8
   -o strict_rfc821_envelopes=yes
ispcp-arpl unix  -      n       n       -       -       pipe
  flags=O user=vmail argv=/var/www/ispcp/engine/messager/ispcp-arpl-msgr
smtps     inet  n       -       -       -       -       smtpd
   -o smtpd_tls_wrappermode=yes
   -o smtpd_sasl_auth_enable=yes
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
old-cyrus unix  -       n       n       -       -       pipe
  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
cyrus     unix  -       n       n       -       -       pipe
  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
in /etc/hostname stand anscheinend bluevisiontec.com, hab das jetzt auf bluevisiontec abgeändert.

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: mails an webmaster@gui

Post by adjustman » 2007-04-22 16:22

ja, aber oben steht bluevisiontec.local
Das ist kein FQDN

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 16:57

ich habs mit bluevisiontec.com auch schon probiert, aber da geht anscheinend gar nichts mehr.

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 17:14

Wie ich das sehe, wird ein helo gesendet, überprüft ob das mit meiner mail-adresse übereinstimmt, damit ich keine mails unter fremdem namen versenden kann?!

Code: Select all

myhostname = bluevisiontec
ist ja in Ordnung

Code: Select all

mydomain = bluevisiontec.local
soll ich jetzt nochmal auf bluevisiontec.com ändern?

Aber dann bleibt noch die Fragen, wenn mein Kunde über seine Domain zB seinedomain.at eine Mail versendet, stimmt der helo dann auch überein?

schnere
Posts: 64
Joined: 2006-08-15 17:28

Re: mails an webmaster@gui

Post by schnere » 2007-04-22 17:27

Ok, den hostname in /etc/hostname musste ich wieder auf bluevisiontec.com setzten, da sonst proftp nicht mehr startet.

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: mails an webmaster@gui

Post by adjustman » 2007-04-22 17:42

schnere wrote:Ok, den hostname in /etc/hostname musste ich wieder auf bluevisiontec.com setzten, da sonst proftp nicht mehr startet.
hast pm