courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

Hello
Plötzlich und über Nacht nimmt mein Server keine Mails mehr von außen an.
Lokale Mails werden aber komischerweiser zugestellt. Wenn ich über die Shell (lokale) eine Mail abschicke kommt diese auch an. Nur wenn ich von einem fremden Server eine Mail versende, kommt diese nicht an.

courier-imap restart meckert nicht

Logfiles scheinen auch ok zu sein. Woran erkenne dort evtl. Ungenauigkeiten?



(SuSE 9.1/Plesk 7.5/1&1)
Last edited by betrazivis on 2007-04-13 13:02, edited 1 time in total.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by Roger Wilco »

Was steht in den Logs deines MTA?
Top

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

Roger Wilco wrote:Was steht in den Logs deines MTA?
ISt vielleicht etwas blöd, die Frage, aber wo versteckt der MTA denn seine logs, falls er überhaput gesondert welche schreibt.
Ich habe hier nur

/var/log/mail.err
/var/log/mail.warn
/var/log/mail.info

und da scheint alles i.O. zu sen. Soweit ich das beurteilen kann.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by Roger Wilco »

/usr/local/psa/var/log/
Top

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

Roger Wilco wrote:/usr/local/psa/var/log/
ok, vielen Dank. Auch hier kann ich in den Logfiles nichts finden was daruf hinweist, dasss die Mail nicht ankommen. Womöglich kommen diese gar nicht erst soweit.


keiner Auzug aus /usr/local/psa/var/log/maillog

Code: Select all

Apr 13 12:49:40 p15192936 pop3d: IMAP connect from @ [217.87.*.*]INFO: LOGIN, user=support, ip=[217.87.*.*]
Apr 13 12:49:40 p15192936 pop3d: 1176461380.577617 LOGOUT, user=support, ip=[217.87.*.*], top=0, retr=0, time=0, rcvd=12, sent=39, maildir=/var/qmail/mailnames/*.de/support/Maildir
Das ist bis auf die qmail-Einträge alles. Und SMTP funktioniert ja.
Wenn ich das richtig verstehe ist das auch nur die Abfrage des Postfachs.

Ehrlich gesagt, bin ich kurz davor zu verzweifeln. :cry: :cry:
Top

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by kenzo »

Das ist bis auf die qmail-Einträge alles. Und SMTP funktioniert ja.
Bist du da sicher?
Plötzlich und über Nacht nimmt mein Server keine Mails mehr von außen an.
Der Zusammenhang will sich nicht erschließen - du hast ein Problem mit deinem Plesk-Geraffel, nicht mit IMAP.
Top

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

kenzo wrote:
Das ist bis auf die qmail-Einträge alles. Und SMTP funktioniert ja.
Bist du da sicher?
Plötzlich und über Nacht nimmt mein Server keine Mails mehr von außen an.
Der Zusammenhang will sich nicht erschließen - du hast ein Problem mit deinem Plesk-Geraffel, nicht mit IMAP.
Ja, Ich denke schon, denn Mail kann ich ja verschicken.

Und ja, ich kann mir auch vorstellen dass es an dem PLESK-Geraffel liegt. Leider lässt es sich auch für mich nicht erschließen, was da los sein soll.
Kein Watchdog, kein Mecker, nichts...

Ich bin ratlos...
Top

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

Habe gerade auch endlich eine Mail zurück bekommen.
Mit dieser Meldung:

Code: Select all

This message was created automatically by mail delivery software.

A message that you sent has not yet been delivered to one or more of
its recipients after 25 hours.

The message has not yet been delivered to the following addresses:

  <mail@***********.de>

host ***********.de[212.227.*.*]:
connection to mail exchanger failed

Wie bekomee ich den MTA wieder zum Laufen? Oder woran kann ich feststellen, dass dieser gar nicht läuft. Oder zumindest nicht richtig läuft?
Top

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

betrazivis wrote:Hello
Plötzlich und über Nacht nimmt mein Server keine Mails mehr von außen an.
Lokale Mails werden aber komischerweiser zugestellt. Wenn ich über die Shell eine Mail abschicke, kommt diese auch an. Nur wenn ich von einem fremden Server eine Mail versende, kommt diese nicht an.

courier-imap restart meckert nicht

Logfiles scheinen auch ok zu sein. Woran erkenne dort evtl. Ungenauigkeiten?



(SuSE 9.1/Plesk 7.5/1&1)
Top

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by flo »

Wenn Dein SMTP nach außen lauscht (netstat), spiel doch einmal einen manuellen SMTP-Dialog durch (telnet host 25) - dann solltest Du wissen, wo abgebrochen wird - die Fehlermeldung oben sieht allerdings eher danach aus, als ob smtp nicht nach außen verfügbar ist - da kannst Du den Courier minütlich per Cron starten und es ändert sich nichts.
Top

betrazivis
Posts: 32
Joined: 2006-06-01 11:10

Re: courier-imap nimmt keine Mails mehr an (SuSE 9.1/Plesk 7.5/1&1)

Post by betrazivis »

flo wrote:Wenn Dein SMTP nach außen lauscht (netstat), spiel doch einmal einen manuellen SMTP-Dialog durch (telnet host 25) - dann solltest Du wissen, wo abgebrochen wird - die Fehlermeldung oben sieht allerdings eher danach aus, als ob smtp nicht nach außen verfügbar ist - da kannst Du den Courier minütlich per Cron starten und es ändert sich nichts.
Ich bekomme hier gerade (Windows mit Putty) keine Telnet Verbindung auf dem entprechenden Host zustande(Connection refused). Ist da evt. ein Problem mit dem Port? Sollte ich mich per Telnet nicht einloggen können?
Top