Debian etch ist nun stable

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
cronet
Posts: 83
Joined: 2003-07-21 13:37
Location: Augsburg

Debian etch ist nun stable

Post by cronet » 2007-04-10 17:07


lord_pinhead
RSAC
Posts: 830
Joined: 2004-04-26 15:57

Re: Debian etch ist nun stable

Post by lord_pinhead » 2007-04-10 18:51

Hat schon jemand ein Update auf Etch gemacht? Ich wollte es ende der Woche in Angriff nehmen, dann sollte der Ansturm auf die Server etwas abgeklungen sein.

User avatar
nyxus
RSAC
Posts: 697
Joined: 2002-09-13 08:41
Location: Lübeck

Re: Debian etch ist nun stable

Post by nyxus » 2007-04-10 20:04

Heute habe ich einen Server beim Kunden aktualisiert. Keine nennenswerten Probleme. Auch der Download der Pakete lief zügig vom zweiten Debian FTP-Server.

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Debian etch ist nun stable

Post by EdRoxter » 2007-04-10 20:39

Gibt's bereits irgendwelche bekannten Probleme mit backported-Packages? Ich hab da so einige drauf und für etch ist ja beileibe noch nicht alles portiert.

cronet
Posts: 83
Joined: 2003-07-21 13:37
Location: Augsburg

Re: Debian etch ist nun stable

Post by cronet » 2007-04-10 21:46

Ich werde mir mit dem Updaten sicher noch 1-2 Monate Zeit lassen (zumindest mit dem Produktivsystem).

Ich schätze mal nicht dass es grossartig zu Problemen kommt. Hat beim letzten mal (auf sarge) auch schon ziemlich reibungslos geklappt.

Viele Grüße

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Debian etch ist nun stable

Post by EdRoxter » 2007-04-10 22:09

Klingt nach einem Plan... Bis dahin sollten die meisten Sachen bei den backports auch für etch verfügbar sein.

lord_pinhead
RSAC
Posts: 830
Joined: 2004-04-26 15:57

Re: Debian etch ist nun stable

Post by lord_pinhead » 2007-04-11 01:56

Da ich demnächst ein SCSI Controller Tausch mache, werde ich wohl oder übel neu installieren müssen. Mit den Produktiv Systemen werde ich aber nächste Woche anfangen. Wenn es also genauso reibungslos läuft wie von Woody->Sarge, dann dürfte das innerhalb von ein paar Stunden komplett sein. Ich liebe Debian, das Updaten auf ein neues System ist immer so schön einfach :)

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Debian etch ist nun stable

Post by sledge0303 » 2007-04-11 11:42

Ich hab lokal ein update von Sarge --> Etch durchgeführt. Beim OpenLDAP gab es danach Probleme, sind aber inzwischen gefixt.

lambras
RSAC
Posts: 90
Joined: 2002-05-29 16:35
Location: Frankfurt am Main

Re: Debian etch ist nun stable

Post by lambras » 2007-04-11 16:29

Hatte eine Menge backports von dotdeb.org (php5, mysql5) und backports.org (neueres postfix) drauf, lief alles problemlos.

Einzig mein cacti wollte nicht mehr, das lag an einem nicht-funktionierenden rrdtool. Nachdem ich rrdtool manuell kompiliert hatte, gings problemlos.

Achja, wer noch nicht auf Apache2 umgesteiegen ist, hat jetzt nochmal eine gute Gelegenheit. :)

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Debian etch ist nun stable

Post by flo » 2007-04-11 16:55

Ich hab heute morgen geflucht - wput 6 aus Etch bricht ab, wenn er auf den Strato-Backup-Server soll - geht von jedem anderen Rootie, geht auch ins private Home per FTP, aber beim Backup-Server brach er ab - eine selber kompilierte Variante ging dann.

*grr*

flo.

lord_pinhead
RSAC
Posts: 830
Joined: 2004-04-26 15:57

Re: Debian etch ist nun stable

Post by lord_pinhead » 2007-04-11 20:14

@LamBras
Nein danke, Lighttpd ist mir liebe ;)

Und auf den Produktivkisten würde ich doch gerne noch auf 1.3 bleiben, in Etch ist 1.3.34, was noch einigermaßen neu ist (aktuell 1.3.37 von 2006). Ist mir immernoch lieber als auf Version 2.2.x zu gehen und dann Probleme zu haben. Der Anlass ist aber mal gut einige Pakete die noch so rumschwirren auf den neusten Stand zu bringen, z.b. nmap oder mod_security

Ich würde sogar Lighttpd auf den Produktivkisten verwenden, wenn ich da keine Probleme mit Syscp hätte. Wäre Traumhaft wenn die Syscp Jungs sich mal dem kleinen HTTPD annehmen würden :)

@Flo
Frag mich mal, ich hab jede menge Sachen die gegen alte libc/glibc gelinkt sind und nicht mehr laufen werden. Wird kein Spaß mein ganzes Zeug neu zu übersetzen :(

time-walker
Posts: 48
Joined: 2006-02-15 14:17
Location: Osna

Re: Debian etch ist nun stable

Post by time-walker » 2007-04-12 09:06

Hey, hab gestern abend auch ein upgrade gemacht auf etch stable,
hab einen server von Server4you.
Nach paar anfangsschwierigkeiten mit aptitude wars dann doch erfolgreich.

Hab danach erst mal ein Neustart gemacht, naja dann war der server nicht mehr erreichbar.

Der hat auch bei dem upgrade meinen selbst compimierten Kernel entfernt.
hab dann den alten genommen.

Nun will der nicht mehr hochfahren, zur zeit befindet der sich im Rettungssystem, kann aber keine fehler finden.
In den logs von dmesg sieht steht auch nicht ungewöhnliches drine.

Code: Select all

Linux version 2.6.14-2-k7-smp (Debian 2.6.14-2bpo1) (nobse@debian.org) (gcc version 3.3.5 (Debian 1:3.3.5-13)) #1 SMP Tue Nov 15 00:28:07 CET 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009e000 (usable)
 BIOS-e820: 000000000009e000 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000003dee0000 (usable)
 BIOS-e820: 000000003dee0000 - 000000003deef000 (ACPI data)
 BIOS-e820: 000000003deef000 - 000000003df00000 (ACPI NVS)
 BIOS-e820: 000000003df00000 - 0000000040000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000fff00000 - 0000000100000000 (reserved)
94MB HIGHMEM available.
896MB LOWMEM available.
found SMP MP-table at 000f73b0
On node 0 totalpages: 253664
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 225280 pages, LIFO batch:31
  HighMem zone: 24288 pages, LIFO batch:7
DMI present.
ACPI: RSDP (v002 PTLTD                                 ) @ 0x000f7350
ACPI: XSDT (v001 PTLTD  	 XSDT   0x00050000  LTP 0x00000000) @ 0x3deeb9d6
ACPI: FADT (v003 FSC             0x00050000      0x000f4240) @ 0x3deeba96
ACPI: SSDT (v001 PTLTD  POWERNOW 0x00050000  LTP 0x00000001) @ 0x3deeee93
ACPI: MADT (v001 PTLTD  	 APIC   0x00050000  LTP 0x00000000) @ 0x3deeef48
ACPI: MCFG (v001 PTLTD    MCFG   0x00050000  LTP 0x00000000) @ 0x3deeef98
ACPI: BOOT (v001 PTLTD  $SBFTBL$ 0x00050000  LTP 0x00000001) @ 0x3deeefd8
ACPI: DSDT (v001 FSC    D2030    0x00050000 MSFT 0x02000002) @ 0x00000000
ACPI: PM-Timer IO Port: 0xf008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:7 APIC version 16
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
Using ACPI for processor (LAPIC) configuration information
Intel MultiProcessor Specification v1.1
    Virtual Wire compatibility mode.
OEM ID: FSC      Product ID: SIS761GX+965 APIC at: 0xFEE00000
I/O APIC #1 Version 20 at 0xFEC00000.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Processors: 1
Allocating PCI resources starting at 50000000 (gap: 40000000:bec00000)
Built 1 zonelists
Kernel command line: root=/dev/md1 ro acpi=ht noapic 
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 65536 bytes)
Detected 1799.996 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 1000820k/1014656k available (1835k kernel code, 13140k reserved, 567k data, 208k init, 97152k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3601.39 BogoMIPS (lpj=1800696)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 078bfbff e3d3fbff 00000000 00000000 00000001 00000000 00000001
CPU: After vendor identify, caps: 078bfbff e3d3fbff 00000000 00000000 00000001 00000000 00000001
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
CPU: After all inits, caps: 078bfbff e3d3fbff 00000000 00000010 00000001 00000000 00000001
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
mtrr: v2.0 (20020519)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
CPU0: AMD Opteron(tm) Processor 144 stepping 01
Total of 1 processors activated (3601.39 BogoMIPS).
Brought up 1 CPUs
checking if image is initramfs... it is
softlockup thread 0 started up.
Freeing initrd memory: 1201k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfd8a3, last bus=3
PCI: Using MMCONFIG
ACPI: Subsystem revision 20050902
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI: disabled
PnPBIOS: Scanning system for PnP BIOS support...
PnPBIOS: Found PnP BIOS installation structure at 0xc00f7380
PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0x9f4a, dseg 0x400
PnPBIOS: 15 nodes reported by PnP BIOS; 15 recorded by driver
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 0000:00:02.5
Boot video device is 0000:01:00.0
PCI: Using IRQ router SIS [1039/0965] at 0000:00:02.0
PCI: IRQ 0 for device 0000:00:02.5 doesn't match PIRQ mask - try pci=usepirqmask
PCI: Found IRQ 11 for device 0000:00:02.5
pnp: 00:00: ioport range 0x800-0x82f has been reserved
pnp: 00:00: ioport range 0xf200-0xf27f has been reserved
pnp: 00:00: ioport range 0xf280-0xf2ff has been reserved
pnp: 00:00: ioport range 0xfe00-0xfe00 has been reserved
pnp: 00:0b: ioport range 0x480-0x48f has been reserved
pnp: 00:0b: ioport range 0x4d0-0x4d1 has been reserved
pnp: 00:0b: ioport range 0xf000-0xf0be has been reserved
pnp: 00:0b: ioport range 0xf0d0-0xf10f has been reserved
PCI: Ignore bogus resource 6 [0:0] of 0000:01:00.0
PCI: Bridge: 0000:00:01.0
  IO window: 2000-2fff
  MEM window: fa100000-fa1fffff
  PREFETCH window: f0000000-f7ffffff
PCI: Bridge: 0000:00:06.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1f.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Setting latency timer of device 0000:00:06.0 to 64
PCI: Setting latency timer of device 0000:00:1f.0 to 64
Simple Boot Flag at 0x69 set to 0x1
audit: initializing netlink socket (disabled)
audit(1176316867.755:1): initialized
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
PCI: Setting latency timer of device 0000:00:06.0 to 64
pcie_portdrv_probe->Dev[000a:1039] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
Allocate Port Service[pcie00]
Allocate Port Service[pcie01]
Allocate Port Service[pcie03]
PCI: Setting latency timer of device 0000:00:1f.0 to 64
pcie_portdrv_probe->Dev[0004:1039] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
Allocate Port Service[pcie00]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
PNP: PS/2 Controller [PNP0303] at 0x60,0x64 irq 1
PNP: PS/2 controller doesn't have AUX irq; using default 12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
TCP bic registered
NET: Registered protocol family 8
NET: Registered protocol family 20
Using IPI Shortcut mode
Freeing unused kernel memory: 208k freed
mice: PS/2 mouse device common for all mice
SCSI subsystem initialized
libata version 1.12 loaded.
PCI: Found IRQ 9 for device 0000:00:05.0
sata_sis: Detected SiS 182 chipset
ata1: SATA max UDMA/133 cmd 0x14B0 ctl 0x14A6 bmdma 0x1490 irq 9
ata2: SATA max UDMA/133 cmd 0x14A8 ctl 0x14A2 bmdma 0x1498 irq 9
input: AT Translated Set 2 keyboard on isa0060/serio0
ata1: dev 0 cfg 49:2f00 82:7c6b 83:7f69 84:4773 85:7c69 86:3e01 87:4763 88:407f
ata1: dev 0 ATA, max UDMA/133, 160086528 sectors: lba48
ata1: dev 0 configured for UDMA/133
scsi0 : sata_sis
ata2: dev 0 cfg 49:2f00 82:7c6b 83:7f09 84:4003 85:7c69 86:3e01 87:4003 88:007f
ata2: dev 0 ATA, max UDMA/133, 156312576 sectors: lba48
ata2: dev 0 configured for UDMA/133
scsi1 : sata_sis
  Vendor: ATA       Model: Maxtor 6V080E0    Rev: VA11
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: ATA       Model: Maxtor 6Y080M0    Rev: YAR5
  Type:   Direct-Access                      ANSI SCSI revision: 05
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SCSI device sda: 160086528 512-byte hdwr sectors (81964 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 160086528 512-byte hdwr sectors (81964 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sdb: 156312576 512-byte hdwr sectors (80032 MB)
SCSI device sdb: drive cache: write back
SCSI device sdb: 156312576 512-byte hdwr sectors (80032 MB)
SCSI device sdb: drive cache: write back
 sdb: sdb1 sdb2 sdb3
Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0
md: md driver 0.90.2 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 3.39
md: raid1 personality registered as nr 3
md: md1 stopped.
md: bind<sda3>
md: bind<sdb3>
raid1: raid set md1 active with 2 out of 2 mirrors
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: md1: orphan cleanup on readonly fs
ext3_orphan_cleanup: deleting unreferenced inode 6211014
ext3_orphan_cleanup: deleting unreferenced inode 6204978
ext3_orphan_cleanup: deleting unreferenced inode 8798270
ext3_orphan_cleanup: deleting unreferenced inode 6750309
ext3_orphan_cleanup: deleting unreferenced inode 6750476
ext3_orphan_cleanup: deleting unreferenced inode 6750311
ext3_orphan_cleanup: deleting unreferenced inode 6750387
ext3_orphan_cleanup: deleting unreferenced inode 6750377
ext3_orphan_cleanup: deleting unreferenced inode 6750376
ext3_orphan_cleanup: deleting unreferenced inode 6750374
ext3_orphan_cleanup: deleting unreferenced inode 6750371
ext3_orphan_cleanup: deleting unreferenced inode 6750365
ext3_orphan_cleanup: deleting unreferenced inode 6750316
ext3_orphan_cleanup: deleting unreferenced inode 6196511
ext3_orphan_cleanup: deleting unreferenced inode 3540061
ext3_orphan_cleanup: deleting unreferenced inode 6751685
ext3_orphan_cleanup: deleting unreferenced inode 6751710
ext3_orphan_cleanup: deleting unreferenced inode 6751712
ext3_orphan_cleanup: deleting unreferenced inode 6751716
ext3_orphan_cleanup: deleting unreferenced inode 6751718
ext3_orphan_cleanup: deleting unreferenced inode 6751720
ext3_orphan_cleanup: deleting unreferenced inode 6262706
ext3_orphan_cleanup: deleting unreferenced inode 6750246
ext3_orphan_cleanup: deleting unreferenced inode 6750244
ext3_orphan_cleanup: deleting unreferenced inode 6750259
ext3_orphan_cleanup: deleting unreferenced inode 6750250
ext3_orphan_cleanup: deleting unreferenced inode 6750257
ext3_orphan_cleanup: deleting unreferenced inode 6750242
ext3_orphan_cleanup: deleting unreferenced inode 6750249
ext3_orphan_cleanup: deleting unreferenced inode 6750237
ext3_orphan_cleanup: deleting unreferenced inode 6750264
ext3_orphan_cleanup: deleting unreferenced inode 6750232
ext3_orphan_cleanup: deleting unreferenced inode 6750231
ext3_orphan_cleanup: deleting unreferenced inode 5162365
EXT3-fs: md1: 34 orphan inodes deleted
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
NET: Registered protocol family 1
Adding 976552k swap on /dev/sda2.  Priority:-1 extents:1 across:976552k
Adding 976552k swap on /dev/sdb2.  Priority:-2 extents:1 across:976552k
EXT3 FS on md1, internal journal
Real Time Clock Driver v1.12
Generic RTC Driver v1.07
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.50.4)
powernow-k8:    0 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)
powernow-k8:    1 : fid 0xa (1800 MHz), vid 0x6 (1400 mV)
cpu_init done, current fid 0xa, vid 0x6
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
md: md0 stopped.
md: bind<sda1>
md: bind<sdb1>
raid1: raid set md0 active with 2 out of 2 mirrors
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Debian etch ist nun stable

Post by flo » 2007-04-12 09:45

Lord_Pinhead wrote:@Flo
Frag mich mal, ich hab jede menge Sachen die gegen alte libc/glibc gelinkt sind und nicht mehr laufen werden. Wird kein Spaß mein ganzes Zeug neu zu übersetzen :(
Mein Apache lief out-of-the Box, werde den aber am WE trotzdem neu übersetzen - bin jetzt schon gespannt. Starten der Proxies dauert momentan länger als auf der alten Kiste, da bockt also noch etwas.

Das wput schmeißt auch in Ubuntu oder Debian 3.1 Fehler, wenn man "-v -v" benutzt, nur das Etch-Paket bricht deswegen ab - ich denke, daß die Option "TLS" Probleme macht, das war eigentlich das einzige, was ich rausgeschmissen habe. Auch wenn ich wput aus Etch installiere und mein eigenes wput laufen lasse, geht es.

lord_pinhead
RSAC
Posts: 830
Joined: 2004-04-26 15:57

Re: Debian etch ist nun stable

Post by lord_pinhead » 2007-04-12 20:56

time-walker wrote:Hey, hab gestern abend auch ein upgrade gemacht auf etch stable,
hab einen server von Server4you.
Nach paar anfangsschwierigkeiten mit aptitude wars dann doch erfolgreich.

Hab danach erst mal ein Neustart gemacht, naja dann war der server nicht mehr erreichbar.

Der hat auch bei dem upgrade meinen selbst compimierten Kernel entfernt.
hab dann den alten genommen.

Nun will der nicht mehr hochfahren, zur zeit befindet der sich im Rettungssystem, kann aber keine fehler finden.
In den logs von dmesg sieht steht auch nicht ungewöhnliches drine.
Wird das Interface hochgefahren? Ein einfaches Testscript das seine Ausgabe z.b. nach /var/log/test schreibt sollte das lösen. Schau mal in die Datei /etc/network/interfaces ob auch die Daten richtig eingetragen wurden, nicht das sie überschrieben wurden.