Hetzner DS7000 - tot nach Reinstall

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
Anonymous

Hetzner DS7000 - tot nach Reinstall

Post by Anonymous » 2007-04-06 23:12

Hallo allerseits,

ich habe kuerzlich meinen dritten sogenannten "Rootserver" in Betrieb genommen, einen Hetzner DS7000 (siehe http://www.hetzner.de/rootserver.html ).

Das vorinstallierte etch "preview" fuer x86_64 habe ich gleich in der ersten Stunde via "Rettungskonsole" verworfen, und eine Hardened Gentoo ~amd64 install mit md-RAID und lvm2 begonnen. Ist nicht das erste Mal, dass ich so ein Setup aufgesetzt habe.

Allerdings hat es nicht lange gedauert, dass sich die bis jetzt scheinbar unbehebbaren Probleme losgingen - die Kiste will einfach nicht mehr von HDD bootend hochfahren. Mittlerweile habe ich meine "Anforderungen" graduell gesenkt: Zuerst eine non-hardened stage3 gemacht, dann einmal auf md und lvm verzichtet (und alles auf gute, alte MSDOS-typische Partitionen gelegt). Statt 2.6.20 mal 2.6.18 versucht. Auf die neue libata verzichtet. Ubuntu Feisty debootstrapped (auf einem anspruchlosen Einpartitionensetup). Ubuntu Dapper auf die selbe Weise versucht.

Alles ohne Erfolg.

Da ich keine serielle Konsole zur Verfuegung habe (nachdem sich am FS waehrend meiner Bootversuche nichts geaendert hat, gehe ich mal davon aus, dass nicht mal init startet - vielleicht scheitert alles schon am Bootloader...) und dem Hetzner-Support nicht unbedingt Geld in den Rachen werfen moechte, hab ich beschlossen, hier mal um Rat zu fragen. Ich bin kein Anfaenger, und eigentlich bin ich der Meinung, schon saemtliche Register gezogen zu haben - aber vielleicht hat ja jemand einen magischen Geheimtipp fuer mich.

Der Vollstaendigkeit halber hier noch ein paar Daten meines ersten Installversuchs:
http://gnulords.org/~colo/tmp/server.txt

(/ war md-RAID1. der GRUB-Kernel-Eintrag nur testhalber auf "root=/dev/sda1" - hat auch nix gebracht.)

Hat jemand vielleicht eine aehnliche Maschine und etwas Zeit, mir beizeiten Beistand zu leisten?

Vielen herzlichen Dank fuer eure Muehen ;)
- colo

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Hetzner DS7000 - tot nach Reinstall

Post by daemotron » 2007-04-06 23:33

Ich hab einen DS7000 mit Gentoo Hardened (und dem aktuellen 2.6.20-r1) incl. LVM am laufen (allerdings mit Hardware RAID1) und einen zweiten DS7000 mit Software RAID, allerdings noch mit dem letzten 2.6.17er (hardened-sources). Wir können ja mal versuchen, einen Abgleich zu machen - meld Dich doch sonst mal per ICQ, dann müssen wir nicht das Forum mit Rückfragen zumüllen (weltbewegende Erkenntnisse werden hier natürlich veröffentlicht :wink: )

static
Posts: 437
Joined: 2002-10-27 19:56
Location: Schweiz

Re: Hetzner DS7000 - tot nach Reinstall

Post by static » 2007-04-07 21:00

Nur kurz zur Info:
Soweit ich weiss, stellt dir Hetzner kostenlos eine LARA für einige Stunden zur Verfügung. Ich habe das zwar selbst noch nicht gebraucht, aber schon öfters gehört. Vielleicht einfach mal anfragen, kostet ja nichts und würde dir wahrscheinlich viel Arbeit ersparen.

.static