Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

tobster
Posts: 28
Joined: 2005-08-12 19:01

Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

Post by tobster »

Hallo zusammen,

ich habe einen kleinen Exim4.60 Mailserver aufgesetzt, welcher per SMTP-Smarthost seine E-Mails weitergeben soll.
Das Problem ist nun, dass das Exim beim Smarthost weder TLS verwendet (nicht kriegsendscheident) noch sich authentifiziert.

Ich habe Exim mit der Option -v gestartet und sehe dort, dass nach dem EHLO beim Server meines ISP's direkt ein MAIL FROM kommt.
Ich vermute dass die passwd-client nicht beachtet wird. Der Eintrag in der update.exim.conf.conf und in der passwd-client sind gleich.

Code: Select all

6800 T: remote_smtp_smarthost for xxx@xxx.xx
 6800 Connecting to auth.smtp.kundenserver.de [150.100.1.91]:25 ... connected
 6800   SMTP<< 220 auth.smtp.kundenserver.de (mrelayeu8) Welcome to Nemesis ESMTP server
 6800   SMTP>> EHLO localhost
 6800   SMTP<< 250-mrelayeu8.kundenserver.de pleased to meet you
 6800          250-STARTTLS
 6800          250-AUTH PLAIN LOGIN
 6800          250-AUTH=PLAIN LOGIN
 6800          250-PIPELINING
 6800          250-SIZE 52428800
 6800          250 HELP
 6800   SMTP>> MAIL FROM:<xx.xx@xxx.xx> SIZE=1659
 6800   SMTP>> RCPT TO:<verwaltung@xxx.x>
 6800   SMTP>> DATA
 6800   SMTP<< 250 mail from: <xx.xx@xxx.xx> ok
 6800   SMTP<< 550 must be authenticated
 6800   SMTP<< 554 no valid recipients
 6800   SMTP>> QUIT
Hat jemand eine Idee
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

Post by Roger Wilco »

Hast du hosts_try_auth in dem Transport eingetragen und einen entsprechenden Authenticator erstellt?

Siehe auch http://www.tgunkel.de/docs/exim_smarthosts.de
Top

tobster
Posts: 28
Joined: 2005-08-12 19:01

Re: Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

Post by tobster »

Das ist mein Transporter

Code: Select all

remote_smtp_smarthost:
  debug_print = "T: remote_smtp_smarthost for $local_part@$domain"
  driver = smtp
  hosts_try_auth = ${if exists{CONFDIR/passwd.client} 
        {
        ${lookup{$host}nwildlsearch{CONFDIR/passwd.client}{$host_address}}
        }
        {} 
      }
  # to disable TLS on outgoing connections, uncomment this
  hosts_avoid_tls = *
  DEBCONFheaders_rewriteDEBCONF
  DEBCONFreturn_pathDEBCONF
Das ist die Zeile aus meiner passwd-client

Code: Select all

auth.smtp.kundenserver.de:xxx:xxx
Ich kann mir beim besten Willen nicht vorstellen was da schief läuft.

Edit:

Ich habe das host_try_auth mal probehalber durch ein host_require_auth ersetzt. Dabei kam folgendes raus:

Code: Select all

defer (-42): authentication required but no common mechanisms were found
Man beachte hierbei auch die Ausgabe die ich oben gemacht habe.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

Post by Roger Wilco »

Tobster wrote:Man beachte hierbei auch die Ausgabe die ich oben gemacht habe.
Roger Wilco wrote:Hast du [...] einen entsprechenden Authenticator erstellt?
Top

tobster
Posts: 28
Joined: 2005-08-12 19:01

Re: Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

Post by tobster »

Dann hilf mir doch bitte auf die Sprünge, wenn es nicht der Eintrag in der passwd-client ist.
Top


tobster
Posts: 28
Joined: 2005-08-12 19:01

Re: Smarthost Authentifizierungsproblem exim4 auf Ubuntu 6.06

Post by tobster »

Ich hatte es selbst schon gefunden. Trotzdem Danke für die Hilfe. Blöde das ich das nicht alleine gemerkt habe.
Top