Probleme mit dem Systemstart -> angeblich Mysql-problem

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
grinsekatze
Posts: 3
Joined: 2007-03-01 16:17

Probleme mit dem Systemstart -> angeblich Mysql-problem

Post by grinsekatze » 2007-03-01 16:27

Hiho!

ich habe ein kleines (großes) Problem. Ich fahre Debian Sarge auf einem Hetzner Server und nachdem mein Mysql-Dienst den Dienst versagte (zeigte gar keine Reaktion) hab ich den Server rebootet (ich weiß, ned gut, aber ich war müde und hungrig ;) )
Problem ist jetzt, dass ich nicht mehr auf den Server rauf komme. Die Jungs von Hetzner meinten, dass sich der Server beim Start irgendwie an Mysql aufhängt. Ich hab im Rescuesystem alles überprüft und konnte nichts feststellen, also hab ich mal Mysql aus dem Systemstart raus genommen - immer noch keine Besserung.
Habt ihr da noch Denkanstösse?

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Probleme mit dem Systemstart -> angeblich Mysql-problem

Post by daemotron » 2007-03-01 17:27

Was sagt denn die boot.msg?

grinsekatze
Posts: 3
Joined: 2007-03-01 16:17

Re: Probleme mit dem Systemstart -> angeblich Mysql-problem

Post by grinsekatze » 2007-03-06 15:36

also meine dmesg geht nich weiter wie:
uhci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:10.4[C] -> GSI 21 (level, low) -> IRQ 185
ehci_hcd 0000:00:10.4: VIA Technologies, Inc. USB 2.0
ehci_hcd 0000:00:10.4: irq 185, pci mem f88e0000
ehci_hcd 0000:00:10.4: new USB bus registered, assigned bus number 5
ehci_hcd 0000:00:10.4: USB 2.0 enabled, EHCI 1.00, driver 2004-May-10
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 8 ports detected
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected AGP bridge 0
agpgart: Maximum main memory to use for agp memory: 940M
agpgart: AGP aperture is 128M @ 0xd8000000
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.4
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
input: PC Speaker
inserting floppy driver for 2.6.8-3-k7-smp
FDC 0 is a post-1991 82077
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP]
loop: loaded (max 8 devices)
device-mapper: 4.1.0-ioctl (2003-12-10) initialised: dm@uk.sistina.com
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting. Commit interval 5 seconds
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Adding 2096440k swap on /dev/sda1. Priority:-1 extents:1
EXT3 FS on sda2, internal journal
Capability LSM initialized
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda3, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda5, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda6, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda7, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
NET: Registered protocol family 10
Disabled Privacy Extensions on device c031b140(lo)
IPv6 over IPv4 tunneling driver
solange ich nicht total blau bin und die boot.msg immer noch unter var/log/ liegt, gibt es keine boot.msg (habe ich da drin auch noch nie gesehen....)

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Probleme mit dem Systemstart -> angeblich Mysql-problem

Post by sledge0303 » 2007-03-06 17:23

Du musst den Bootlog natürlich aktivieren...:roll:

Code: Select all

nano /etc/default/bootlogd
BOOTLOGD_ENABLE=Yes

grinsekatze
Posts: 3
Joined: 2007-03-01 16:17

Re: Probleme mit dem Systemstart -> angeblich Mysql-problem

Post by grinsekatze » 2007-03-06 18:12

sledge0303 wrote:Du musst den Bootlog natürlich aktivieren...:roll:

Code: Select all

nano /etc/default/bootlogd
BOOTLOGD_ENABLE=Yes
narf, wenn man nie solche probleme hat, weiss man das natürlich nicht^^
Tue Mar 6 18:03:07 2007: bootlogd.
Tue Mar 6 18:03:07 2007: Activating swap.
Tue Mar 6 18:03:07 2007: System time was Tue Mar 6 17:03:04 UTC 2007.
Tue Mar 6 18:03:07 2007: Setting the System Clock using the Hardware Clock as reference...
Tue Mar 6 18:03:07 2007: System Clock set. System local time is now Tue Mar 6 17:03:06 UTC 2007.
Tue Mar 6 18:03:07 2007: Cleaning up ifupdown...done.
Tue Mar 6 18:03:07 2007: Calculating module dependencies... done.
Tue Mar 6 18:03:07 2007: Loading modules...
Tue Mar 6 18:03:07 2007: ide-cd
Tue Mar 6 18:03:07 2007: ide-disk
Tue Mar 6 18:03:07 2007: ide-generic
Tue Mar 6 18:03:07 2007: psmouse
Tue Mar 6 18:03:07 2007: sr_mod
Tue Mar 6 18:03:07 2007: All modules loaded.
Tue Mar 6 18:03:07 2007: Creating device-mapper devices...done.
Tue Mar 6 18:03:07 2007: Starting raid devices: mdadm: No arrays found in config file
Tue Mar 6 18:03:07 2007: done.
Tue Mar 6 18:03:07 2007: Starting crypto disks:.
Tue Mar 6 18:03:07 2007: Checking all file systems...
Tue Mar 6 18:03:07 2007: fsck 1.37 (21-Mar-2005)
Tue Mar 6 18:03:07 2007: Setting kernel variables ...
Tue Mar 6 18:03:07 2007: ... done.
Tue Mar 6 18:03:07 2007: Mounting local filesystems...
Tue Mar 6 18:03:07 2007: [mntent]: warning: no final newline at the end of /etc/fstab
Tue Mar 6 18:03:07 2007: /dev/sda3 on /home type ext3 (rw)
Tue Mar 6 18:03:07 2007: /dev/sda5 on /contain type ext3 (rw)
Tue Mar 6 18:03:07 2007: /dev/sda6 on /var type ext3 (rw)
Tue Mar 6 18:03:07 2007: /dev/sda7 on /rest type ext3 (rw)
Tue Mar 6 18:03:07 2007: Cleaning /tmp /var/run /var/lock.
Tue Mar 6 18:03:07 2007: Detecting hardware: r8169 sata_via via82cxxx usb_uhci ehci_hcd
Tue Mar 6 18:03:07 2007: Skipping already loaded module r8169.
Tue Mar 6 18:03:07 2007: Skipping already loaded module sata_via.
Tue Mar 6 18:03:07 2007: Skipping already loaded module via82cxxx.
Tue Mar 6 18:03:07 2007: Skipping already loaded module uhci_hcd.
Tue Mar 6 18:03:07 2007: Skipping already loaded module ehci_hcd.
Tue Mar 6 18:03:07 2007: Running 0dns-down to make sure resolv.conf is ok...done.
Tue Mar 6 18:03:08 2007: Setting up networking...done.
Tue Mar 6 18:03:08 2007: Starting hotplug subsystem:
Tue Mar 6 18:03:08 2007: pci
Tue Mar 6 18:03:08 2007: amd64-agp: already loaded
Tue Mar 6 18:03:09 2007: pciehp: already loaded
Tue Mar 6 18:03:09 2007: shpchp: already loaded
Tue Mar 6 18:03:09 2007: r8169: already loaded
Tue Mar 6 18:03:10 2007: sata_via: already loaded
Tue Mar 6 18:03:10 2007: via82cxxx: already loaded
Tue Mar 6 18:03:10 2007: uhci-hcd: already loaded
Tue Mar 6 18:03:10 2007: uhci-hcd: already loaded
Tue Mar 6 18:03:10 2007: uhci-hcd: already loaded
Tue Mar 6 18:03:11 2007: uhci-hcd: already loaded
Tue Mar 6 18:03:11 2007: ehci-hcd: already loaded
Tue Mar 6 18:03:12 2007: ignoring pci display device 01:00.0
Tue Mar 6 18:03:12 2007: pci [success]
Tue Mar 6 18:03:12 2007: usb
Tue Mar 6 18:03:13 2007: usb [success]
Tue Mar 6 18:03:13 2007: isapnp
Tue Mar 6 18:03:13 2007: modprobe: FATAL: Error inserting rtc (/lib/modules/2.6.8-3-k7-smp/kernel/drivers/char/rtc.ko): No such device
Tue Mar 6 18:03:13 2007:
Tue Mar 6 18:03:13 2007: rtc: can't be loaded
Tue Mar 6 18:03:13 2007: pcspkr: loaded sucessfully
Tue Mar 6 18:03:13 2007: floppy: loaded sucessfully
Tue Mar 6 18:03:13 2007: parport_pc: loaded sucessfully
Tue Mar 6 18:03:13 2007: isapnp [success]
Tue Mar 6 18:03:13 2007: ide
Tue Mar 6 18:03:13 2007: ide [success]
Tue Mar 6 18:03:13 2007: input
Tue Mar 6 18:03:13 2007: evdev: already loaded
Tue Mar 6 18:03:13 2007: evdev: already loaded
Tue Mar 6 18:03:13 2007: input [success]
Tue Mar 6 18:03:13 2007: scsi
Tue Mar 6 18:03:13 2007: sd_mod: loaded sucessfully (for disk)
Tue Mar 6 18:03:13 2007: sd_mod: loaded sucessfully (for disk)
Tue Mar 6 18:03:13 2007: scsi [success]
Tue Mar 6 18:03:13 2007: d
und das schlagwort fatal sagt mir da liegt was im argen....