Postfix mit SMTP-AUTH funktioniert nicht

sandro
Posts: 46
Joined: 2007-02-11 23:39

Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Hallo,
ich habe ein Ubuntu-Server mit postfix und Cyrus sasl2. Ich bin schon seit Tagen dabei, SMTP-AUTH mit sasldb2 für Mails einzurichten. :twisted: Ich habe mich dabei an das Buch Postfix von Ralf Hildebrandt gehalten:
Ich komme einfach nicht weiter, vielleicht kann mir hier jemand einen Tipp geben.

Vielen Dank im Voraus
Gruß, Sandro

,----[ /etc/postfix/main.cf ]
| smtpd_sasl_auth_enable = yes
| smtpd_sasl_security_options = noanonymous
| # smtpd_sasl_local_domain = $myhostname
| smtpd_sasl_local_domain =
| broken_sasl_auth_clients = yes
|
| smtpd_recipient_restrictions =
| permit_sasl_authenticated,
| permit_mynetworks,
| check_relay_domains
`----

,----[ /etc/postfix/sasl/smtpd.conf ]
| pwcheck_method: auxprop
| mech_list: plain login digest-md5 cram-md5
`----

/etc/sasldb2, nach Erstellen der User-Einträge, habe ich in
/var/spool/postfix/etc/ hineinkopiert:

,----[ /var/spool/postfix/etc/ ]
| -rw-rw---- 1 root sasl …
`----

saslpasswd2 -c -u `postconf -h myhostname` test2

Nach erneutem Einlesen der Konfiguration mache ich remote ein telnet auf
den Mailserver und nach Senden des EHLO bekomme ich:

,----
| 250-AUTH LOGIN PLAIN DIGEST-MD5 CRAM-MD5
| 250-AUTH=LOGIN PLAIN DIGEST-MD5 CRAM-MD5
`----

Scheint also schon einmal zu funktionieren.

Anschließend tippe ich

AUTH PLAIN $BASE64-PASSWORT

und erhalte ich:

,----
| 535 Error: authentication failed
`----

Hier mal die Logs:

mail.warn
Feb 11 22:36:41 server17864 postfix/pickup[5659]: warning: maildrop/3AB0127818F: Error writing message file
Feb 11 22:36:46 server17864 postfix/smtpd[5687]: warning: SASL authentication failure: Password verification failed
Feb 11 22:36:46 server17864 postfix/smtpd[5687]: warning: server17864[xxx.xxx.xxx.xxx]: SASL PLAIN authentication failed
Feb 11 22:37:41 server17864 postfix/pickup[5659]: warning: D5F84278199: message has been queued for 5 days
Feb 11 22:37:41 server17864 postfix/cleanup[5661]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Feb 11 22:37:41 server17864 postfix/cleanup[5661]: warning: D5F84278199: virtual_alias_maps map lookup problem for root@server17864.provider.de
Feb 11 22:37:41 server17864 postfix/pickup[5659]: warning: maildrop/5378A278042: Error writing message file

mail.log
Feb 11 22:37:41 server17864 postfix/pickup[5659]: D5F84278199: uid=1000 from=<SaidAdmin>
Feb 11 22:37:41 server17864 postfix/cleanup[5661]: D5F84278199: message-id=<20070211213741.D5F84278199@server17864.provider.de>
Feb 11 22:37:41 server17864 postfix/cleanup[5661]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Feb 11 22:37:41 server17864 postfix/cleanup[5661]: warning: D5F84278199: virtual_alias_maps map lookup problem for root@server17864.provider.de
Feb 11 22:37:41 server17864 postfix/pickup[5659]: warning: maildrop/5378A278042: Error


mail.inf
Feb 11 22:38:41 server17864 postfix/pickup[5659]: warning: maildrop/3AB0127818F: Error writing message file
Feb 11 22:39:41 server17864 postfix/pickup[5659]: warning: D9189278199: message has been queued for 5 days
Feb 11 22:39:41 server17864 postfix/pickup[5659]: D9189278199: uid=1000 from=<SaidAdmin>
Feb 11 22:39:41 server17864 postfix/cleanup[5661]: D9189278199: message-id=<20070211213941.D9189278199@server17864.provider.de>
Feb 11 22:39:41 server17864 postfix/cleanup[5661]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Feb 11 22:39:41 server17864 postfix/cleanup[5661]: warning: D9189278199: virtual_alias_maps map lookup problem for root@server17864.provider.de
Feb 11 22:39:41 server17864 postfix/pickup[5659]: warning: maildrop/5378A278042: Error writing message file
Feb 11 22:39:41 server17864 postfix/pickup[5659]: D97C9278199: uid=0 from=<root>
Feb 11 22:39:41 server17864 postfix/cleanup[5663]: warning: D97C9278199: virtual_alias_maps map lookup problem for root@server17864.provider.de
Feb 11 22:39:41 server17864 postfix/pickup[5659]: warning: maildrop/3AB0127818F: Error writing message file
Last edited by sandro on 2007-02-12 11:46, edited 1 time in total.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by Roger Wilco »

Sandro wrote:pwcheck_method: auxprop
mech_list: plain login digest-md5 cram-md5
Füge da spasseshalber noch folgende Zeile ein:

Code: Select all

auxprop_plugin: sasldb
Sandro wrote:Feb 11 22:36:41 server17864 postfix/pickup[5659]: warning: maildrop/3AB0127818F: Error writing message file
Dein Postfix kann keine Mails in die Queue schreiben. Stimmen die Rechte?
Sandro wrote:Feb 11 22:36:46 server17864 postfix/smtpd[5687]: warning: SASL authentication failure: Password verification failed
Feb 11 22:36:46 server17864 postfix/smtpd[5687]: warning: server17864[127.0.0.1]: SASL PLAIN authentication failed
Kann dein Postfix auf die SASLDB zugreifen?
Sandro wrote:Feb 11 22:37:41 server17864 postfix/cleanup[5661]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Feb 11 22:37:41 server17864 postfix/cleanup[5661]: warning: D5F84278199: virtual_alias_maps map lookup problem for root@server17864.provider.de
Dein Postfix kann nicht auf die MySQL-Datenbank zugreifen, da sich der UNIX-Socket natürlich nicht in deiner chroot-Umgebung befindet.

Poste die Ausgabe von `postconf -n`, deine master.cf und die übrigen Konfigurationsdateien, die du benutzt. Dazu kannst du gerne die CODE-Tags benutzen.
Lass Postfix außerdem nicht chrooted laufen, sondern versuch die Probleme erst normal zu beheben. Danach kannst du die chroot-Umgebung immer noch einrichten.

EDIT: Security by obscurity
Last edited by Roger Wilco on 2007-02-12 13:13, edited 1 time in total.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Hallo,
danke für die schnelle Antwort. Ich habe die von dir erwähnten Änderungen vor genommen:

Ich habe "auxprop_plugin: sasldb" hinzugefügt.
Bei "maildrop" habe ich erstmal 777 gesetzt.
Sasldb2 habe von 640 auf 777 gesetzt.

Postfix reload, aber leider immer noch : 535 Error: authentication failed.

Gruß

Code: Select all

 ********* root@server17864:~# postconf -n ********* 
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
mailbox_size_limit = 0
mydestination = server17864, localhost.localdomain, , localhost
myhostname = server17864.provider.de
mynetworks = 127.0.0.0/8
myorigin = server17864.provider.de
recipient_delimiter = +
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = mysql:/etc/postfix/mysql-sasl.cf
smtp_sasl_security_options = noanonymous
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_restrictions = permit_sasl_authenticated  permit_mynetworks,  reject_unauth_destination,
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_use_tls = yes
virtual_alias_maps = mysql:/etc/postfix/sql/virtual_alias_maps.cf
virtual_gid_maps = mysql:/etc/postfix/sql/virtual_gid_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/sql/virtual_mailbox_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/sql/virtual_mailbox_recipients.cf
virtual_uid_maps = mysql:/etc/postfix/sql/virtual_uid_maps.cf
root@server17864:~#


 ********* main.cf ********* 

# See /usr/share/postfix/main.cf.dist for a commented, more complete version
# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache


myhostname = server17864.provider.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = server17864.provider.de
mydestination = server17864, localhost.localdomain, , localhost
#relayhost = 
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all


virtual_mailbox_domains = mysql:/etc/postfix/sql/virtual_mailbox_domains.cf
virtual_uid_maps = mysql:/etc/postfix/sql/virtual_uid_maps.cf
virtual_gid_maps = mysql:/etc/postfix/sql/virtual_gid_maps.cf
virtual_mailbox_maps = mysql:/etc/postfix/sql/virtual_mailbox_recipients.cf
virtual_alias_maps = mysql:/etc/postfix/sql/virtual_alias_maps.cf

smtpd_sasl_auth_enable = yes
smtpd_sasl2_auth_enable = yes

smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname

smtp_sasl_auth_enable = yes
smtp_sasl2_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = mysql:/etc/postfix/mysql-sasl.cf

broken_sasl_auth_clients = yes

smtpd_recipient_restrictions =
  permit_sasl_authenticated
  permit_mynetworks,
  reject_unauth_destination,



 ********* master.cf ********* 

#
# Postfix master process configuration file.  For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd -v
#submission inet n      -       -       -       -       smtpd
#	-o smtpd_etrn_restrictions=reject
#	-o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n      -       -       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
	-o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache	  unix	-	-	-	-	1	scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix	-	n	n	-	2	pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}



 ********* smtpd.conf ********* 
# Golbal Parameters
log_level: 3
pwcheck_method: auxprop
mech_list: PLAIN LOGIN CRAM-MD5 DIGEST-MD5
# auxiliary Plugin Parameters
auxprop_plugin: sql
sql_engine: mysql
sql_hostnames: localhost
sql_database: mail
sql_user: postfix
sql_passwd: Yanggt!
sql_select: SELECT %p FROM users WHERE username = '%u' AND userrealm = '%r' AND auth = '1'
sql_usessl: no


 ********* virtual_uid_maps.cf ********* 
user = postfix
password = Yanggt!
hosts = localhost
dbname = mail
table = virtual_users
query = SELECT virtual_uid FROM virtual_users WHERE email = '%s' AND active = '1'

 ********* virtual_mailbox_recipients.cf ********* 
user = postfix
password = Yanggt!
hosts = localhost
dbname = mail
table = virtual_users
query = SELECT virtual_mailbox FROM user WHERE email = '%s' AND active = '1'

 ********* virtual_mailbox_domains.cf ********* 
user = postfix
password = Yanggt!
hosts = localhost
dbname = mail
table = virtual_mailbox_domains
query = SELECT domain FROM virtual_mailbox_domains WHERE domain = '%s'

 ********* virtual_gid_maps.cf ********* 
user = postfix
password = Yanggt!
hosts = localhost
dbname = mail
table = virtual_users
query = SELECT virtual_gid FROM virtual_users WHERE email = '%s' AND active = '1'

 ********* virtual_alias_maps.cf ********* 
user = postfix
password = Yanggt!
hosts = localhost
dbname = mail
table = virtual_aliases
query = SELECT virtual_user_email FROM virtual_aliases WHERE alias = '%s'
Last edited by sandro on 2007-02-12 12:40, edited 1 time in total.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by Roger Wilco »

1. `postconf -n` liefert schon die geändert Einstellungen der main.cf, du bräuchtest die also nicht nochmal aufführen.

2. Welches auxprop-Backend willst du eigentlich benutzen? Deine smtpd.conf sieht sehr schizophren aus...
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Ich habe versucht mein "smtpd.conf" zu verbessern.

auxprop-Backend ? Ich weiß es nicht, kannst du mir einen Vorschlagen? "saslauthd -v"
sieht wie folgt aus:

# saslauthd -v
saslauthd 2.1.19
authentication mechanisms: sasldb getpwent kerberos5 pam rimap shadow ldap

Gruß
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by Roger Wilco »

Du willst also gegen MySQL authentifizieren, nicht gegen die SASLDB, wie du vorher geschrieben hast...

Der saslauthd hat mit auxprop nichts am Hut.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Ok, danke für den Hinweis. Wie gesagt, ich habe mich ans Buch gehalten.
Wenn es eine Änderung vorzunehmen ist, sage es mir, dann werde ich machen.

Übrigens, du hast mich oben zitierst, dabei ist meine IP- Adresse aus log-Dateien zu sehen. Ich wollte es mit xxx.x… überschreiben, leider weil dein beitrage ist, konnte ich es nicht tun. Kannst du es bitte mit xxx überschreiben, danke.

Gruß
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by Roger Wilco »

Sandro wrote:Ok, danke für den Hinweis. Wie gesagt, ich habe mich ans Buch gehalten.
Wenn es eine Änderung vorzunehmen ist, sage es mir, dann werde ich machen.
Mach dir erstmal selbst klar, gegen welches Backend du die Authentifizierung durchführen willst. Dann lies das entsprechende Kapitel in deinem Buch dazu.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Ich bin leider mit dem Buch nicht zu recht gekommen, deshalb bin ich doch hier. Außerdem im Buch steht:

An dieser Stelle trennen sich die Wege zur Konfiguration der verschiedenen passwordverification services. Wenn Sie saslauthd konfigurieren wollen, lesen Sie einfach weiter. Für authdaemond blättern Sie bitte weiter zu Abschnitt 17.4.7 und für auxprop plu-ins blättern Sie bitte zu Abschnitt 17.4.8.

Bei saslauthd konfigurieren ist die Rede von "authentication backends". Bei auxprop plu-ins wird "backends" überhaupt nicht erwähnt.

Gruß
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by Roger Wilco »

Mit Backend meinte ich schon die auxprop Plugins. Du kannst nur eines gleichzeitig verwenden. Entscheide dich für SASLDB, MySQL oder ein anderes und ändere die smtpd.conf entsprechend ab.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Hallo,
dazwischen bin ich etwas weiter gekommen. Ich kann mich jetzt authentifizieren:

perl -MMIME::Base64 -e 'print encode_base64("test@mail.domainname.detest@mail.domainname.deYanggt!");'
Die @-Zeichen ist bei mir gefehlt.

Ich versuche jetzt ein Test-Mail zu schicken. Nach dem "MAIL FROM: <test@domainname.de>" bleibt es hängen.

Eine Idee, woran kann es liegen?

Gruß

Code: Select all

root@server17864:~# telnet mail.domainname.de 25
Trying x.x.x.x...
telnet: Unable to connect to remote host: Connection refused
root@server17864:~# postfix start
root@server17864:~# telnet mail.domainname.de 25
Trying x.x.x.x...
Connected to mail.domainname.de.
Escape character is '^]'.
220 server17864.provider.de ESMTP Postfix (Ubuntu)
EHLO client.domainname.de
250-server17864.provider.de
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN DIGEST-MD5 CRAM-MD5
250-AUTH=LOGIN PLAIN DIGEST-MD5 CRAM-MD5
250 8BITMIME
AUTH PLAIN dGVzdEBzZXJ2ZXIxODc2Mi54YW
235 Authentication successful
MAIL FROM: <test@domainname.de>

[/quote]

mail.log

Code: Select all

…
Feb 13 15:07:06 server17864 postfix/smtpd[10969]: smtpd_sasl_authenticate: decoded initial response test@server17864.provider.de
Feb 13 15:07:06 server17864 postfix/smtpd[10969]: > server17864[x.x.x.x]: 235 Authentication successful
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: < server17864[x.x.x.x]: MAIL FROM: <test@domainname.de>
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: extract_addr: input: <test@domainname.de>
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: smtpd_check_addr: addr=test@domainname.de
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: connect to subsystem private/rewrite
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: send attr request = rewrite
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: send attr rule = local
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: send attr address = test@domainname.de
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: private/rewrite socket: wanted attribute: flags
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: input attribute name: flags
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: input attribute value: 0
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: private/rewrite socket: wanted attribute: address
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: input attribute name: address
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: input attribute value: test@domainname.de
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: private/rewrite socket: wanted attribute: (list terminator)
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: input attribute name: (end)
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: rewrite_clnt: local: test@domainname.de -> test@domainname.de
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: send attr request = resolve
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: send attr address = test@domainname.de
Feb 13 15:07:22 server17864 postfix/smtpd[10969]: private/rewrite socket: wanted attribute: flags
Feb 13 15:07:22 server17864 postfix/trivial-rewrite[10967]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Feb 13 15:07:22 server17864 postfix/trivial-rewrite[10967]: fatal: mysql:/etc/postfix/sql/virtual_alias_maps.cf(0,100): table lookup problem
Feb 13 15:07:23 server17864 postfix/smtpd[10969]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Feb 13 15:07:23 server17864 postfix/smtpd[10969]: warning: problem talking to service rewrite: Success
Feb 13 15:07:23 server17864 postfix/master[10963]: warning: process /usr/lib/postfix/trivial-rewrite pid 10967 exit status 1
…
…
Feb 13 15:06:31 server17864 postfix/pickup[10964]: warning: maildrop/4D60A278440: Error writing message file
Feb 13 15:06:31 server17864 postfix/pickup[10964]: 0BD822781A3: uid=0 from=<root>
Feb 13 15:06:31 server17864 postfix/cleanup[10966]: warning: 0BD822781A3: virtual_alias_maps map lookup problem for test@server17864.provider.de
…

Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by Roger Wilco »

Sandro wrote:

Code: Select all

Feb 13 15:07:22 server17864 postfix/trivial-rewrite[10967]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Feb 13 15:07:22 server17864 postfix/trivial-rewrite[10967]: fatal: mysql:/etc/postfix/sql/virtual_alias_maps.cf(0,100): table lookup problem
Siehe oben.
Sandro wrote:

Code: Select all

Feb 13 15:06:31 server17864 postfix/pickup[10964]: warning: maildrop/4D60A278440: Error writing message file
Siehe oben.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

"maildrop" ist schon auf 777 gesetzt, und der Besitzer ist auch Postfix. :?:
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Hallo,
dazwischen sind die Fehler Meldungen beseitigt worden. :-D Ich habe anstatt localhost die IP: 127.0.0.1 eingetragen und in my.cnf habe:
# skip-networking
bindaddress = 127.0.0.1

Jetzt kann ich fast Email senden und Empfangen und habe nur ein "Warning" und paar "not found".

(Feb 14 21:12:54 server17864 postfix/smtp[9636]: warning: mail.example.de[x2.x2.x2.x2] offered AUTH option multiple times)

Wenn ich ein Email von zu Hause mit Outlook sende, dann kann ich auf dem Server in mail.log das Email sehen, dass angekommen ist. Lesen kann ich es noch nicht.

Wenn ich vom Server (siehe unten) ein Email an Outlook (zu Hause) sende, das Email ist zwar zu lesen, ist aber Fehlerhaft und mit Warnung verbunden.
:evil:
Eine Idee, woran es liegen kann? :?:

Gruß

Code: Select all

root@server17864:~# telnet mail.beispiel.de 25
Trying x.x.x.x...
Connected to mail.beispiel.de.
Escape character is '^]'.
220 mail.beispiel.de ESMTP Postfix (Ubuntu)
EHLO client.beispiel.de
250-mail.beispiel.de
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN DIGEST-MD5 CRAM-MD5
250-AUTH=LOGIN PLAIN DIGEST-MD5 CRAM-MD5
250 8BITMIME
AUTH PLAIN dGVzdEBzZXJ2ZXIxODc2Mi54YW
235 Authentication successful
MAIL FROM: <test@beispiel.de>
250 Ok
RCPT TO: <info@example.de>
250 Ok
DATA
354 End data with <CR><LF>.<CR><LF>
Testnachrichrit von einer telnet-Sitzung.
Tschüß.
.
250 Ok: queued as 5F61A27842C
quit
221 Bye
Connection closed by foreign host.


mail.log

Code: Select all

…
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: >>> CHECKING RECIPIENT MAPS <<<
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: ctable_locate: leave existing entry key info@example.de
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: maps_find: recipient_canonical_maps: info@example.de: not found
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_string: example.de ~? server17864
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_string: example.de ~? localhost.localdomain
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_string: example.de ~? localhost
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_list_match: example.de: no match
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: maps_find: recipient_canonical_maps: @example.de: not found
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: mail_addr_find: info@example.de -> (not found)
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: maps_find: canonical_maps: info@example.de: not found
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_string: example.de ~? server17864
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_string: example.de ~? localhost.localdomain
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_string: example.de ~? localhost
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: match_list_match: example.de: no match
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: maps_find: canonical_maps: @example.de: not found
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: mail_addr_find: info@example.de -> (not found)
Feb 14 21:12:29 server17864 postfix/smtpd[9619]: dict_mysql_get_active: attempting to connect to host 127.0.0.1
…
Feb 14 21:12:54 server17864 postfix/smtp[9636]: < mail.example.de[x2.x2.x2.x2]: 250-PIPELINING
Feb 14 21:12:54 server17864 postfix/smtp[9636]: < mail.example.de[x2.x2.x2.x2]: 250-8BITMIME
Feb 14 21:12:54 server17864 postfix/smtp[9636]: < mail.example.de[x2.x2.x2.x2]: 250-SIZE
Feb 14 21:12:54 server17864 postfix/smtp[9636]: < mail.example.de[x2.x2.x2.x2]: 250 DSN
Feb 14 21:12:54 server17864 postfix/smtp[9636]: warning: mail.example.de[x2.x2.x2.x2] offered AUTH option multiple times
Feb 14 21:12:54 server17864 postfix/smtp[9636]: server features: 0x102f size 0
Feb 14 21:12:54 server17864 postfix/smtp[9636]: Using ESMTP PIPELINING, TCP send buffer size is 4096
Feb 14 21:12:54 server17864 postfix/smtp[9636]: maps_find: smtp_sasl_passwd: mail.example.de: not found
Feb 14 21:12:54 server17864 postfix/smtp[9636]: maps_find: smtp_sasl_passwd: example.de: not found
Feb 14 21:12:54 server17864 postfix/smtp[9636]: smtp_sasl_passwd_lookup: host `mail.example.de' no auth info found
Feb 14 21:12:54 server17864 postfix/smtp[9636]: > mail.example.de[x2.x2.x2.x2]: MAIL FROM:<test@beispiel.de> SIZE=429
Feb 14 21:12:54 server17864 postfix/smtp[9636]: > mail.example.de[x2.x2.x2.x2]: RCPT TO:<info@example.de>
Feb 14 21:12:54 server17864 postfix/smtp[9636]: > mail.example.de[x2.x2.x2.x2]: DATA
Feb 14 21:12:54 server17864 postfix/smtp[9636]: < mail.example.de[x2.x2.x2.x2]: 250 Ok.

Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Ich hatte einen Syntax-Fehler bei Username und Passwort. Zurzeit sasl_passwd-Datei sieht wie folgt aus:
------------------------------------------------------
mail.beispiel.de test:Yanggt!
smtp.beispiel.de test:Yanggt!
http://www.beispiel.de test:Yanggt!
beispiel.de test:Yanggt!
------------------------------------------------------

Jetzt wenn ich ein Email vom Server sende, kommt sehr sauber an. Die Mails, die an Server ankommen, kann ich ihre Ankunft in mail.log sehen, aber wie kann ich sie lesen? Muss ich ein Verzeichnis erstellen, worin die Mails ankommen?

Wenn ich das Account Bei Outlook einrichte und auf Kontoeinstellungen testen klicke:

Netzwerk Verbindung herstellen --> Erledigt
Postausgangsserver suchen (SMTP) --> Erledigt
Posteingangsserver suchen (POP3) --> Erledigt
Bei Posteingangsserver anmelden (POP3) --> Bleibt hängen
Testnachrichten Senden --> Erledigt

Also bei Posteingangsserver kann nicht angemeldet werden.
Eine Idee, oder etwas aus der Zauberkiste?

Gruß
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: Postfix mit SMTP-AUTH funktioniert nicht

Post by sandro »

Hallo,
ich habe bis jetzt vieles versucht, leider habe ich immer noch keinen richtigen erfolg. :( Ich bekomme zwar keine "Warnig" bzw. "error / failed " von Postfix, aber ich kann wie vorher kein Email von zu Hause z.B. mit Outloock senden.

Wenn ich ein Email vom Server sende, kommt sehr sauber bei Outlook zu Hause an.

Wenn ich das Account bei Outlook einrichte und auf "Kontoeinstellungen testen" klicke:

Netzwerk Verbindung herstellen --> Erledigt
Postausgangsserver suchen (SMTP) --> Erledigt
Posteingangsserver suchen (POP3) --> Erledigt
Bei Posteingangsserver anmelden (POP3) --> Bleibt hängen
Testnachrichten Senden --> Erledigt

Also bei Posteingangsserver kann nicht angemeldet werden.


Ich habe Courier installiert und port 110 ist wie folgt:

Code: Select all

root@server17864:~# lsof -i :110
COMMAND    PID USER   FD   TYPE DEVICE SIZE NODE NAME
couriertc 6026 root    5u  IPv6  16809       TCP *:pop3 (LISTEN)
Auf dem Server kann ich das Ankommen von Mails in mail.log sehen, aber die Mails werden mir nicht zugestellt, und so kann ich sie nicht lesen.

Wenn ich ein Email von Outlook sende, sieht "mail.log" beim Server wie folgt aus:

Code: Select all

…
…
Feb 19 16:33:57 server17864 postfix/smtpd[6595]: master_notify: status 1
Feb 19 16:33:57 server17864 postfix/smtpd[6595]: connection closed
Feb 19 16:34:01 server17864 courierpop3login: LOGIN FAILED, ip=[::ffff:80.171.191.126]
Anscheinend Courier hat Probleme damit oder? Was Kann ich machen? Ich komme einfach nicht weiter.

Danke im Voraus

Gruß, Sandro.
Top