2 Probleme mit MySQL

siradam2k
Posts: 5
Joined: 2007-02-09 17:00

2 Probleme mit MySQL

Post by siradam2k »

Problem Nummer 1. phpMyAdmin gibt mir folgende Fehlermeldung #1045 - Access denied for user 'root'@'localhost' (using password: NO).

Wenn ich in der Konsole mysql -p und dann das Passwort nach der Aufforderung eingebe funktioniert es.

config.inc.php enthält auch das Passwort.

Problem nummer 2. ich habe keinen utf8 charset im Ordern /usr/share/mysql/charsets wo bekomme ich den her?

Habe einen Hetzner DS3000 mit openSuse 10.1 64 und die LAMP Version genommen, also webserver schon installiert.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: 2 Probleme mit MySQL

Post by Roger Wilco »

1. Du übergibst in phpMyAdmin kein Passwort, in der Shell schon...

2. Hast du eine MySQL Version >=4.1? Wenn ja, dann schau auch mal in /usr/share/mysql/charsets/Index.xml...
Top

siradam2k
Posts: 5
Joined: 2007-02-09 17:00

Re: 2 Probleme mit MySQL

Post by siradam2k »

Zu 1. Passwort steht doch aber in der config.inc.php ?

zu 2. Tatsächlich da gibt es utf8 :) Danke für den Hinweis.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: 2 Probleme mit MySQL

Post by Roger Wilco »

SirAdam2k wrote:Zu 1. Passwort steht doch aber in der config.inc.php ?
Dann hast du eine andere Einstellung falsch gesetzt. Die Meldung sagt eindeutig, dass kein Passwort übermittelt wurde. Zeig einfach deine config.inc.php (ohne Kommentare, in CODE-Tags).
Top

siradam2k
Posts: 5
Joined: 2007-02-09 17:00

Re: 2 Probleme mit MySQL

Post by siradam2k »

Oh mein Gott, bin ich doof.

Sie lag im falschen Verzeichnis. Tut mir echt leid. *g*

Sollte vielleicht doch ins Bett gehen :)

Danke auf jedenfall für deine Hilfe Roger Wilco
Top