Maildrop installieren

mf-scripts
Posts: 34
Joined: 2006-10-30 00:09

Maildrop installieren

Post by mf-scripts »

Ich versuche grade einen Mailserver auf die Beine zu bringen. Da ich es bei meinem ersten Server nie geschafft habe, hab ich jemanden Beauftragt. Aber da die Projekte da jetzt ncoh ein paar Wochen schmoren können (naja, die Performance, aber das muss dann halt etwas warten) hab ich etwas Zeit zum rumtesten.
Ich hab daher dieses Tut genutzt: http://rikman.mtb-news.de/rikwik/PostfixMailserver
Bei Maildrop scheiter ich aber im Moment bei
Nun kann der Quellcode kompiliert werden: apt-get source courier-maildrop -b
Das erzeugt Fehler und es geht nicht weiter. Ich weiß nicht, was ich da machen soll :roll:

Hier mal die Ausgabe nach dem ausführen des Befehls (und etwas später):
Fetched 6447kB in 0s (8170kB/s)
dpkg-source: extracting courier in courier-0.47
dpkg-buildpackage: source package is courier
dpkg-buildpackage: source version is 0.47-4sarge5
dpkg-buildpackage: source maintainer is Martin Schulze <joey@infodrom.org>
dpkg-buildpackage: host architecture is i386
dpkg-checkbuilddeps: Unmet build dependencies: libmysqlclient-dev | libmysqlclient10-dev
dpkg-checkbuilddeps: Build conflicts: automake1.4
dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: (Use -d flag to override.)
Build command 'cd courier-0.47 && dpkg-buildpackage -b -uc' failed.
E: Child process failed
Hat jemand eine Idee, was ich machen kann?
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Maildrop installieren

Post by Roger Wilco »

MF-Scripts wrote:dpkg-checkbuilddeps: Unmet build dependencies: libmysqlclient-dev | libmysqlclient10-dev
dpkg-checkbuilddeps: Build conflicts: automake1.4
Die beiden Meldungen sind doch recht eindeutig. Dir fehlen die Entwicklerpakete für MySQL (bzw. die MySQL-Clientbibliotheken) und die Version von AutoMake passt nicht.
Top

mf-scripts
Posts: 34
Joined: 2006-10-30 00:09

Re: Maildrop installieren

Post by mf-scripts »

Hab ich aber installliert. Und Automake1.8 ist installiert, oder muss es umbedingt die alte sein?
EDIT: hab auch neuere MySQL Entwicklerpakete. Muss ich das dafür jetzt extra downgraden?
Top