Schlechte Performance bei Apache's ab

Apache, Lighttpd, nginx, Cherokee
foobar
Posts: 44
Joined: 2007-01-24 18:52

Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-24 18:54

Hey,

habe mal meine Seite gebenchmarkt und erhalte irgendwie sehr schlechte Ergebisse. Wisst Ihr, woran das liegen könnte?

Code: Select all

localhost:/# ab -n 100 -c 10 http://www.domain.de/
This is ApacheBench, Version 2.0.41-dev <$Revision: 1.141 $> apache-2.0
Copyright (c) 1996 Adam Twiss, Zeus Technology Ltd, http://www.zeustech.net/
Copyright (c) 1998-2002 The Apache Software Foundation, http://www.apache.org/

Benchmarking www.domain.de (be patient).....done


Server Software:        Apache
Server Hostname:        www.domain.de
Server Port:            80

Document Path:          /
Document Length:        30602 bytes

Concurrency Level:      10
Time taken for tests:   7.653132 seconds
Complete requests:      100
Failed requests:        94
   (Connect: 0, Length: 94, Exceptions: 0)
Write errors:           0
Total transferred:      3054282 bytes
HTML transferred:       3019682 bytes
Requests per second:    13.07 [#/sec] (mean)
Time per request:       765.313 [ms] (mean)
Time per request:       76.531 [ms] (mean, across all concurrent requests)
Transfer rate:          389.64 [Kbytes/sec] received

Connection Times (ms)
              min  mean[+/-sd] median   max
Connect:        0   32 109.0      0     444
Processing:    60  645 718.3    492    3530
Waiting:        0  627 709.0    484    3525
Total:         60  678 711.1    548    3530

Percentage of the requests served within a certain time (ms)
  50%    548
  66%    700
  75%    757
  80%    806
  90%   1080
  95%   2818
  98%   3493
  99%   3530
 100%   3530 (longest request)
localhost:/#
Was mich vor allem stört, sind die vielen failed request. Woher kommen die?

Gruß

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Schlechte Performance bei Apache's ab

Post by Roger Wilco » 2007-01-24 19:57

foobar wrote:habe mal meine Seite gebenchmarkt und erhalte irgendwie sehr schlechte Ergebisse. Wisst Ihr, woran das liegen könnte?
Schlechte Konfiguration deines Webservers oder die Kiste ist einfach ausgelastet.
foobar wrote:Was mich vor allem stört, sind die vielen failed request. Woher kommen die?
Der Webserver nimmt keine Verbindungen mehr an oder antwortet nicht in der vorgegebenen Zeit.

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-24 20:09

Ausgelastet ... naja. Top:

Code: Select all

top - 20:08:34 up 9 days,  6:30,  1 user,  load average: 0.03, 0.11, 0.15
Tasks: 186 total,   1 running, 185 sleeping,   0 stopped,   0 zombie
Cpu(s):  5.0% us,  0.8% sy,  0.0% ni, 93.8% id,  0.3% wa,  0.0% hi,  0.1% si
Mem:    906636k total,   857476k used,    49160k free,    47028k buffers
Swap:  1951888k total,    10772k used,  1941116k free,   194368k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
18298 www-data  15   0 26472  11m 4352 S  2.0  1.3   0:03.21 apache2
    1 root      15   0  1588  524  456 S  0.0  0.1   0:00.93 init
    2 root      35  19     0    0    0 S  0.0  0.0   0:00.02 ksoftirqd/0
    3 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 events/0
    4 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kthread
   28 root      10  -5     0    0    0 S  0.0  0.0   0:00.16 kblockd/0
   44 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kseriod
  100 root      10  -5     0    0    0 S  0.0  0.0   0:06.29 kswapd0
  101 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 aio/0
  547 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 ksuspend_usbd
  555 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khubd
  639 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 ata/0
  641 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 ata_aux
  653 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_0
  654 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_1
  905 root      10  -5     0    0    0 S  0.0  0.0   0:29.68 kjournald
 1032 root      17  -4  1812  448  344 S  0.0  0.0   0:00.07 udevd
 1332 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 kpsmoused
 1809 root      16   0  1632  604  488 S  0.0  0.1   0:01.64 syslogd
 1812 root      17   0  2420 1332  348 S  0.0  0.1   0:00.06 klogd
 1858 root      18   0  1624  540  464 S  0.0  0.1   0:00.01 inetd
 1869 daemon    15   0  1772  344  280 S  0.0  0.0   0:00.00 atd
 1872 root      18   0  1824  760  612 S  0.0  0.1   0:00.15 cron
 1880 root      16   0  1584  488  424 S  0.0  0.1   0:00.00 getty
 1881 root      18   0  1588  492  424 S  0.0  0.1   0:00.00 getty
 1882 root      18   0  1588  492  424 S  0.0  0.1   0:00.00 getty
 1883 root      18   0  1588  492  424 S  0.0  0.1   0:00.00 getty
 1886 root      18   0  1584  488  424 S  0.0  0.1   0:00.00 getty
 1887 root      18   0  1584  488  424 S  0.0  0.1   0:00.00 getty
 2028 root      18   0  1620  484  420 S  0.0  0.1   0:00.02 inetd
 4341 root      16   0  7776 2112 1536 S  0.0  0.2   0:00.02 sshd
 4348 insanic   15   0  7936 1780 1164 S  0.0  0.2   0:01.14 sshd
 4349 insanic   15   0  3052 1624 1216 S  0.0  0.2   0:00.00 bash
 4355 root      15   0  3096 1688 1232 S  0.0  0.2   0:00.09 bash
 5836 root      16   0  2912  640  552 S  0.0  0.1   0:00.00 couriertcpd
 5838 root      18   0  2812  784  624 S  0.0  0.1   0:00.00 courierlogger
 5847 root      25   0  2908  628  544 S  0.0  0.1   0:00.00 couriertcpd
 5855 root      25   0  2680  620  472 S  0.0  0.1   0:00.00 courierlogger
 5856 root      16   0  2908  632  552 S  0.0  0.1   0:00.24 couriertcpd
 5858 root      18   0  2812  784  624 S  0.0  0.1   0:00.16 courierlogger
 5866 root      19   0  2908  636  552 S  0.0  0.1   0:00.01 couriertcpd
 5868 root      18   0  2808  780  624 S  0.0  0.1   0:00.01 courierlogger
 7490 root      17   0  1584  416  352 S  0.0  0.0   0:00.00 inetd
13035 postgres  15   0 17464 2260 1884 S  0.0  0.2   0:00.05 postmaster
13036 postgres  15   0  8264 1432  512 S  0.0  0.2   0:00.00 postmaster
13037 postgres  15   0  7272 1000  576 S  0.0  0.1   0:00.00 postmaster
13658 root      18   0 23264  10m 6584 S  0.0  1.2   0:00.20 apache2
13659 www-data  18   0 16064 3148  728 S  0.0  0.3   0:00.00 apache2
13661 www-data  15   0 26432  11m 4376 S  0.0  1.3   0:03.91 apache2
13664 www-data  15   0 26360  11m 4384 S  0.0  1.3   0:03.89 apache2
wohl eher schlecht konfiguriert, oder? Ist, soweit ich weiß, die Standardconfig, bis auf ein paar Änderungen in prefork.

Wie könnt Ihr mir nun helfen? Braucht Ihr meine Configs?!


foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-25 15:08

Könntest Du mir sagen, was ich da so einstellen soll? Denn woher soll ich wissen, was bei mir zur zeit falsch ist, bzw. welche Werte für meinen Server in Ordnung sind (ich müsste euch natürlich Anzahl der Domains, Anzahl der Zugriffe und Hardware nennen, richtig?).

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Schlechte Performance bei Apache's ab

Post by oxygen » 2007-01-25 16:10

Es hängt von sehr vielen Faktoren ab. Ein Kochrezept gibt es da nicht... da kommt man nur mit try & error zum Erfolg oder Jahre lange Erfahrung.
Weitere Faktoren wäre hier z.B. auch noch PHP und MySQL Konfiguration (ich geh einfach mal davon aus, dass es verwendet wird)

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-25 17:52

oxygen wrote:Es hängt von sehr vielen Faktoren ab. Ein Kochrezept gibt es da nicht... da kommt man nur mit try & error zum Erfolg oder Jahre lange Erfahrung.
Weitere Faktoren wäre hier z.B. auch noch PHP und MySQL Konfiguration (ich geh einfach mal davon aus, dass es verwendet wird)
Japp wird verwendet. Die jahrelange Erfahrung habe ich nicht, daher hoffte ich ja, dass ich hier auf Hilfe stoße :) Ich kann von imr aus die Configs posten oder irgendwelche Logs oder oder oder ... :D

User avatar
daemotron
Administrator
Administrator
Posts: 2635
Joined: 2004-01-21 17:44

Re: Schlechte Performance bei Apache's ab

Post by daemotron » 2007-01-25 19:18

foobar wrote:Was mich vor allem stört, sind die vielen failed request. Woher kommen die?
Das verraten Dir nur die Log-Dateien des Indianers... im access_log mal auf 400er und 500er Fehler achten, oder mal einen Blick ins error_log werfen...

Um das Problem methodisch einzukreisen, solltest Du erst mal sicherstellen, dass das Prolem nicht von MySQL oder PHP verursacht wird. Also: AB noch mal laufen lassen, diesmal mit ner statischen HTML-Seite. OK, die Ergebnisse werden performance-technisch wahrscheinlich deutlich besser sein, interessant ist vor allem, ob's noch zu so vielen failed requests kommt. Danach das gleiche Spiel mit einem PHP-Skript ohne MySQL-Zugriff und ohne Zugriff auf die diversen PHP-Module, dann sukzessive ein bisschen mehr einbauen, bis der Bösewicht entlarvt ist.

Parallel dazu mal MySQL möglichst optimal konfigurieren und Deine Skripte optimieren (siehe z. B. http://www.rootforum.org/forum/viewtopic.php?t=36343 ebenso wie http://dev.mysql.com/doc/refman/5.1/de/ ... ation.html) und mit den MySQL-Benchmarks mal die Leistunszuwächse Deines Datenbank-Setups überprüfen.

PHP so weit wie möglich abspecken (z. B. was das laden dynamischer Module angeht). Wie greift Apache auf PHP zu? Genauso solltest Du wo möglich auf das laden dynamischer Module für Apache verzichten (weil speicherintensiv), genauso wie auf exzessiven Gebrauch von mod_rewrite oder mod_security (weil rechenintensiv).

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-26 14:50

Öhm, mein Error Log ist 35MB und mein Access Log 2.5 GB oOO Soll ich die Dateien mal löschen oder so!? :D

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Schlechte Performance bei Apache's ab

Post by Joe User » 2007-01-26 15:20

foobar wrote:Öhm, mein Error Log ist 35MB und mein Access Log 2.5 GB oOO Soll ich die Dateien mal löschen oder so!? :D
man logrotate

BTW: Lighttpd kommt auch mit >3,5GB access_log ohne spührbaren Performanceverlust zurecht :roll:
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Schlechte Performance bei Apache's ab

Post by Roger Wilco » 2007-01-26 15:22

Joe User wrote:BTW: Lighttpd kommt auch mit >3,5GB access_log ohne spührbaren Performanceverlust zurecht :roll:
Der Apache httpd üblicherweise auch. ;)

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Schlechte Performance bei Apache's ab

Post by Joe User » 2007-01-26 16:41

Auch bei mehreren access_log (vHosts) dieser Grösse? Bei mir waren es bisher "nur" vier mit >3GB und bei Apache2 hatte ich damals bei mehreren grösseren access_log spührbare Verluste...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-26 16:47

Joe User wrote:
foobar wrote:Öhm, mein Error Log ist 35MB und mein Access Log 2.5 GB oOO Soll ich die Dateien mal löschen oder so!? :D
man logrotate

BTW: Lighttpd kommt auch mit >3,5GB access_log ohne spührbaren Performanceverlust zurecht :roll:
joa, lighttpd wollt ich mir evtl mal draufhaun. wie ich den neben apache installiere, dann umstelle und apache erstmal "verbanne" werd ich aber eher in nem anderen thread fragen oder? ist halt produktivsystem, da kann ich nicht apache deinstallieren, dann lighttpd installieren etc ...
muss meine rewrite rules auch erst für lighttpd umschreiben und dementsprechend testen ;)
ich nehme an, dass man .htaccess dateien mit sachen wie "order deny allow" ganz normal weiternutzten kann!?

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Schlechte Performance bei Apache's ab

Post by Roger Wilco » 2007-01-26 16:50

foobar wrote:ich nehme an, dass man .htaccess dateien mit sachen wie "order deny allow" ganz normal weiternutzten kann!?
Nein.

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-26 19:05

Shit, dann muss ich wohl einiges mehr umstellen als "nur" die Rewrite Rules ... :(

thorsten
Posts: 561
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: Schlechte Performance bei Apache's ab

Post by thorsten » 2007-01-26 19:28

Mein Apache sitzt vor dem CMS (Plone) und mit dem richtigen Caching bin ich von 1 Seiten/sec auf ~900 Seiten/sec für die Startseite gekommen.
Du solltest dir also - je nachdem ob das deine site erlaubt - mod_cache anschauen, das gibt einen richtigen boost!

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-30 19:25

Wow, hört sich gut an. WIe meinst Du, "je nachdem, ob Deine Seite das erlaubt"? Meine Seite ist teildynamisch. Teilweise müssen Dinge komplett dynamisch gehandhabt werden, und andere Dinge der Seite können wiederum gecacht werden. Ich arbeite mit Smarty und dort funktioniert das sehr gut, dass man in einem Template teilweise Dinge cachen kann und andere dynamisch bleiben :)

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-30 20:43

jfreund wrote:
foobar wrote:Was mich vor allem stört, sind die vielen failed request. Woher kommen die?
Das verraten Dir nur die Log-Dateien des Indianers... im access_log mal auf 400er und 500er Fehler achten, oder mal einen Blick ins error_log werfen...

Um das Problem methodisch einzukreisen, solltest Du erst mal sicherstellen, dass das Prolem nicht von MySQL oder PHP verursacht wird. Also: AB noch mal laufen lassen, diesmal mit ner statischen HTML-Seite. OK, die Ergebnisse werden performance-technisch wahrscheinlich deutlich besser sein, interessant ist vor allem, ob's noch zu so vielen failed requests kommt. Danach das gleiche Spiel mit einem PHP-Skript ohne MySQL-Zugriff und ohne Zugriff auf die diversen PHP-Module, dann sukzessive ein bisschen mehr einbauen, bis der Bösewicht entlarvt ist.

Parallel dazu mal MySQL möglichst optimal konfigurieren und Deine Skripte optimieren (siehe z. B. http://www.rootforum.org/forum/viewtopic.php?t=36343 ebenso wie http://dev.mysql.com/doc/refman/5.1/de/ ... ation.html) und mit den MySQL-Benchmarks mal die Leistunszuwächse Deines Datenbank-Setups überprüfen.

PHP so weit wie möglich abspecken (z. B. was das laden dynamischer Module angeht). Wie greift Apache auf PHP zu? Genauso solltest Du wo möglich auf das laden dynamischer Module für Apache verzichten (weil speicherintensiv), genauso wie auf exzessiven Gebrauch von mod_rewrite oder mod_security (weil rechenintensiv).
Hab mich mal ein wenig rangemacht.

-Statische HTML Seite: 0 / 100 failed Requests
-PHP Seite mit phpinfo() drin un sowas: 0 / 100 failed Requests
-PHP Seite: Includieren einer PHP Seite, die relativ viele Klassen lädt und auch eine MySQL Verbindung: 0 / 100 failed Requests
-PHP Seite wie zuvor mit einem MySQL Query, der 100 Einträge aus einer Tabelle ausliest: 0 / 100 failed Requests.

Meine /etc/mysql/my.cnf:

Code: Select all


# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
set-variable=local-infile=0
max_connections=2500
set-variable = table_cache=256
set-variable = sort_buffer=4M

#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
language        = /usr/share/mysql/english
skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords   = 1
#
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 127.0.0.1
#
# * Fine Tuning
#
key_buffer              = 128M
max_allowed_packet      = 16M
thread_stack            = 128K

# * InnoDB abschalten *
skip-innodb
# * Show Databases abschalten *
skip-show-database
# Standard Tabellentyp
default_table_type    = MYISAM

#
# * Geschwindigkeitstuning by bj *
#
sort_buffer_size      = 8M
join_buffer_size      = 8M
read_buffer_size      = 8M
myisam_sort_buffer_size = 64M
myisam_max_sort_file_size = 1G
myisam_max_extra_sort_file_size = 1G
myisam_repair_threads = 1

#
# * Query Cache Configuration
#
query_cache_limit       = 1048576
query_cache_size        = 32MB
query_cache_type        = 1

#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log            = /var/log/mysql.log
#log            = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
log-slow-queries        = /var/log/mysql/mysql-slow.log
long_query_time       = 3
log_slow_queries
log_long_format
#
# The following can be used as easy to replay backup logs or for replication.
#server-id              = 1
log-bin                 = /var/log/mysql/mysql-bin.log
# See /etc/mysql/debian-log-rotate.conf for the number of files kept.
max_binlog_size         = 104857600
#binlog-do-db           = include_database_name
#binlog-ignore-db       = include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem


[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 16M
Weiß nun leider nicht mehr, woran es noch liegen könnte ... Der Benchmark der Seite ist und bleibt schlecht :(

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-30 20:45

Achso, und Module des Apaches habe ich auch mal fast alle deaktiviert (brauche die meisten nicht und habe denen einfach .bak angehängt, sodass diese nicht mehr geladen werden):

Code: Select all

localhost:/etc/apache2/mods-enabled# ls -l
total 0
lrwxrwxrwx  1 root root 40 2007-01-15 17:08 actions.load -> /etc/apache2/mods-available/actions.load
lrwxrwxrwx  1 root root 36 2007-01-15 17:08 cgi.load.bak -> /etc/apache2/mods-available/cgi.load
lrwxrwxrwx  1 root root 38 2007-01-15 17:19 fcgid.conf.bak -> /etc/apache2/mods-available/fcgid.conf
lrwxrwxrwx  1 root root 38 2007-01-15 17:19 fcgid.load.bak -> /etc/apache2/mods-available/fcgid.load
lrwxrwxrwx  1 root root 40 2007-01-15 17:10 include.load.bak -> /etc/apache2/mods-available/include.load
lrwxrwxrwx  1 root root 36 2007-01-15 17:17 jk2.conf.bak -> /etc/apache2/mods-available/jk2.conf
lrwxrwxrwx  1 root root 36 2007-01-15 17:17 jk2.load.bak -> /etc/apache2/mods-available/jk2.load
lrwxrwxrwx  1 root root 33 2007-01-15 17:17 mod_python.load.bak -> ../mods-available/mod_python.load
lrwxrwxrwx  1 root root 37 2007-01-15 17:09 perl.conf.bak -> /etc/apache2/mods-available/perl.conf
lrwxrwxrwx  1 root root 37 2007-01-15 17:09 perl.load.bak -> /etc/apache2/mods-available/perl.load
lrwxrwxrwx  1 root root 37 2007-01-15 17:09 php4.conf -> /etc/apache2/mods-available/php4.conf
lrwxrwxrwx  1 root root 37 2007-01-15 17:09 php4.load -> /etc/apache2/mods-available/php4.load
lrwxrwxrwx  1 root root 40 2007-01-15 17:08 rewrite.load -> /etc/apache2/mods-available/rewrite.load
lrwxrwxrwx  1 root root 36 2007-01-15 17:09 ssl.load.bak -> /etc/apache2/mods-available/ssl.load
lrwxrwxrwx  1 root root 39 2007-01-15 17:10 suexec.load.bak -> /etc/apache2/mods-available/suexec.load
lrwxrwxrwx  1 root root 40 2007-01-15 17:08 userdir.conf -> /etc/apache2/mods-available/userdir.conf
lrwxrwxrwx  1 root root 40 2007-01-15 17:08 userdir.load -> /etc/apache2/mods-available/userdir.load
localhost:/etc/apache2/mods-enabled#


oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Schlechte Performance bei Apache's ab

Post by oxygen » 2007-01-30 21:01

Auch wenn es kaum zur Lösung beiträgt. Ich kann mir kaum vorstellen, dass du mod_jk2 oder mod_perl brauchst. fcgid/userdir wahrscheinlich auch nicht.
Um was für eine Seite handelt es sich denn? Am besten postest du einfach mal den Link. Wahrscheinlich ist weniger die Konfiguration deines Servers das Problem, sondern die Site selber.
Ansonsten bleibt noch der Punkt PHP abspecken. Möglicherweise könnte auch ein OpCode Cache was bringen.

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-30 21:36

Ja, ich denke auch nicht, dass ich diese Module brauche. Daher habe ich diese auch umbenannt, damit sie nicht mehr geladen werden (oder werden sie das etwa immernoch!? obwohl ich .bak angehängt habe?!).

PHP abspecken ... wie ist das möglich? Sicher, dass es das istz? Der Benchmark der PHP Datei lief ja auch einwandfrei eigentlich ...

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Schlechte Performance bei Apache's ab

Post by oxygen » 2007-01-30 21:42

foobar wrote:Ja, ich denke auch nicht, dass ich diese Module brauche. Daher habe ich diese auch umbenannt, damit sie nicht mehr geladen werden (oder werden sie das etwa immernoch!? obwohl ich .bak angehängt habe?!).
Achso. Ist mir gar nicht aufgefallen.
Weiß jetzt nicht wie SuSE das handhabt. Sprich ob Include /etc/apache2/mods-enabled/* oder Include /etc/apache2/mods-enabled/*.[conf|load] in der httpd.conf steht (oder etwas ganz anderes).
Wenn ich mich recht errinnere handelt YaST/sysconfig das Modul aktivieren/deaktivieren.

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-30 22:09

Ich hab Debian ;) Aber ich glaube, er lädt sie nicht, da er vorhin rumgemotzt hat, als ich eine .load in .load.bak und die conf normal gelassen habe, von wegen, es müsse zu der .conf eine .load existieren (anstatt dass er halt einafch die .load.bak nutzt).

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Schlechte Performance bei Apache's ab

Post by oxygen » 2007-01-30 23:22

Bin irgendwie wohl etwas durcheinander heut. Hätte ich eigentlich an der Verzeichnisstruktur sehen müssen... Bei Debian gibts a2enmod / a2dismod zur Verwaltung der Apache Module.

foobar
Posts: 44
Joined: 2007-01-24 18:52

Re: Schlechte Performance bei Apache's ab

Post by foobar » 2007-01-31 17:47

Ja, habs gerade ausprobiert. Das bewirkt genau das selbe, wie wenn ich die zu ladenden Dateien umbenenne ;)