Server(debian,Strato) friert ein bzw. ist erst nach restart wieder erreichbar. Was koennte die Ursac

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
sicaine
Posts: 5
Joined: 2004-12-11 20:14

Server(debian,Strato) friert ein bzw. ist erst nach restart wieder erreichbar. Was koennte die Ursac

Post by sicaine » 2007-01-15 23:10

Hi,

Rootserver bei Strato, Debian upToDate.
Laufen tut auf den Server: Apache, MySQL, sshd, postfix, proftpd, psybnc. nix grossartiges also.
Sicherheitstechnisch ist der sshport umgelegt, Server is debianmaesig upToDate(nur stable) und ich bekomm taeglich trafficmails die mir sagen, dass da nix aussergewoehnliches da ist. Zudem ist das schon 3x in gut nem Jahr passiert und mitlerweile will ich sehr gerne wissen was los ist. In der syslog selbst steht nichts drin und in allen accesslogs steht auch nichts(zu der Zeit) drin was nach nem ausnutzen von php aussehen koennte.

Jemand Idee was man machen koennte?

timeless2
Posts: 416
Joined: 2005-03-04 14:45
Location: Paris

Re: Server(debian,Strato) friert ein bzw. ist erst nach restart wieder erreichbar. Was koennte die U

Post by timeless2 » 2007-01-15 23:41

Also bisher dreimal innerhalb eines Jahres, das kann theoretisch viel sein, du musst das Problem irgendwie eingrenzen. Hardwareprobleme können in den Logs auftauchen, aber es kann auch was ein, wie ein kaputter Lüfter o.ä., das z.B. bei großer Last bemerkbar wird.

franki
Posts: 60
Joined: 2005-05-31 16:23
Location: Dresden

Re: Server(debian,Strato) friert ein bzw. ist erst nach restart wieder erreichbar. Was koennte die U

Post by franki » 2007-01-16 13:48

Ich tippe auch auf Festplatte (was sagt smartctl -A) oder RAM. Mit dem Lüfter glaub ich nicht, dann müßte er regelmäßig nach ein paar Stunden stehenbleiben und nicht nur 3 mal im Jahr. Wir hatten hier einen Server, der lief jahrelang ohne Probleme, bis er dann anfing, gelegentlich einzufrieren. Memtest hat dann Speicherfehler gefunden, den RAM getauscht und alles ging wieder.

Gruß von Franki.

sicaine
Posts: 5
Joined: 2004-12-11 20:14

Re: Server(debian,Strato) friert ein bzw. ist erst nach restart wieder erreichbar. Was koennte die U

Post by sicaine » 2007-01-17 00:35

Ram? Ich wuesst nur wie ich Ram mit memtest testen kann und dazu muesste ich in die recoveryconsole bzw. wird da wohl nich mal nen Booteintrag drinstehen mmmhhhh : |

Hmmmm dd gibt mir ne Rate von 35mb/s aus und smartctl zeigt bei den Fehlerraten jeweils 0. Das einzige was ich Fehlermaesig finden konnte sind folgende Logs. Dabei vermute ich wohl mal auf die Schnelle, dass das von den Reboots kommt:

Code: Select all

Error 39 occurred at disk power-on lifetime: 0 hours (0 days + 0 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 59 01 64 00 00 e0  Error: UNC at LBA = 0x00000064 = 100

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  21 44 01 64 00 00 e0 00      00:00:37.800  READ SECTOR(S) [OBS-5]
  32 44 01 64 00 00 e0 00      00:00:37.700  WRITE LONG(w/ retry) [OBS-4]
  ef 44 00 11 ff ff e0 00      00:00:37.700  SET FEATURES [Length of VS data] [OBS-4]
  fb ac 01 02 ff ff e0 00      00:00:37.700  [VENDOR SPECIFIC]
  fa ac 01 64 ff ff e0 00      00:00:37.700  [VENDOR SPECIFIC]

Error 38 occurred at disk power-on lifetime: 0 hours (0 days + 0 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 59 01 64 00 00 e0  Error: UNC at LBA = 0x00000064 = 100

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  21 44 01 64 00 00 e0 00      00:00:37.500  READ SECTOR(S) [OBS-5]
  32 44 01 64 00 00 e0 00      00:00:37.500  WRITE LONG(w/ retry) [OBS-4]
  ef 44 00 11 ff ff e0 00      00:00:37.500  SET FEATURES [Length of VS data] [OBS-4]
  fb ac 01 02 ff ff e0 00      00:00:37.500  [VENDOR SPECIFIC]
  fa ac 01 64 ff ff e0 00      00:00:37.500  [VENDOR SPECIFIC]

Error 37 occurred at disk power-on lifetime: 0 hours (0 days + 0 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 59 01 64 00 00 e0  Error: UNC at LBA = 0x00000064 = 100

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  21 44 01 64 00 00 e0 00      00:00:37.300  READ SECTOR(S) [OBS-5]
  32 44 01 64 00 00 e0 00      00:00:37.300  WRITE LONG(w/ retry) [OBS-4]
  ef 44 00 11 ff ff e0 00      00:00:37.200  SET FEATURES [Length of VS data] [OBS-4]
  fb ac 01 02 ff ff e0 00      00:00:37.200  [VENDOR SPECIFIC]
  fa ac 01 64 ff ff e0 00      00:00:37.200  [VENDOR SPECIFIC]

Error 36 occurred at disk power-on lifetime: 0 hours (0 days + 0 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 59 01 64 00 00 e0  Error: UNC at LBA = 0x00000064 = 100

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  21 44 01 64 00 00 e0 00      00:00:37.100  READ SECTOR(S) [OBS-5]
  32 44 01 64 00 00 e0 00      00:00:37.000  WRITE LONG(w/ retry) [OBS-4]
  ef 44 00 11 ff ff e0 00      00:00:37.000  SET FEATURES [Length of VS data] [OBS-4]
  fb ac 01 02 ff ff e0 00      00:00:37.000  [VENDOR SPECIFIC]
  fa ac 01 64 ff ff e0 00      00:00:37.000  [VENDOR SPECIFIC]