PHP compile Problem fcgi wird zu cli

Apache, Lighttpd, nginx, Cherokee
aubergine
Posts: 471
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

PHP compile Problem fcgi wird zu cli

Post by aubergine » 2007-01-14 23:57

Hi,

ich möchte mein PHP als cgi-fcgi kompilieren.
Es dreht sich um php-5.2.0 und php-4.4.4

In beiden Config Scripten habe ich --enable-fastcgi mit reingeschrieben.

Dennoch ergibt ein php -v bei beiden PHP Versionen nach dem compilen:

Code: Select all

sh-3.1$ ./php -v
PHP 5.2.0 (cli) (built: Jan 14 2007 23:49:02)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
Das selbe gilt für meine PHP 4.4.4 Version die ich mit der selben config compiliert habe.

Ich finde jetzt das Problem nicht und bitte euch um Hilfe.

Die config.nice sieht so aus:

Code: Select all

'./configure' 
'--prefix=/home/php5/php5.2.0' 
'--with-apxs2=/home/apache/apache2.2.4/bin/apxs' 
'--with-mysql=/home/mysql4/mysql-max-4.1.22-pc-linux-gnu-i686' 
'--with-regex=php' 
'--with-config-file-path=/home/php5/php5.2.0' 
'--disable-rpath' 
'--enable-memory-limit' 
'--disable-debug' 
'--with-layout=GNU' 
'--with-pear=/home/php5/php5.2.0' 
'--enable-calendar' 
'--enable-sysvsem' 
'--enable-sysvshm' 
'--enable-track-vars' 
'--enable-trans-sid' 
'--enable-bcmath' 
'--with-bz2-path=/usr' 
'--enable-ctype' 
'--with-iconv' 
'--enable-exif' 
'--enable-filepro' 
'--enable-ftp' 
'--with-gettext' 
'--enable-mbstring=all' 
'--enable-shmop' 
'--enable-sockets' 
'--enable-wddx' 
'--enable-xml' 
'--with-xml' 
'--enable-yp' 
'--with-zlib' 
'--without-pgsql' 
'--with-openssl=/usr' 
'--disable-static' 
'--with-curl=shared,/usr' 
'--with-dom' 
'--with-zlib-dir=/usr' 
'--with-gd=/usr' 
'--with-jpeg-dir=shared,/usr' 
'--with-xpm-dir=shared,/usr/X11R6' 
'--with-png-dir=shared,/usr' 
'--with-freetype-dir=shared,/usr' 
'--enable-imap' 
'--with-imap=/usr/local/imap-2004g' 
'--with-imap-ssl=/usr/include/openssl' 
'--with-ldap=shared,/usr' 
'--with-mcal=shared,/usr' 
'--with-mhash=shared,/usr' 
'--without-mm' 
'--enable-xslt=shared' 
'--with-xslt-sablot=shared,/usr' 
'--with-ttf=shared,/usr' 
'--enable-memory-limit' 
'--enable-force-cgi-redirect' 
'--enable-track-vars' 
'--with-pcre-regex' 
'--without-sqlite' 
'--enable-fastcgi' 
'--with-mycrypt' 
'--with-t1ib=shared,/usr' 
"$@"
Wer weiss um Rat?

aubergine
Posts: 471
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

Re: PHP compile Problem fcgi wird zu cli

Post by aubergine » 2007-01-15 03:12

Also mit einer minimalistischen config klappt es wunderbar.

Irgendeiner der Werte in meiner config.nice oben muss dafür sorgen das PHP trotzdem als cli kompiliert wird.

Leider konnte ich bis jetzt nicht rausfinden welcher das ist.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: PHP compile Problem fcgi wird zu cli

Post by Joe User » 2007-01-15 11:04

--enable-cgi fehlt.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

aubergine
Posts: 471
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

Re: PHP compile Problem fcgi wird zu cli

Post by aubergine » 2007-01-15 14:19

Joe User wrote:--enable-cgi fehlt.
Hab dies der oben geposteten config hinzugefügt, doch leider nach wie vor nach dem compilieren:

Code: Select all

sh-3.1$ ./php -v
PHP 5.2.0 (cli) (built: Jan 15 2007 14:16:33)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

User avatar
daemotron
Administrator
Administrator
Posts: 2635
Joined: 2004-01-21 17:44

Re: PHP compile Problem fcgi wird zu cli

Post by daemotron » 2007-01-15 14:39

Wird vielleicht für (Fast)CGI ein separates Binary erstellt? Könnte php-cgi oder php-fcgi heißen...

aubergine
Posts: 471
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

Re: PHP compile Problem fcgi wird zu cli

Post by aubergine » 2007-01-15 15:28

Problem wurde gelöst.
'--with-apxs2=/home/apache/apache2.2.4/bin/apxs'

Darf nicht mit drin stehen sonst wird es immer ein cli Binary wenn das Modul gebaut wird.

Ohne klappt es wunderbar.

Vielen Dank für alle Helfenden.