HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern festgest

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
moppi
Posts: 368
Joined: 2003-02-15 11:16

HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern festgest

Post by moppi » 2007-01-13 13:28

Hallo Leute,

ich habe mir Stundenlang den Kopf zerbrochen, wie ich endlich von Fedora Core 4 wegkomme und mich nicht mit der Standardinstallation rumschlagen muss. ;)

Meine Lösung ist easy und kann jeder nachvollziehen. Es handelt sich um ein von mir modifiziertes diskboot.img.

Folgender Ablauf für die Installation von CentOS4.4 mit Plesk 8.1.0, wichtig ist dabei, Du musst zwei SATA Festplatten haben.

1. Rescue System booten
2. Dateien runterladen:

Code: Select all

wget http://rindt.name/fileadmin/download/ks-cos44-i686-oao-server-softraid-plesk81.img
wget http://rindt.name/fileadmin/download/ks-cos44-i686-oao-server-softraid-plesk81.img.sha1
3. die Datei auf die 1. Platte schreiben

Code: Select all

dd if=ks-cos44-i686-oao-server-softraid-plesk81.img of=/dev/sda
4. Vom Rescue System auf Normalsystem umschalten
5. Server rebooten und nach ca. 30 Minuten ist das System installiert. Das neue Rootkennwort lautet:

Code: Select all

kant0815
6. Plesk installieren der Autoinstaller befindet sich in:

Code: Select all

/root/plesk
Auf der Seriellen Konsole kann man der Installation zuschauen. Die Anleitung ist nicht perfekt und auch nur ein paar mal getestet. Ich konnte keine Fehler feststellen.

Viel Spaß beim ausprobieren. Feedback erwünscht.
Daniel
Last edited by moppi on 2007-01-16 14:32, edited 4 times in total.

moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by moppi » 2007-01-14 13:16

für alle Voyeuristen :roll: die gerne gern was zum gucken haben, gibt es nun auch eine Version die den kompletten Installationsvorgang auf der Seriellen Konsole anzeigt.

EDIT: Diese Funktion ist inzwischen bereits in der obigen Version eingebaut.

Ein Hinsweis noch, es geht nicht ohne das man im Rescue bootet. In einem von sda laufenden System ist es nicht möglich via dd die Daten dort korrekt aufzuspielen. Nach einem Neustart schlägt das Booten fehl.
Daher ist es dringend zu empfehlen das Image im Rescue System aufzuspielen.

Auf Verlangen hin würde ich auch gern hier ein HOWTO erstellen, wo komplett beschrieben wird, wie man mit bestehenden Daten in PLESK auf CentOS umsattelt in wenigen Minuten.
Last edited by moppi on 2007-01-16 14:41, edited 1 time in total.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by Joe User » 2007-01-14 14:06

PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by moppi » 2007-01-14 14:18

ich wollte sicherstellen das ich mir nicht Arbeit mache die hinterher auf Ablehnung stößt aus gewissen Gründen da PLESK kommerzielles Produkt und blah man kennt es ja aus anderen Foren/ Chats etc.

In den kommenden Tagen/ Stunden steht das dort. Im Wiki muss ich mich separat anmelden?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by Joe User » 2007-01-14 14:20

Moppi wrote:Im Wiki muss ich mich separat anmelden?
Ja.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Anonymous

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by Anonymous » 2007-01-15 18:12

Auf eine Anleitung, wie Du das Image erstellt hast und dann installierst wäre ich auch gespannt.
Habe ich das richtig verstanden, dass Dein Rootserver zwei Platten hat? bzw. hast Du das Raid deaktiviert?

Viele Grüße
sceddie

moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by moppi » 2007-01-16 12:29

Der Rootserver hat 2 Platten ja 2x SATA. Ich musste jedoch feststellen das 1&1 verschiedene Hardware bei den 1&1 Systemen einsetzt. So scheint es derzeit das der Kernel in dem Image bei eingier Hardware nicht richtig die Module lädt. Und damit die Installation versagt.

Zu dem Image ganz kurz unter dem Ordner /images auf der 1 Installations CD bzw. DVD ist eine Datei diskboot.img die darin enthaltene Datei syslinux.cfg habe ich nur angepasst. Damit macht das Teil via Kickstart eine völlig saubere Installation inkl. Software Raid versteht sich. ;)

Schön wäre es, wenn mir jemand ein Feedback geben könnte, da ich leider nicht alle 1&1 Hardware durchtesten kann sondern nur hier lokal auf ähnlichen Systemen.

P.S.: Das Image musst Du nicht selbst erstellen, Du kannst das Image wie o.g. verwenden. Und der Rest ist wirklich leicht.

Anonymous

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by Anonymous » 2007-01-16 17:18

Ah ok, als ich habe in meinem ein Hardware- und kein Software-Raid, daher siehst Du wahrscheinlich auch Deine zweite Platte ... mir bleibt nur 1&1 zu vertrauen ;-)

Das Image (Deins und das Original) hat bei mir Chaos in der Partitionstabelle ausgelöst, so dass ich es nicht mounten (und damit bearbeiten kann um z.B. die Installerdateien lokal abzulegen) kann:

Code: Select all

fdisk -l

Disk /dev/sda: 200.0 GB, 200048599040 bytes
64 heads, 32 sectors/track, 190781 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   ?     2073900     2016610  2088818490    1  FAT12
Partition 1 does not end on cylinder boundary.
/dev/sda2   ?      524399      402857  2023024920+  42  SFS
Partition 2 does not end on cylinder boundary.
/dev/sda3   ?      830862      831183      329394   6f  Unknown
Partition 3 does not end on cylinder boundary.
/dev/sda4          682795     1215803   545800106+  49  Unknown
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order

Dennoch funktioniert dann bei mir der Installerscreen über die Konsole (mit Deinem Image getestet). Weit komme ich allerdings nicht, da ich offensichtlich kein Netzwerk habe. (Kann mich nicht anpingen und komme auch nicht nach aussen). Liegt das an der queren Konfig des Gateways, der in einem anderen Subnetz liegt als die Server-IP?

Hat da jemand noch eine Idee, ich bin am Verzweifeln!! 1und1 sagt sie haben keine Centos Images :-(

Noch ein kleiner Nachtrag, mit Deinem neusten Image bleibt der Installer bei :

Code: Select all

+-----------------+ Rechnername +------------------+
|                                                  |
| Rechnername und Domäne werden ermittelt...       |
|                                                  |
+--------------------------------------------------+

stehen. Vermutlich das Problem mit der Netzwerkkarte?

Nachtrag2:
Im Rescue System sehe ich, dass es folgende Karte/Treiber sein müßte:

Code: Select all

r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
GSI 16 sharing vector 0xC1 and IRQ 16
ACPI: PCI Interrupt 0000:00:09.0[A] -> GSI 19 (level, low) -> IRQ 193
eth0: Identified chip type is 'RTL8169s/8110s'.
eth0: RTL8169 at 0xffffc200005dc000, 00:30:05:be:46:be, IRQ 193
Fehlt der vielleicht in dem Image? Wie bekomme ich den da rein?

moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: HOWTO: CentOS4.4 x86 installieren auf 1&1 Server (Probleme mit NIC auf einigen Servern fest

Post by moppi » 2007-01-16 20:37

Du brauchst das Image nur auf die Harddisk kopieren wie Du schon richtig getan hast und neustarten es ist nicht mehr erforderlich.
Allerdings Ist das Image für Server mit 2 Platten.

Ich müsste für dein Server ein separates Image bauen. Musst Du nur sagen.
Wäre schön wenn Du mir weiterhelfen kannst zu dem Thema mit der Netzwerkkarte und kann man in der Seriellen Konsole eigentlich mit Alt + F3 auf andere Konsolen wechseln? Denn auf der tty3 steht was anaconda (Installer) gerade macht. Da steht dann auch ob das modul r8169 geladen ist für die Netzwerkkarte. Das Modul ist definitiv dabei.

Danke für Deine Mithilfe.