Postfix Suse 9.3 sendmail Konflikt

virtual evil
Posts: 9
Joined: 2006-03-07 15:52
Location: Hamburg

Postfix Suse 9.3 sendmail Konflikt

Post by virtual evil »

Hallo zusammen,

ich habe versucht auf einem Suse 9.3 Server Postfix mit MySQL Support zu installieren. Über Yast kein Problem, leider da ohne MySQL-Unterstützung. Also doch händisch, habe mir also das RPM besorgt und wollte mit

Code: Select all

rpm -U postfix-2.2.1-3.1.MySQL.i586.rpm
direkt loslegen - Pustekuchen. :-(

Code: Select all

rpmdb: illegal flag specified to DB->cursor
error: db4 error(22) from db->cursor: Invalid argument
error: Failed dependencies:
        sendmail conflicts with postfix-2.2.1-3.1.MySQL
Offensichtlich besteht ein Konflikt mit sendmail, das aber gar nicht mehr installiert ist, zumindest sagt Yast das, und auch

Code: Select all

rpm -e sendmail sendmail-doc sendmail-cf --nodeps
error: package sendmail is not installed
error: package sendmail-doc is not installed
error: package sendmail-cf is not installed
...

Kann mir jemand helfen?
Top

virtual evil
Posts: 9
Joined: 2006-03-07 15:52
Location: Hamburg

Re: Postfix Suse 9.3 sendmail Konflikt

Post by virtual evil »

Zusatz:

Das Problem mit Sendmail ist leider immer noch nicht gelöst. Allerdings hat ein

Code: Select all

rpm --rebuilddb
zumindest die anderen Meldungen eleminiert, so dass die neue Meldung nun folgende ist:

Code: Select all

error: Failed dependencies:
        sendmail conflicts with postfix-2.2.1-3.1.MySQL
Freue mich über jeden Vorschlag, da ich leider keine Ahnung hab wie ich das Problem sonst lösen soll. :?

Vielen Dank!
Top