Telnet funktioniert nicht !

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Telnet funktioniert nicht !

Post by langebeine »

Juten Nabend,

ich habe ein Problem und zwar habe ich bzw bin gerade dabei nach einem Howto ein E-Mail server zuinstallieren. Wenn ich im Telnet mail from: test@myserver eingebe passiert nix weiter auch kein Disconnect. Hier mal meine Auszüge aus der mail.err:

Code: Select all

Dec 29 18:02:57 myserver postfix/trivial-rewrite[28226]: fatal: mysql:/etc/postfix/mysql-virtual_forwardings.cf(0,100): table lookup problem
Dec 29 18:03:58 myserver postfix/trivial-rewrite[27284]: fatal: mysql:/etc/postfix/mysql-virtual_forwardings.cf(0,100): table lookup problem
Dec 29 18:04:59 myserver postfix/trivial-rewrite[10211]: fatal: mysql:/etc/postfix/mysql-virtual_forwardings.cf(0,100): table lookup problem
Dec 29 18:06:00 myserver postfix/trivial-rewrite[9770]: fatal: mysql:/etc/postfix/mysql-virtual_forwardings.cf(0,100): table lookup problem
und so sieht die forwarding Datei aus:

Code: Select all

user = provider_admin
password = password
dbname = provider
table = forwardings
select_field = destination
where_field = source
hosts = localhost
Habe auch die Local IP bei hosts eingetragen aber ohne erfolg.
Hier mal meine Main.cf:

Code: Select all

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
delay_warning_time = 1h

myhostname = myserver
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = myserver, localhost.myserver, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
Nu stehe ich vor einer Tür und komme nicht mehr rein :(
hat jemand noch evt ein Tip für mich ?

Gruß
Langebeine
Top

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: Telnet funktioniert nicht !

Post by snowball »

Mhh, ich kenne die Antwort auf dein Problem leider auch nicht direkt, aber der Fehler: "table lookup problem" sagt, das der MTA nicht an die Datenbank kommt.
Hast du schonmal versucht, dich mit den Zugangsdaten zur DB zu verbinden? Hast du dann auch Zugriff auf die Tabelle?
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Ja verbindung habe, mit jeder anderen Software (phpmyadmin, meine website) können sich mit der Datenbank verbinden. Es ist zum Harre ausreißen.
Auch wenn ich beim host die ip oder den Servernamen eintrage bring nix :(
Top

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: Telnet funktioniert nicht !

Post by snowball »

Tja, vielleicht hat hier jemand noch einen Tipp wie man schneller an die Lösung kommt.

Mein nächster Schritt wäre, das Logging der SQL-Statements in der DB an zu schallten (ist ein eintrag in der my.cnf), mitloggen lassen, wie das Statement aussieht un das mal manuell an die Datenbank schicken. Ich vermute, das da irgentwo ein Tippfehler drinn ist.
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Sorry, bin noch nicht zu sehr begabt mit der mysql conf. hier mal die conf:

Code: Select all

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
language        = /usr/share/mysql/english
#skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords   = 1
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 127.0.0.1
#
# * Fine Tuning
#
key_buffer              = 16M
max_allowed_packet      = 16M
thread_stack            = 128K
#
# * Query Cache Configuration
#
query_cache_limit       = 1048576
query_cache_size        = 16777216
query_cache_type        = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log            = /var/log/mysql.log
#log            = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log-slow-queries       = /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id              = 1
log-bin                 = /var/log/mysql/mysql-bin.log
# See /etc/mysql/debian-log-rotate.conf for the number of files kept.
max_binlog_size         = 104857600
#binlog-do-db           = include_database_name
#binlog-ignore-db       = include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 16M
mehr steht leider nicht in der conf :([/quote]
Top

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: Telnet funktioniert nicht !

Post by snowball »

Naja, google sagt, man könnte es auch in die my.cnf schreiben (log-slow-queries) aber die doku zu mysql sagt:
das hier

Edit: Vieleicht hilft dir das hier ja auch weiter
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Edit: Vieleicht hilft dir das hier ja auch weiter
Ja Danke :) wurde etwas fündig, läuft in der chroot umgebung und Mysql kann dort zuzusagen nicht hin. Daher habe ich noch eine FRage wie erstelle ich vernünftig ein Link ohne das er nachem Reboot verschwindet ?
Top

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: Telnet funktioniert nicht !

Post by snowball »

langebeine wrote:wie erstelle ich vernünftig ein Link ohne das er nachem Reboot verschwindet ?

Code: Select all

ln -s
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Telnet funktioniert nicht !

Post by daemotron »

Alternative: Du lässt Postfix via TCP auf MySQL zugreifen. Dazu muss allerdings MySQL auf 127.0.0.1:3306 lauschen, und der entsprechende User muss als Host 127.0.0.1 eingetragen haben (MySQL unterscheidet zwischen '127.0.0.1' und 'localhost').
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Hallo und Guten Morgen,

jfreund
ist richtig beim Mysql User habe ich als Host localhost eingegeben und in der Datei die locale IP. Wenn ich mysql über tcp laufen lassen will brauche ich doch nur den port hinter der Localen IP anhängen in der my.cnf ?
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Telnet funktioniert nicht !

Post by Joe User »

RTFM!

MySQL nutzt localhost ausschliesslich zur Kommunikation per UNIX-Socket und 127.0.0.1 zur Kommunikation per TCP/IP.

Sowohl der MySQL-User als auch der MySQLd müssen die gleiche Kommunikationsart, in Deinem Fall TCP/IP, nutzen. Ergo ist Dein MySQL-User falsch angelegt. Dein MySQLd ist bereits richtig konfiguriert.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Vielen Dank Joe User,
nach dem ich Data eingebe über telnet ein kommt pflicht mäßig diese Meldung:
354 End data with <CR><LF>.<CR><LF>. Danach gebe ich ein text ein und Drücke auf Enter. diesr Lookup fehler ist aus der Welt geschaft und nu steht dies in den Logs:

Code: Select all

Dec 30 13:41:19 myserver postfix/smtpd[5430]: connect from p57A2E4DA.dip.t-dialin.net[87.162.228.218]
Dec 30 13:42:28 myserver postfix/smtpd[5430]: DE0E885C011: client=p57A2E4DA.dip.t-dialin.net[87.162.228.218]
Dec 30 13:48:04 myserver postfix/smtpd[5430]: lost connection after DATA from p57A2E4DA.dip.t-dialin.net[87.162.228.218]
Dec 30 13:48:04 myserver postfix/smtpd[5430]: disconnect from p57A2E4DA.dip.t-dialin.net[87.162.228.218]
Dec 30 13:48:04 myserver postfix/cleanup[20555]: DE0E885C011: message-id=<20061230124202.DE0E885C011@myserver.com>


eigentlich müsste nach dem ich den Text eingegeben habe ein 250 Ok: queued as kommen, dies tut es leider nicht.
Top

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Telnet funktioniert nicht !

Post by Outlaw »

War da nicht was mit Telnet = BesserNichtBenutzenUndStattDessenSSHeinsetzen ??

Gruß
Outi
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

@Outlaw

Das ist ja sowit richtig, ich gehe ja nur nach einem Howto. Sonst bleibe ich auch über SSH bei diesem Punkt stehen.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Telnet funktioniert nicht !

Post by Roger Wilco »

langebeine wrote:eigentlich müsste nach dem ich den Text eingegeben habe ein 250 Ok: queued as kommen, dies tut es leider nicht.
Hast du den Text auch mit <CR><LF>.<CR><LF> (auf gut deutsch: Enter, Punkt, Enter) abgeschlossen?
Outlaw wrote:War da nicht was mit Telnet = BesserNichtBenutzenUndStattDessenSSHeinsetzen ??
telnet ist in diesem Kontext synonym für "generischer TCP-Client", wie etwa auch Netcat.
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Code: Select all

Hast du den Text auch mit <CR><LF>.<CR><LF> (auf gut deutsch: Enter, Punkt, Enter) abgeschlossen? 
Vielen Dank jetze gehts, wusste nicht das man es so machen muss *g*
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Telnet funktioniert nicht !

Post by Joe User »

langebeine wrote:Vielen Dank jetze gehts, wusste nicht das man es so machen muss *g*
Dann solltest Du Fehlermeldungen sorgfältiger lesen:
langebeine wrote:nach dem ich Data eingebe über telnet ein kommt pflicht mäßig diese Meldung:
354 End data with <CR><LF>.<CR><LF>.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

langebeine
Posts: 9
Joined: 2006-12-23 09:44

Re: Telnet funktioniert nicht !

Post by langebeine »

Gut habe halt mal wieder dazu gelernt. Eine Frage habe ich da nochmal. Per Telnet kann ich eine E-Mail versenden. Tue ich dies aber über eine andere Domain die auf einen anderen Server ist kommt nix an. in den Logs wurde auch nix geschrieben.

*edit* Raus kommt man aber nicht rein um es mal einfach zu formulieren.
Top

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Telnet funktioniert nicht !

Post by Outlaw »

>> <CR><LF>.<CR><LF>

<CR> = Carriage Return = Zeilenumbruch
<LF> = Line Feed = Linie füttern

Kommt aus der guten alten Nadeldruckerzeit oder eigentlich sogar aus der Schreibmaschinenzeit.

Dabei diente das <CR> dem großen Hebel, um die Walze in die nächste Zeile zu befördern und das <LF> den "Wagen" (also den Buchstabensetzer (Cursor)) mit der Walze an den Anfang zu setzen.

Heute ist das 1 zusammengefasste Funktioen (Return oder Enter).

Gruß
Outi
Top