Postfix, Mailempfang - Intern: ja ; Extern: nein

lindwyrm
Posts: 10
Joined: 2005-06-08 01:05

Postfix, Mailempfang - Intern: ja ; Extern: nein

Post by lindwyrm »

Huhu Zusammen,

ich habe mir hier einen Mailserver Postfix/courier aufgesetzt. So weit funktioniert alles wunderbar. Die Postfächer werden durch das AP (sysCP) ordnungsgeäss angelegt. Ich kann diese per IMAP und POP abrufen und auch das versenden an lokale und externe Adressen funktioniert tadellos.

Auch kann ich von einem Postfach, einer auf dem System eingerichteten Adresse auf eine andere Adresse, die sich ebenfalls auf dem System befindet senden und auch empfangen.

Nur das empfangen von externen Adressen/Servern funktioniert nicht, und in den logs ist kein Eintrag dazu zu finden.

Mein System: debian etch, postfix 2.3.4-3,

Hmm ich habe mir schon überlegt ob dies evtl. ein DNS-Fehler sein könnte. Denn die email verschwindet wie vom Erdboden verschluckt, ich bekomme auch keine Maildeamon-Error zurück.

Auf jedenfall scheint Postfix zu laufen und eine Anwendung lauscht auch auf Port 25

netstat -nlp

Code: Select all

tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN     3692/master
Ich habe die Domains auf den Nameserver von Schlundtech eintragen lassen

z.B. wie hier immer mit den Mx-Eintrag mail.gocore.de (Serverdomain) und den Wildcard für Subdomains.

Code: Select all

Domain:  	reddesire.de (88.198.25.49)
Einrichtung soll erfolgen: 	vollständig
inklusive www Zusatz: 	ja
SOA-Level Auswahl: 	Empfohlene Einstellungen
SOA eMail 	1
Primary Nameserver:             ns9.schlundtech.de
1. Secondary Nameserver:    ns10.schlundtech.de

Sub-Domains: 	name 	type 	value 	                 pref
Sub-Domain 1 		MX 	mail.gocore.de. 	10
Sub-Domain 2 	* 	A 	88.198.25.49
Zusätzlich habe ich meine lokale /etc/hosts bearbeitet:

Code: Select all


127.0.0.1       localhost gocore
88.198.25.49    gocore.de mail.gocore.de

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Und hier zum Abschluss noch meine postfix/main.cf

Code: Select all

inet_interfaces = all
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no
append_dot_mydomain = no
myhostname = mail.gocore.de
mydomain = $myhostname
mydestination = $myhostname $mydomain localhost localhost.$mydomain
mynetworks = 127.0.0.0/8
alias_maps = $alias_database
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
virtual_mailbox_base = /var/www/kunden/mail/
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf
virtual_alias_domains =
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf
virtual_uid_maps = static:2000
virtual_gid_maps = static:2000
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
Irgendwie weiss ich nicht mehr wo ich noch nach einen Fehler suchen könnte.

Vieleicht kann mir jemand von euch weiterhelfen?
So weit auf bald
Lindi
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Postfix, Mailempfang - Intern: ja ; Extern: nein

Post by Joe User »

Code: Select all

mynetworks = 127.0.0.0/8
RTFM!
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

lindwyrm
Posts: 10
Joined: 2005-06-08 01:05

Re: Postfix, Mailempfang - Intern: ja ; Extern: nein

Post by lindwyrm »

Joe User wrote:

Code: Select all

mynetworks = 127.0.0.0/8
RTFM!
Das habe ich! Meinem Verständnis nach gebe ich mit dieser Option an, welcher Subnetz auf den Mailserver zum Versand zugreifen darf.

Also mit mynetworks = 127.0.0.0/8 gebe ich doch nur lokalen Serverdiensten den Mailversand frei. So wie gewünscht. Was hat dies aber mit dem Empfang zu tun?

Ich habe leider vergessen zu erwähnen, dass ich Postfix an dieser Stelle auch mit der Option

mynetworks = 0/0

für alle Netze geöffnet hatte. Doch auch damit komme ich nicht weiter. Versenden kann ich, nur empfange ich keine Mails.

Aber vieleicht verstehe die Funktionalität hinter diesem Schalter ja auch vollkommen falsch.

Wie auch immer, vielen Dank für deine Antwort, auch wenn sie mir momentan nicht weiter hilft.

So weit auf bald
Lindi
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Postfix, Mailempfang - Intern: ja ; Extern: nein

Post by Joe User »

mynetworks raus und Folgendes rein, dann klappt's:

Code: Select all

mynetworks_style = host
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top