probleme mit der suphp ([info] executing)

Apache, Lighttpd, nginx, Cherokee
ar3k
Posts: 4
Joined: 2006-12-21 21:39

probleme mit der suphp ([info] executing)

Post by ar3k » 2006-12-21 21:43

moinsen alle miteinander,
nachdem ich stundenweise google hintermir hab und alle das selbe problem haben aber nirgens eine gescheite lösung steht wende ich mich mal an euch hier :-D
hatte auch schon hier im forum einen thread gefunden nur der endete einfach ohne eine lösung -.-

hab ein kleines problem, wie oben beschrieben, mit der suphp.
sie schreibt bei jedem ausfüren eines scriptes ne
"[info] Executing /home/domain/script/xxx.php as user xxx (1000), group www (60006)"

das geschieht aufgrund der hohen besucherzahlen etwa 10 - 15, an guten tagen auch gerne mehr als 20 mal in der sekunde... :roll:

nicht nur das der suphp log schnell voll ist und nen "permanent end of script header" oder so rausgibt, es zwingt den server an besagten "guten tagen" gerne mal in die knie... :evil:

ich bin nur leider nicht so der serveradmincrack und bräuchte hilfe, wie ich das loglevel von [info] auf [warn] oder höher bekomme....
hatte auch schon beim hoster selber angerufen, der hat mich soweit gebracht das ich mal in die httpd.conf reinschaue und da im punkt customlog den log selbst deaktiviere... nur das da der suphp nicht mit drin verschachtelt ist
nur leider ist's schon zuspät um nochmal anzurufen -.-


wäre nett wenn mir jemand helfen könnte...
wäre noch besser wenn das bis samstag in der früh geht würde gerne rechtzeitig in den urlaub fahren wollen :-D :D/

grüße Arek

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: probleme mit der suphp ([info] executing)

Post by Roger Wilco » 2006-12-21 21:56

Wirf einen Blick in deine suphp.conf.

ar3k
Posts: 4
Joined: 2006-12-21 21:39

Re: probleme mit der suphp ([info] executing)

Post by ar3k » 2006-12-21 22:20

würd ich machen wenn ich wüsste wo die ist :?

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: probleme mit der suphp ([info] executing)

Post by Roger Wilco » 2006-12-21 22:50

/etc ist mal ein guter Ansatzpunkt. Die suphp.conf gibt es seit SuPHP 0.6.0.

ar3k
Posts: 4
Joined: 2006-12-21 21:39

Re: probleme mit der suphp ([info] executing)

Post by ar3k » 2006-12-22 17:10

mhhh... hab nix in der richtung /etc gefunden...
wo kann ich die version einsehen?

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: probleme mit der suphp ([info] executing)

Post by Roger Wilco » 2006-12-22 19:11

mod_info sollte dir die entsprechende Version anzeigen, wenn es die Paketverwaltung deiner Distribution nicht kann (vorausgesetzt SuPHP wurde darüber installiert).

grandcat
Posts: 104
Joined: 2006-08-15 12:26
Location: Bayern

Re: probleme mit der suphp ([info] executing)

Post by grandcat » 2006-12-22 23:56

Allerdings muss dabei beachtet werden:
Wurde suPHP mit einem Prefix installiert, so findest du die "suphp.conf" unter "$prefix/etc". suPHP legt also in dem Prefixordner eine "etc" Directory an, in der dann das File liegt :wink:

ar3k
Posts: 4
Joined: 2006-12-21 21:39

Re: probleme mit der suphp ([info] executing)

Post by ar3k » 2007-01-01 15:22

komm leider garnicht klar....
nix in /etc/ /$prefix/etc und mit mod_info kann ich schon garnichts anfangen -.-

grandcat
Posts: 104
Joined: 2006-08-15 12:26
Location: Bayern

Re: probleme mit der suphp ([info] executing)

Post by grandcat » 2007-01-01 21:27

Du solltest wissen, dass "suPHP" keine Configdatei erstellt. Diese musst du selber erstellen. Es wurde nicht einmal eine Vorlage mit installiert (war bei mir zumindest so). Aufgrund dessen hier eine Kopie meiner "suphp.conf", die unter $prefix/etc/suphp.conf liegt.

Code: Select all

[global]
;Path to logfile
logfile=/var/log/suphp.log

;Loglevel
loglevel=debug

;User Apache is running as
webserver_user=wwwrun

;Path all scripts have to be in
docroot=/var/www

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=true

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0077

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100

[handlers]
;Handler for php-scripts
x-httpd-php=php:/usr/sbin/php5

;Handler for CGI-scripts
x-suphp-cgi=execute:!self
Natürlich musst du einige Optionen anpassen.
Ich hoffe, das hilft dir :wink:

antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: probleme mit der suphp ([info] executing)

Post by antondollmaier » 2007-01-01 22:48

suPHP mit 20 requests per second und mehr? und dabei geht die Kiste in die Knie?


Da bist du a) mit mod_php, oder b) mit fast-cgi oder c) gleich mit lighty und fcgi auf ner eigenen IP um EINIGES besser beraten ...