Keine Verbindung zu Mailserver

joern
Posts: 48
Joined: 2004-07-30 13:41

Keine Verbindung zu Mailserver

Post by joern »

Hallo,

habe eine neu ausgelieferten Server, der als MTA qmail vorweist.

Leider erhalte ich keine Verbindung zum Mailserver:

Fehlermeldung:
ERROR: I could not complete a connection to any of your mailservers!

mail.domain.de: Timed out [Last data sent: [Did not connect]]
-----------------------------------------------------------------------

Das Einzige, war bisher lief, war das versenden einer Mail über Horde Webmail.

Ich habe in den messages und maillogs nichts Passendes finden können:

21 14:49:52 s15231403 pop3d: Connection, ip=[217.226.140.237] <-- Meine IP
Dec 21 14:49:52 s15231403 pop3d: Connection, ip=[217.226.140.237]
Dec 21 14:49:52 s15231403 pop3d: IMAP connect from @ [217.226.140.237]IMAP connect from @ [217.226.140.237]INFO: LOGIN, user=test, ip=[217.226.140.237]
Dec 21 14:49:52 s15231403 pop3d: LOGIN, user=test, ip=[217.226.140.237]
Dec 21 14:49:52 s15231403 pop3d: 1166708992.498226 LOGOUT, user=test, ip=[217.226.140.237], top=0, retr=0, time=0, rcvd=12, sent=38, maildir=/var/qmail/mailnames/domain.de/test/Maildir
Dec 21 14:49:52 s15231403 pop3d: 1166708992.548499 LOGOUT, user=test, ip=[217.226.140.237], top=0, retr=0, time=0, rcvd=12, sent=38, maildir=/var/qmail/mailnames/domain.de/test/Maildir


qmail läuft aber.
Die Firewall ist deaktiviert.

Woran könnte es liegen, dass der Mailserver unerreichbar ist ?


Danke

Jörn
Top

taurin
Posts: 44
Joined: 2003-11-30 23:41

Re: Keine Verbindung zu Mailserver

Post by taurin »

Dein Maillog weist nur Infos zur Verbindung auf den POP3/IMAP-Daemon auf, aber keine zum SMTP-Daemon.

Das qmail läuft siehst Du über die PID nehm ich an. Was sagt denn "netstat -pletun | grep 25"?
Top

joern
Posts: 48
Joined: 2004-07-30 13:41

Re: Keine Verbindung zu Mailserver

Post by joern »

Vielen Dank für die schnelle Antwort.

Das qmail läuft sehe zum Einen über mein Control Panel und dann

hab ich auf der Konsole durch ps ax | grep qmail gesehen, dass
der Server aktiv ist.

Ich habe ihn auch schon diverse male restated .

Die Abfrage btrachte mir folgendes Ergebnis:

# netstat -pletun | grep 25
tcp 0 0 0.0.0.0:8880 0.0.0.0:* LISTEN 0 5598 2549/httpsd
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 0 5257 2486/httpd2-prefork
tcp 0 0 0.0.0.0:888 0.0.0.0:* LISTEN 0 2571 1586/3dm2
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 0 11559 4061/xinetd
tcp 0 0 0.0.0.0:xxxx 0.0.0.0:* LISTEN 0 5599 2549/httpsd
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 0 5258 2486/httpd2-prefork

--------------------------------------------------------------------

Komisch, dass bei localhost für SMTP die 127 eingetragen ist und nicht 0.0.0.0.0

Aber SMTP scheint OK zu sein oder?

VG
Top

rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: Keine Verbindung zu Mailserver

Post by rootsvr »

Deine Ausgabe sagt das smtp an 127.0.0.1 über xinetd läft..

von aussen her kommt dann wohl nichts ran.

Schau mal da:
http://linuxfromscratch.org/pipermail/b ... 04344.html

da steht zumindest was über qmail und xinetd
Top

joern
Posts: 48
Joined: 2004-07-30 13:41

Re: Keine Verbindung zu Mailserver

Post by joern »

Hallo,

hervorragend. Hat alles geklappt.

:-) Allen ein schönes Weihnachtsfest.

Vielen Grüße
Jörn
Top