.htacces in httpd.conf übernehmen

Apache, Lighttpd, nginx, Cherokee
indy0130
Posts: 23
Joined: 2005-08-27 16:08

.htacces in httpd.conf übernehmen

Post by indy0130 »

Hallo liebes Forum,

bräuchte mal Hilfe zur Konfiguration meines neuen Apaches.

Ich möchte meine gute alte .htaccess-Datei nun endlich in die httpd.conf aus Performance-Gründen übernehmen.

.htaccess:

Code: Select all

RewriteEngine on
# Username
RewriteRule ^([a-z0-9_-]+)$ /index_start.php?name=$1 [L]
und das soll nun hier rein:

httpd.conf

Code: Select all

<Directory /var/www>
AllowOverride FileInfo
Options +FollowSymLinks
RewriteEngine On
# Username
RewriteRule ^([a-z0-9_-]+)$ /var/www/index_start.php?name=$1 [L]
</Directory>
Und die Fehlermeldung:
Syntax error on line 21 of /etc/apache2/sites-enabled/000-default:
Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
httpd not running, trying to start
Danke für die Hilfe...

Mirco
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: .htacces in httpd.conf übernehmen

Post by Roger Wilco »

Code: Select all

a2enmod rewrite
indy0130
Posts: 23
Joined: 2005-08-27 16:08

Re: .htacces in httpd.conf übernehmen

Post by indy0130 »

anstelle von rewriteengine on?
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: .htacces in httpd.conf übernehmen

Post by Roger Wilco »

indy0130 wrote:anstelle von rewriteengine on?
Nein.
indy0130
Posts: 23
Joined: 2005-08-27 16:08

Re: .htacces in httpd.conf übernehmen

Post by indy0130 »

Gut, was soll ich nun machen? :)
Google liefert mir nur Mist...

Nebenbei: Frohe Weihnachten!

Code: Select all

Syntax error on line 5 of /etc/apache2/sites-enabled/000-default:
Invalid command 'a2enmod', perhaps misspelled or defined by a module not included in the server configuration
httpd not running, trying to start
mad cow
Posts: 33
Joined: 2006-11-23 22:57
Location: Heidelberg (Baden)

Re: .htacces in httpd.conf übernehmen

Post by mad cow »

Roger Wilco wrote:

Code: Select all

a2enmod rewrite
Du sollst das nicht in die Datei packen, sondern den Befehl in der Konsole eingeben. :wink: