qmail findet meine domain nicht beim senden an aliase

gentoo-fan
Posts: 4
Joined: 2006-09-06 12:29

qmail findet meine domain nicht beim senden an aliase

Post by gentoo-fan »

hi leute,

ich hab vor kurzem ein gentoo auf ein root-server aufgesetzt, mit Qmail,
courier-authlib, courier-imap, vpopmail, squirrelmail, vqadmin, qmailadmin, spamassassin, relay-ctrl.
das problem dabei ist, qmail gibt fehlermeldung aus,
wenn ich versuche auf eine alias-adresse eine mail zuschicken.
mails versenden
von lokal nach lokal
von lokal nach extern
und von extern an lokalen account klappt wunderbar.
leider aber klappts nicht mit den aliasen.
es kommt zu der fehlermeldung: "Sorry, I couldn't find any host named ..."

hier erstmal einige infos ueber mein server:

lokale accounts:
bobo@blub.de
dido@blub.de

alias account:
lala@blub.de // alias auf: dido@blub.de

Code: Select all

# hostname
gentoo


# hostname -f
gentoo.blub.de


# hostname -d
blub.de


# hostname -i
213.239.207.4
hier die configs vom qmail:

Code: Select all

# cat /var/qmail/control/me
gentoo.blub.de


# cat /var/qmail/control/locals
gentoo.blub.de


# cat /var/qmail/control/rcpthosts
blub.de
.blub.de
andere-domain.de
.andere-domain.de


# cat /var/qmail/control/virtualdomains
blub.de:blub.de
andere-domain.de:andere-domain.de


# cat /var/qmail/control/plusdomain
blub.de


# cat /var/qmail/control/defaultdomain
blub.de


# cat /var/qmail/control/conf-smtpd
TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
QMAIL_TCPSERVER_PRE="${QMAIL_TCPSERVER_PRE} envdir /etc/relay-ctrl relay-ctrl-chdir"
QMAIL_SMTP_PRE="${QMAIL_SMTP_PRE} relay-ctrl-check"
QMAIL_SMTP_CHECKPASSWORD="/var/vpopmail/bin/vchkpw"
QMAIL_SMTP_AUTHHOST=$(<${QMAIL_CONTROLDIR}/me)
[[ -n "${QMAIL_SMTP_CHECKPASSWORD}" ]] && {
        [[ -z "${QMAIL_SMTP_POST}" ]] && QMAIL_SMTP_POST=/bin/true
        QMAIL_SMTP_POST="${QMAIL_SMTP_CHECKPASSWORD} ${QMAIL_SMTP_POST}"
}


# cat /var/qmail/users/assign
+blub.de-:blub.de:89:89:/var/vpopmail/domains/blub.de:-::
+andere-domain.de-:blub.de:89:89:/var/vpopmail/domains/blub.de:-::
und jetzt vpopmail:

Code: Select all

# cat /var/vpopmail/domains/blub.de/.qmail-lala
&dido@blub.de


# cat /var/vpopmail/domains/blub.de/vpasswd
bobo:$1$...:1:0:bobo:/var/vpopmail/domains/blub.de/bobo:NOQUOTA
dido:$1$...:1:0:dido:/var/vpopmail/domains/blub.de/dido:NOQUOTA


# ls -alhF /var/vpopmail/domains/blub.de/
drwx------ 5 vpopmail vpopmail 4,0K 14. Dez 14:53 ./
drwxr-xr-x 3 vpopmail vpopmail 4,0K 14. Dez 14:48 ../
drwx------ 3 vpopmail vpopmail 4,0K 14. Dez 14:49 bobo/
drwx------ 3 vpopmail vpopmail 4,0K 14. Dez 14:49 dido/
-rw------- 1 vpopmail vpopmail   34 14. Dez 14:49 .dir-control
drwx------ 3 vpopmail vpopmail 4,0K 14. Dez 14:48 postmaster/
-rw------- 1 vpopmail vpopmail   72 15. Dez 21:01 .qmail-default
-rw------- 1 vpopmail vpopmail   23 15. Dez 19:39 .qmail-lala
-rw------- 1 vpopmail vpopmail  324 14. Dez 14:49 vpasswd
-rw------- 1 vpopmail vpopmail 2,4K 14. Dez 14:49 vpasswd.cdb
--w------- 1 vpopmail vpopmail    0 14. Dez 14:48 .vpasswd.lock
und hier die tcprules:

Code: Select all

# cat /etc/tcprules.d/tcp.qmail-smtp
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue",QS_SPAMASSASSIN="1"
213.239.207.4:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue",QS_SPAMASSASSIN="1"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"


# cat /etc/tcprules.d/tcp.qmail-qmqp
:deny
213.239.207.4:allow,RELAYCLIENT="",RBLSMTPD=""
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD=""

# cat /etc/tcprules.d/tcp.qmail-qmtp
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD=""
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
213.239.207.4:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
und jetzt die log vom qmail, beim abschicken einer mail an ein lokalen-account:

Code: Select all

# tail -f /var/log/qmail/qmail-send/current /var/log/qmail/qmail-smtpd/current
==> /var/log/qmail/qmail-send/current <==
@4000000045831aea2aba2604 new msg 1985042
@4000000045831aea2aba31bc info msg 1985042: bytes 1017 from <bobo@blub.de> qp 2824 uid 210
@4000000045831aea2d0ab93c starting delivery 1: msg 1985042 to local blub.de-dido@blub.de
@4000000045831aea2d0ac8dc status: local 1/10 remote 0/20
@4000000045831aea2d835054 delivery 1: success: did_0+0+1/
@4000000045831aea2d835ff4 status: local 0/10 remote 0/20
@4000000045831aea2d835ff4 end msg 1985042

==> /var/log/qmail/qmail-smtpd/current <==
@4000000045831aea205634b4 tcpserver: status: 1/40
@4000000045831aea2056406c tcpserver: pid 2816 from 213.239.207.4
@4000000045831aea21753174 tcpserver: ok 2816 blub.de:213.239.207.4:25 blub.de:213.239.207.4::4547
@4000000045831aea2b71aa7c tcpserver: end 2816 status 0
@4000000045831aea2b71ba1c tcpserver: status: 0/40
und hier die log, wen man eine mail zu alias abschickt:

Code: Select all

# tail -f /var/log/qmail/qmail-send/current /var/log/qmail/qmail-smtpd/current
==> /var/log/qmail/qmail-send/current <==
@4000000045831a6a32cf399c new msg 1985038
@4000000045831a6a32cf493c info msg 1985038: bytes 1063 from <bobo@blub.de> qp 2003 uid 210
@4000000045831a6a352c7aec starting delivery 21: msg 1985038 to local blub.de-lala@blub.de
@4000000045831a6a352c8e74 status: local 1/10 remote 0/20
@4000000045831a6a35aee98c new msg 1985058
@4000000045831a6a35aef92c info msg 1985058: bytes 1176 from <bobo@blub.de> qp 2008 uid 89
@4000000045831a6a383d934c starting delivery 22: msg 1985058 to remote dido@blub.de_
@4000000045831a6a383da6d4 status: local 1/10 remote 1/20
@4000000045831a6a383da6d4 delivery 21: success: did_0+1+0/qp_2008/
@4000000045831a6a383daabc status: local 0/10 remote 1/20
@4000000045831a6a383daea4 end msg 1985038
@4000000045831a6a388e3bbc delivery 22: failure: Sorry,_I_couldn't_find_any_host_named_blub.de?._(#5.1.2)/
@4000000045831a6a388e4f44 status: local 0/10 remote 0/20
@4000000045831a6a39e1c984 bounce msg 1985058 qp 2010
@4000000045831a6a39e1d924 end msg 1985058
@4000000045831a6a39e58a74 new msg 1985044
@4000000045831a6a39e58e5c info msg 1985044: bytes 1739 from <> qp 2010 uid 206
@4000000045831a6b04957c1c starting delivery 23: msg 1985044 to local blub.de-bobo@blub.de
@4000000045831a6b04958bbc status: local 1/10 remote 0/20
@4000000045831a6b055db9d4 delivery 23: success: did_0+0+1/
@4000000045831a6b055dc58c status: local 0/10 remote 0/20
@4000000045831a6b055dc974 end msg 1985044

==> /var/log/qmail/qmail-smtpd/current <==
@4000000045831a6a2917284c tcpserver: status: 1/40
@4000000045831a6a29173404 tcpserver: pid 1996 from 213.239.207.4
@4000000045831a6a293e1524 tcpserver: ok 1996 blub.de:213.239.207.4:25 blub.de:213.239.207.4::3313
@4000000045831a6a338287f4 tcpserver: end 1996 status 0
@4000000045831a6a338293ac tcpserver: status: 0/40
und hier die email, die dann zurueckkommt,
auf den account von wo man es abschickt:

Code: Select all

Hi. This is the qmail-send program at gentoo.blub.de.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<dido@blub.de
>:
Sorry, I couldn't find any host named blub.de?. (#5.1.2)

--- Below this line is a copy of the message.

Return-Path: <bobo@blub.de>
Received: (qmail 2008 invoked by uid 89); 15 Dec 2006 21:57:52 -0000
Delivered-To: blub.de-lala@blub.de
Received: (qmail 2003 invoked by uid 210); 15 Dec 2006 21:57:52 -0000
Received: from 213.239.207.4 by gentoo (envelope-from <bobo@blub.de>, uid 201)
with qmail-scanner-1.25st 
 (clamdscan: 0.88.7/2335. perlscan: 1.25st.  
 Clear:RC:1(213.239.207.4):. 
 Processed in 0.039156 secs); 15 Dec 2006 21:57:52 -0000
Received: from blub.de (HELO mail.blub.de) (213.239.207.4)
  by blub.de with SMTP; 15 Dec 2006 21:57:52 -0000
Received: from c156231.adsl.hansenet.de ([213.39.156.231])
        (SquirrelMail authenticated user bobo@blub.de)
        by mail.blub.de with HTTP;
        Fri, 15 Dec 2006 22:57:52 +0100 (CET)
Message-ID: <3278.213.39.156.231.1166219872.squirrel@mail.blub.de>
Date: Fri, 15 Dec 2006 22:57:52 +0100 (CET)
Subject: test-nachricht
From: bobo@blub.de
To: lala@blub.de
User-Agent: SquirrelMail/1.4.9 [CVS]
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
Content-Transfer-Encoding: 8bit
X-Priority: 3 (Normal)
Importance: Normal
bla bla bla

ich hoffe jemand hat eine idee,
oder noch besser, jemand erkennt ein fehler!
bin naemlich schon verzweifelt,
der mail-server funktioniert schon seit tagen nicht :(

vielen dank
Top

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: qmail findet meine domain nicht beim senden an aliase

Post by kenzo »

Es ist merkwürdig, daß dein MX die Domain blub.de nicht findet - der MX-Eintrag löst allerdings auf eine andere IP als deine (213.239.207.4) auf, vielleicht hast du ein gravierendes DNS-Problem? :?
# cat /var/vpopmail/domains/blub.de/.qmail-lala
&dido@blub.de
Nimm mal das Leerzeichen hinter der eMail-Adresse raus.
Top

gentoo-fan
Posts: 4
Joined: 2006-09-06 12:29

Re: qmail findet meine domain nicht beim senden an aliase

Post by gentoo-fan »

vielen dank fuer die schnelle antwort.

ich hab ja ganz vergessen zu erwahnen, dass ich hier einbishen geschummelt hab
verzeiht mir, ich habe die domains / email-adressen und ip etwas anonymisiert.
:)

ich hoffe es geht auch so.
zu mx, hier die antwort vom dig:

Code: Select all

# dig mx blub.de

; <<>> DiG 9.3.2 <<>> mx blub.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32744
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 5, ADDITIONAL: 6

;; QUESTION SECTION:
;blub.de.                  IN      MX

;; ANSWER SECTION:
blub.de.           43200   IN      MX      10 blub.de.
blub.de.           43200   IN      MX      5 blub.de.

;; AUTHORITY SECTION:
dyndns.org.                 85300   IN      NS      ns2.dyndns.org.
dyndns.org.                 85300   IN      NS      ns3.dyndns.org.
dyndns.org.                 85300   IN      NS      ns4.dyndns.org.
dyndns.org.                 85300   IN      NS      ns5.dyndns.org.
dyndns.org.                 85300   IN      NS      ns1.dyndns.org.

;; ADDITIONAL SECTION:
blub.de.           	  14400   IN      A       213.239.207.4
ns2.dyndns.org.         85755   IN      A       204.13.249.81
ns3.dyndns.org.         85755   IN      A       204.13.250.81
ns4.dyndns.org.         85755   IN      A       213.155.150.205
ns5.dyndns.org.         85755   IN      A       63.170.10.81
ns1.dyndns.org.         85755   IN      A       63.208.196.90

;; Query time: 38 msec
;; SERVER: 213.133.99.99#53(213.133.99.99)
;; WHEN: Sat Dec 16 13:08:30 2006
;; MSG SIZE  rcvd: 270
die "AUTHORITY & ADDITION SECTION" zeigen die dyndns-ns-server, weil meine domain natuerlich dort liegt.
hier meine resolv.conf:

Code: Select all

# cat /etc/resolv.conf
search blub.de
nameserver 213.133.99.99
nameserver 213.133.98.98
nameserver 213.133.100.100
nameserver ns1.dyndns.org
die nameserver stammen vom hetzner...

das leerzeichen am ende der email-adresse hab ich entfernt, leider aber ohne ergebnis...

und ich meinte kein mail-mta/qmail was ich installiert hab, sondern das mail-mta/netqmail, falls es eine grosse rolle spielt...


vielen dank
Top