Exim4 und Spamassassin will einfach nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
mascoxx
Posts: 5
Joined: 2006-11-10 19:06

Exim4 und Spamassassin will einfach nicht

Post by mascoxx » 2006-11-10 19:47

Hallo!

Ich versuche jetzt schon seit langer Zeit Spamassassin 3.0.3
und exim 4 zu vereinen, jedoch gelingt es mit einfach nicht.
Ich verwende den exim4-daemon-heavy. SA scannt anscheinend nicht
einmal die Mails, zumindest wird weder der HEADER im Mail erweitert,
noch der Betreff.

Hatt jemand eine Idee?

MfG
Clemens

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Exim4 und Spamassassin will einfach nicht

Post by Roger Wilco » 2006-11-10 20:46

Exiscan kann dir nur das Ergebnis der Überprüfung liefern. Die Header der Mail verändern musst du selbst über geeignete ACL.

40.3 Calling SpamAssassin from an Exim ACL

mascoxx
Posts: 5
Joined: 2006-11-10 19:06

Re: Exim4 und Spamassassin will einfach nicht

Post by mascoxx » 2006-11-10 21:02

Danke für den Tipp!
Ich habe jetzt das File /etc/exim4/conf.d/acl/40_exim4-config_check_data
wie folgt testhalber geändert

Code: Select all

### acl/40_exim4-config_check_data
#################################

# This ACL is used after the contents of a message have been received. This
# is the ACL in which you can test a message's headers or body, and in
# particular, this is where you can invoke external virus or spam scanners.

acl_check_data:
  deny
    message = Message headers fail syntax check
    !acl = acl_whitelist_local_deny
    !verify = header_syntax
  .endif


  # require that there is a verifiable sender address in at least
  # one of the "Sender:", "Reply-To:", or "From:" header lines.
  .ifdef CHECK_DATA_VERIFY_HEADER_SENDER
  deny
    message = No verifiable sender address in message headers
    !acl = acl_whitelist_local_deny
    !verify = header_sender
  .endif


  # Deny if the message contains malware. Before enabling this check, you
  # must install a virus scanner and set the av_scanner option in the
  # main configuration.
  #
  # exim4-daemon-heavy must be used for this section to work.
  #
  # deny
  #   malware = *
  #   message = This message was detected as possible malware ($malware_name).


  # Add headers to a message if it is judged to be spam. Before enabling this,
  # you must install SpamAssassin. You also need to set the spamd_address
  # option in the main configuration.
  #
  # exim4-daemon-heavy must be used for this section to work.
  #
   warn
     spam = nobody
     message = X-Spam_score: $spam_scoren
               X-Spam_score_int: $spam_score_intn
               X-Spam_bar: $spam_barn
               X-Spam_report: $spam_report

  # This hook allows you to hook in your own ACLs without having to
  # modify this file. If you do it like we suggest, you'll end up with
  # a small performance penalty since there is an additional file being
  # accessed. This doesn't happen if you leave the macro unset.
  .ifdef CHECK_DATA_LOCAL_ACL_FILE
  .include CHECK_DATA_LOCAL_ACL_FILE
  .endif


  # accept otherwise
  accept
Jedoch klappt es noch immer nicht... war das eh das richtige File?!

LG

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Exim4 und Spamassassin will einfach nicht

Post by Roger Wilco » 2006-11-10 21:26

message ist die Meldung, die Exim während des SMTP-Dialogs ausgibt. Headerzeilen werden mit headers_add hinzugefügt.

mascoxx
Posts: 5
Joined: 2006-11-10 19:06

Re: Exim4 und Spamassassin will einfach nicht

Post by mascoxx » 2006-11-10 21:44

ok, ich hab jetzt mal meine 40_exim4-config_check_data config
unterhalb von X-Spam_report: $spam_report
mit headers_add = X-Spam-Status: $spam_report erweitert...
jedoch tut sich trotzdem neustart des exim-daemons nichts.
ich blick da nicht durch!

nn4l
Posts: 172
Joined: 2002-06-19 07:06

Re: Exim4 und Spamassassin will einfach nicht

Post by nn4l » 2006-11-13 20:07

Ich habe auf dieser Seite eine funktionsfähige exim4 Konfiguration mit SpamAssassin, ClamAV und Vexim gepostet:

http://www.schirmacher.de/display/INFO/ ... +bug+fixes

Du kannst die Settings ja mal mit deinen vergleichen.

Diese Seite ist auch empfehlenswert:

http://debianhowto.de/doku.php/de:howto ... er_mailman

mascoxx
Posts: 5
Joined: 2006-11-10 19:06

Re: Exim4 und Spamassassin will einfach nicht

Post by mascoxx » 2006-11-13 20:14

Danke, allerdings funktioniert es jetzt schon...
Ich hab nur ein Procmail Script ins Homeverzeichnis legen müssen,
welches erst Spamassassin anwirft:

Code: Select all

:0fw:spamassassin.lock
* < 256000
| /usr/bin/spamc
MfG