Web.de refused to talk to me

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
kgbschnik
Posts: 10
Joined: 2006-06-28 15:02

Web.de refused to talk to me

Post by kgbschnik » 2006-11-08 14:09

Hallo,

ich habe einem Mailserver nach debianhowto.de aufgesetzt. Der Mailversand funktioniert, aber irgendwie unzuverlässig.

Das Problem tritt unregelmäßig und beim Versand aus PHP-Scripten auf.
In den Logs:

Code: Select all

Nov  8 13:48:01 localhost amavis[27497]: (27497-03) Passed,<www-data@domain.de> -> <empfaenger@web.de>, Message-ID:<20061108124801.3CD4BF28069@domain.de>, Hits -
Nov  8 13:48:01 localhost postfix/smtp[28548]: 3CD4BF28069: to=<empfaenger@web.de>, relay=127.0.0.1[127.0.0.1], delay=0, status=sent (250 2.6.0 Ok,id=27497-03, from MTA: 250 Ok: queued as 4FE7FF2806B)
Nov  8 13:48:01 localhost postfix/qmgr[27227]: 3CD4BF28069: removed
Nov  8 13:48:01 localhost postfix/smtp[28558]: 4FE7FF2806B: host mx-ha01.web.de[217.72.192.149] refused to talk to me: 421 mx36.web.de: Too much load; please try again later
Nov  8 13:48:01 localhost postfix/smtp[28558]: 4FE7FF2806B: to=<empfaenger@web.de>, relay=mx-ha02.web.de[217.72.192.188], delay=0, status=deferred (host mx-ha02.web.de[217.72.192.188] refused to talk to me: 421 mx32.web.de: Too much load; please try again later)
Meine Konfiguration:

Code: Select all

# Konfiguration erstellt nach dem Tutorial auf http://debianhowto.de/doku.php/de:howtos:sarge:postfix2_antispam_virenschutz

biff = no

append_dot_mydomain = no

myorigin = domain.de
myhostname = domain.de
mydomain = mail.domain.de

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

# Trage hier alle Domänen ein, die lokal zugestellt werden sollen, aber auf keinen Fall virtuelle Domänen.
mydestination = debian3164lamp, localhost.localdomain, localhost

relayhost =

mynetworks = 127.0.0.0/8

mailbox_size_limit = 0
recipient_delimiter = +

inet_interfaces = all

virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf mysql:/etc/postfix/mysql-virtual_email2email.cf

virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf

virtual_mailbox_base
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf

virtual_mailbox_base = /home/vmail

virtual_uid_maps = static:5000

virtual_gid_maps = static:5000

smtpd_sasl_auth_enable = yes

broken_sasl_auth_clients = yes

smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

# Authentifizierte SMTP Verbindungen verschlüsseln wir mit SSL
smtpd_use_tls = yes

# Der Ort, an dem wir unsere SSL Zertifikate ablegen - anlegen werden wir die später noch...
smtpd_tls_cert_file = /etc/postfix/smtpd.cert

# Und zu guter Letzt noch der Speicherort des privaten SSL-Schlüssels für TLS.
smtpd_tls_key_file = /etc/postfix/smtpd.key

# Diese content_filter-Option sorgt dafür, daß jede eMail an einen Dienst
# namens amavis übergeben wird. Noch geht das aber nicht - postfix hat noch nicht alles zum Thema amavis gelernt.
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
Wäre über Hilfe echt dankbar. Ich komm einfach nicht weiter. Liegt das jetz an Web.de? Per Otulook versendete Mails erreichen eine Webadresse...

Edit: Sind die Angaben unter myorigin myhostname mydomain mydestination korrekt? Es sollen auf dem Server mehrere Domainen unter einer IP erreichbar sein.

Edit2:In Webmin erhalte ich folgende Meldung:

Code: Select all

host mx-ha02.web.de[217.72.192.188] refused to talk to me: 421 mx36.web.de: Too much load; please try again later

aquajo
RSAC
Posts: 167
Joined: 2003-02-25 21:07

Re: Web.de refused to talk to me

Post by aquajo » 2006-11-08 14:43

Code: Select all

Nov  8 13:48:01 localhost postfix/smtp[28558]: 4FE7FF2806B: to=<empfaenger@web.de>, relay=mx-ha02.web.de[217.72.192.188], delay=0, status=deferred (host mx-ha02.web.de[217.72.192.188] refused to talk to me: 421 mx32.web.de: Too much load; please try again later)
Der web.de SMTP-Server auf den dein Mailserver einliefern will lehnt ab, da seine Load zu hoch ist, zumindest steht das im Logfile :-D

kgbschnik
Posts: 10
Joined: 2006-06-28 15:02

Re: Web.de refused to talk to me

Post by kgbschnik » 2006-11-08 15:34

AquaJo wrote:

Code: Select all

Nov  8 13:48:01 localhost postfix/smtp[28558]: 4FE7FF2806B: to=<empfaenger@web.de>, relay=mx-ha02.web.de[217.72.192.188], delay=0, status=deferred (host mx-ha02.web.de[217.72.192.188] refused to talk to me: 421 mx32.web.de: Too much load; please try again later)
Der web.de SMTP-Server auf den dein Mailserver einliefern will lehnt ab, da seine Load zu hoch ist, zumindest steht das im Logfile :-D
Was bedeutet, dass sein Load zu hoch ist?

Sind meine Einstellungen sonst ok?

Ich habe jetzt bei einigen rausgelesen, dass ihre Postfächer voll sind (Web.de hat ja auch nur 12 MB standartmäßig). Mit dem Load - Fehler hat das nichts zu zun denke ich, oder?

aquajo
RSAC
Posts: 167
Joined: 2003-02-25 21:07

Re: Web.de refused to talk to me

Post by aquajo » 2006-11-08 15:37

Ich habe mir jetzt deine Konfiguration nicht angesehen, aber eine zu hohe Load bedeutet, dass der SMTPD-Server aktuell eine recht hohe last aufweist, und um sich zu schützen nimmt er dann eine Zeit lang keine weiteren E-Mails an.

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Web.de refused to talk to me

Post by Roger Wilco » 2006-11-08 15:38

KGBschnik wrote:Sind meine Einstellungen sonst ok?
Wenn die Meldungen von web.de das einzige Problem sind: Ja.
KGBschnik wrote:Ich habe jetzt bei einigen rausgelesen, dass ihre Postfächer voll sind (Web.de hat ja auch nur 12 MB standartmäßig). Mit dem Load - Fehler hat das nichts zu zun denke ich, oder?
Nein.

kgbschnik
Posts: 10
Joined: 2006-06-28 15:02

Re: Web.de refused to talk to me

Post by kgbschnik » 2006-11-08 15:43

Wenn die Meldungen von web.de das einzige Problem sind: Ja.
Leider nicht..Arcor und Freenetadressen werden teilweise auch abgelehnt.

Code: Select all

host mx.arcor.de[151.189.21.118] said: 450 4.7.1 <Russia10@arcor.de>: Recipient address rejected: Policy Rejection- Please try later. (in reply to RCPT TO command)
Was mich halt wundert ist, dass der Versand per Outlook einwandfrei funktioniert. PHPmäßig kommen die Mails auch an:

Code: Select all

mail('mail@web.de', 'test', 'Dies ist eine Testmail', "From: info@domain.de");

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Web.de refused to talk to me

Post by Roger Wilco » 2006-11-08 15:47

KGBschnik wrote:Leider nicht..Arcor und Freenetadressen werden teilweise auch abgelehnt.

Code: Select all

host mx.arcor.de[151.189.21.118] said: 450 4.7.1 <Russia10@arcor.de>: Recipient address rejected: Policy Rejection- Please try later. (in reply to RCPT TO command)
Auch ein "Problem" bei Arcor. Vielleicht eine Art Greylisting?

kgbschnik
Posts: 10
Joined: 2006-06-28 15:02

Re: Web.de refused to talk to me

Post by kgbschnik » 2006-11-08 16:09

Roger Wilco wrote: Auch ein "Problem" bei Arcor. Vielleicht eine Art Greylisting?
Hmm da könnte ich dann sowieso recht wenig machen oder nicht?

Was mich halt wundert ist, dass jede Mail an meine web-adresse ankommt. Auch aus einen PHP-Script aus. :(

Ich habe jetzt erstmal die Function, die eine Mail an einen User schickt, falls er eine PN auf der Seite erhält rausgenommen. Kann es dadruch entstehen?

rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: Web.de refused to talk to me

Post by rootsvr » 2006-11-08 17:36

Im Hetznerforum steht, das freenet.de im Zuge von Spam bekämpfung nur eine bestimmte Zahl von Mails/Server/Zeiteinheit annimmt, vielleicht hat Web.de was ähnliches? Im Notfall postmaster@web.de fragen.

http://forum.hetzner.de/wbb2/thread.php ... =7436&sid=

rot
Posts: 45
Joined: 2004-03-20 12:44

Re: Web.de refused to talk to me

Post by rot » 2006-11-08 20:15

rootsvr wrote:Im Hetznerforum steht, das freenet.de im Zuge von Spam bekämpfung nur eine bestimmte Zahl von Mails/Server/Zeiteinheit annimmt, vielleicht hat Web.de was ähnliches? Im Notfall postmaster@web.de fragen. http://forum.hetzner.de/wbb2/thread.php ... =7436&sid=
Arcor setzt Greylisting ein, da ist ein 421 also Normal bei der ersten Zustellung. Danach ist das Tripel bekannt und bei Gleichheit von Absender, Empfänger und einliefernder IP läuft die Zustellung dann sofort ohne Verzögerung.

Freenet ist halt unfähig und nicht gewillt, das abzustellen (siehe auch die Antwort im Hetzner-Forum, die nur die Kernaussage darstellt). Und web.de hat in der Tat zumindest heute das gleiche Problem, und zwar ziemlich massiv.

Irgendwie aber auch eine logische Folge der "Geiz ist Geil"-Mentalität: Wenn man immer nur auf billig-billig-billig macht und sich gegenseitig unterbietet, ist irgendwann kein Geld mehr da, um die Infrastruktur am Laufen zu halten.