zend.ze1_compatibility_mode

Apache, Lighttpd, nginx, Cherokee
cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

zend.ze1_compatibility_mode

Post by cirox » 2006-11-05 23:12

Hallo

in der php Empfehlung hier im Forum steht:

zend.ze1_compatibility_mode = On

Das bewirkt ja dass php4 Skripte unter php5 laufen sollen. Näher erläutert:

Zitat:
http://www.kofler.cc/forum/forumthread.php?rootID=5012

"Steht er auf On, muss wie oben beschrieben eine Referenzierung explizit im Code gefordert werden. Ist er Off, erstellt PHP5 automatisch eine Referenz anstelle einer Kopie."

Bin jetzt nicht der php Freak, dass ich das so richtig verstehe aber nun gut.Nun habe ich aber die Erfahrung gemacht, dass es im Produktivbetrieb besser ist die Einstellung auf "Off" zu ändern.

Welche Einstellung bevorzugt Ihr wenn man die Kompatibilität aller Skripte unter php5 berücksichtigt?

danke und gruß cirox

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: zend.ze1_compatibility_mode

Post by cirox » 2006-11-10 11:53

Hallo,

ich würde folgendes vorschlagen:

OFF

weil es ab PHP5.2 eh rausgeflogen ist.

gruß cirox