mod_rewrite will einfach nicht funktionieren

Apache, Lighttpd, nginx, Cherokee
barkeeper69
Posts: 6
Joined: 2006-11-01 12:39

mod_rewrite will einfach nicht funktionieren

Post by barkeeper69 » 2006-11-01 14:03

hallölee,

ich versuche jetzt schon seit tagen mod_rewrite
zum laufen zu bringen, aber nix hat bisher genutzt.

ich habe einen rootserver by s4y mit Suse 9.3 prof

das modul ist laut phpinfo auch geladen.
die httpd.conf habe ich auch angepasst.
php.ini auch.

hoffe nur das ich da nix verhauen habe.

wenn ich jetzt die .htaccess in mein verzeichniss
schiebe bekomme ich immer ein error 403 und nix geht mehr.

ihr seit jetzt meine letzte hoffnung.

danke

gruss

Frank

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: mod_rewrite will einfach nicht funktionieren

Post by Roger Wilco » 2006-11-01 14:07

barkeeper69 wrote:ich versuche jetzt schon seit tagen mod_rewrite
zum laufen zu bringen, aber nix hat bisher genutzt.
Mehr Informationen bitte. Was funktioniert genau nicht mit welcher Fehlermeldung?

barkeeper69
Posts: 6
Joined: 2006-11-01 12:39

Re: mod_rewrite will einfach nicht funktionieren

Post by barkeeper69 » 2006-11-01 14:34

Roger Wilco wrote:
barkeeper69 wrote:ich versuche jetzt schon seit tagen mod_rewrite
zum laufen zu bringen, aber nix hat bisher genutzt.
Mehr Informationen bitte. Was funktioniert genau nicht mit welcher Fehlermeldung?
hallölee,

also jedesmal wenn ich die .htaccess in mein verzeichniss schiebe
bekomme ich folgende fehlermeldung:

Zugriff verweigert!
Der Zugriff auf das angeforderte Objekt ist nicht möglich. Entweder kann es vom Server nicht gelesen werden oder es ist zugriffsgeschützt.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 403

das ist der inhalt der .htaccess:

RewriteEngine on
RewriteRule ^sitemap.html$ fast_index.php
RewriteRule ^sitemap_([0-9]+).html$ fast_index.php?start_fast=$1
RewriteRule ^board_([0-9]+)_(.*).html$ board.php?boardid=$1
RewriteRule ^thread_([0-9]+)_(.*).html$ thread.php?threadid=$1


gruss

frank

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: mod_rewrite will einfach nicht funktionieren

Post by Roger Wilco » 2006-11-01 15:15

Schau in dein error_log und lies den Kasten "Note: Enabling rewrites in per-directory context" unter http://httpd.apache.org/docs/2.0/mod/mo ... ewriterule

barkeeper69
Posts: 6
Joined: 2006-11-01 12:39

Re: mod_rewrite will einfach nicht funktionieren

Post by barkeeper69 » 2006-11-01 17:20

Roger Wilco wrote:Schau in dein error_log und lies den Kasten "Note: Enabling rewrites in per-directory context" unter http://httpd.apache.org/docs/2.0/mod/mo ... ewriterule
also wenn ich das so wie das da steht in die httpd.conf
eintrage geht garnix.

sobald ich den eintrag "RewriteEngine on" rausnehme,
geht die seite wieder.

eine error_log habe ich net gefunden, nur eine error.conf

irgendwo verstehe ich da was nicht und ich bin der meinung
das ich das mit den einträge, wo genau die hinmüssen, nicht verstehe.

mattiass
Userprojekt
Userprojekt
Posts: 608
Joined: 2005-12-16 17:57

Re: mod_rewrite will einfach nicht funktionieren

Post by mattiass » 2006-11-01 17:26

barkeeper69 wrote:
eine error_log habe ich net gefunden, nur eine error.conf

Code: Select all

find /etc -type f -exec grep -Hni ErrorLog {} ;

barkeeper69
Posts: 6
Joined: 2006-11-01 12:39

Re: mod_rewrite will einfach nicht funktionieren

Post by barkeeper69 » 2006-11-01 17:52

MattiasS wrote:
barkeeper69 wrote:
eine error_log habe ich net gefunden, nur eine error.conf

Code: Select all

find /etc -type f -exec grep -Hni ErrorLog {} ;
danke habs gefunden...darin steht das Options FollowSymLinks off
wäre, ich habe das aber in der httpd.conf so geändert:

# forbid access to the entire filesystem by default
<Directory />
Options FollowSymLinks
AllowOverride All
Order allow, deny
Deny from all
</Directory>

mattiass
Userprojekt
Userprojekt
Posts: 608
Joined: 2005-12-16 17:57

Re: mod_rewrite will einfach nicht funktionieren

Post by mattiass » 2006-11-01 17:54

barkeeper69 wrote:
danke habs gefunden...darin steht das Options FollowSymLinks off
wäre, ich habe das aber in der httpd.conf so geändert:
Vielleicht solltest Du erst mal das ein RewriteLog für den betr. Vhost festlegen, das LogLevel hochsetzen und dann man in die Logs schauen. Der "find" sollte dazu dienen, schnell das Logfile ausfindig zu machen.

barkeeper69
Posts: 6
Joined: 2006-11-01 12:39

Re: mod_rewrite will einfach nicht funktionieren

Post by barkeeper69 » 2006-11-01 17:58

MattiasS wrote:
barkeeper69 wrote:
danke habs gefunden...darin steht das Options FollowSymLinks off
wäre, ich habe das aber in der httpd.conf so geändert:
Vielleicht solltest Du erst mal das ein RewriteLog für den betr. Vhost festlegen, das LogLevel hochsetzen und dann man in die Logs schauen. Der "find" sollte dazu dienen, schnell das Logfile ausfindig zu machen.
auf meinem server läuft auch confixx, vielleicht ist das noch
wichtig, da ja confixx auch einiges verstellt.

barkeeper69
Posts: 6
Joined: 2006-11-01 12:39

Re: mod_rewrite will einfach nicht funktionieren

Post by barkeeper69 » 2006-11-01 18:01

MattiasS wrote:
barkeeper69 wrote:
danke habs gefunden...darin steht das Options FollowSymLinks off
wäre, ich habe das aber in der httpd.conf so geändert:
Vielleicht solltest Du erst mal das ein RewriteLog für den betr. Vhost festlegen, das LogLevel hochsetzen und dann man in die Logs schauen. Der "find" sollte dazu dienen, schnell das Logfile ausfindig zu machen.
sorry keine ahnung wie ich das machen muss, bin in diesen sachen absoluter noob, aber lerne gerne immer dazu..;-)

oemi1980
Posts: 25
Joined: 2006-10-07 09:52

Re: mod_rewrite will einfach nicht funktionieren

Post by oemi1980 » 2006-11-03 22:51

barkeeper69 wrote:hallölee,

ich versuche jetzt schon seit tagen mod_rewrite
zum laufen zu bringen, aber nix hat bisher genutzt.

ich habe einen rootserver by s4y mit Suse 9.3 prof

das modul ist laut phpinfo auch geladen.
die httpd.conf habe ich auch angepasst.
php.ini auch.

hoffe nur das ich da nix verhauen habe.

wenn ich jetzt die .htaccess in mein verzeichniss
schiebe bekomme ich immer ein error 403 und nix geht mehr.

ihr seit jetzt meine letzte hoffnung.

danke

gruss

Frank

unter: /etc/sysconfig/apache2 findest du einen part der etwa so aussieht:

Code: Select all

# apache's default installation
# APACHE_MODULES="access actions alias asis auth autoindex cgi dir imap include log_config mime negotiation setenvif status userdir"
# your settings
APACHE_MODULES="access actions alias auth auth_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir php4 php5"
daraus machst du:

Code: Select all

# apache's default installation
# APACHE_MODULES="access actions alias asis auth autoindex cgi dir imap include log_config mime negotiation setenvif status userdir"
# your settings
APACHE_MODULES="access actions alias auth auth_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir rewrite php4 php5"
danach öffnest du deine httpd.conf und fügst ganz am Ende nachdem die Confixx-Dateien includet werden folgenden Code ein:

Code: Select all

<Directory "/srv/www/htdocs/webX/html">
  AllowOverride All
  Options +FollowSymLinks +SymLinksIfOwnerMatch
  <IfModule mod_access.c>
    Allow from all
  </IfModule>
</Directory>
denke daran das webX in web1 oder web2 zu ändern.....

Apache neustarten mit:

Code: Select all

/etc/init.d/apache2 restart
jetzt sollte es laufen :-)