MAIL-Empfang

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
tjabo
Posts: 59
Joined: 2004-09-13 20:16

MAIL-Empfang

Post by tjabo » 2006-10-25 13:32

Hallo,
ich habe ein kleines Problem mit dem Server. Es ist Postfix 2.0 drauf, Spamassassin, Bind 9.etwas...

Ich bekomme nun einige ganz wenige emails nicht rein?! Woran kònnte dies liegen?

Denn wie ich gesehen habe ist scheinbar ein ReverseDNS fuer die ServerIP noch nicht gemacht worden.

Auch Spamassassin filtert diese mails nicht raus, also an dem duerfte es nicht liegen.

Danke.
mfg
tjabo

cat
RSAC
Posts: 125
Joined: 2002-09-14 20:57
Location: unterwegs-im.net ;)

Re: MAIL-Empfang

Post by cat » 2006-10-25 14:21

hmm?

was verstehst Du darunter "bekommst nicht rein"

was sind das fuer Mails?

greetz
Cat

tjabo
Posts: 59
Joined: 2004-09-13 20:16

Re: MAIL-Empfang

Post by tjabo » 2006-10-25 16:57

hmm, also die mail kommen nicht beim server an, oder kommen dort an und werden abgelehnt, weiss es eben nicht,
denn der absender bekommt "scheinbar" keine nachricht, dass die mail nicht rausgegangen ist, jedoch sehe ich selbst keine mails im posteingang, also muss die irgendwo verloren gegangen sein?!

wie kann sowas passieren,? denn den grossteil, oder ich denke mal wirklich fast alle mails bekomme ich rein, und der server hat auch keine downtime und sonst eigentlich auch keine probleme...?!

mfg
tjabo

cat
RSAC
Posts: 125
Joined: 2002-09-14 20:57
Location: unterwegs-im.net ;)

Re: MAIL-Empfang

Post by cat » 2006-10-25 17:05

hast Du schonmal im mail.log geschaut? werden die vielleicht rejectet oder als SPAM klassifiziert?

tjabo
Posts: 59
Joined: 2004-09-13 20:16

Re: MAIL-Empfang

Post by tjabo » 2006-10-25 17:12

hmm, ne noch nicht, aber eine mail.log datei existiert auf meinem server nicht?!

in der /var/log/mail ?
danke

also in der /var/log/mail.err
steht folgendes
vi /var/log/mail.err
Vim: Warning: Output is not to a terminal
Vim: Warning: Input is not from a terminal
[m[m[0m[H[2J[24;1H"/var/log/mail.err" 38L, 4280C[1;1HJan 20 00:10:02 developer spamc[9096]: connect(AF_INET) to spamd at 127.0.0.1 fa[2;1Hiled, retrying (#1 of 3): Connection refused
Jan 20 00:10:03 developer spamc[9096]: connect(AF_INET) to spamd at 127.0.0.1 fa[4;1Hiled, retrying (#2 of 3): Connection refused
Jan 20 00:10:04 developer spamc[9096]: connect(AF_INET) to spamd at 127.0.0.1 fa[6;1Hiled, retrying (#3 of 3): Connection refused
Jan 20 00:10:05 developer spamc[9096]: connection attempt to spamd aborted after[8;2H3 retries
Jan 20 14:08:10 developer spamc[13868]: connect(AF_INET) to spamd at 127.0.0.1 f[10;1Hailed, retrying (#1 of 3): Connection refused
Jan 20 14:08:11 developer spamc[13868]: connect(AF_INET) to spamd at 127.0.0.1 f[12;1Hailed, retrying (#2 of 3): Connection refused
Jan 20 14:08:12 developer spamc[13868]: connect(AF_INET) to spamd at 127.0.0.1 f[14;1Hailed, retrying (#3 of 3): Connection refused
Jan 20 14:08:13 developer spamc[13868]: connection attempt to spamd aborted afte[16;1Hr 3 retries
Jan 21 00:10:01 developer spamc[17180]: connect(AF_INET) to spamd at 127.0.0.1 f[18;1Hailed, retrying (#1 of 3): Connection refused
Jan 21 00:10:02 developer spamc[17180]: connect(AF_INET) to spamd at 127.0.0.1 f[20;1Hailed, retrying (#2 of 3): Connection refused
Jan 21 00:10:03 developer spamc[17180]: connect(AF_INET) to spamd at 127.0.0.1 f[22;1Hailed, retrying (#3 of 3): Connection refused
Jan 21 00:10:04 developer spamc[17180]: connection attempt to spamd aborted afte[23;1H[1m[34m@ [0m[24;63H1,1[11CTop[1;1H[24;1HVim: Error reading input, exiting...
Vim: Finished.
[24;1H
aber die errors scheinen echt alt zu sein...

cat
RSAC
Posts: 125
Joined: 2002-09-14 20:57
Location: unterwegs-im.net ;)

Re: MAIL-Empfang

Post by cat » 2006-10-25 17:16

na, dann halt da, wohin bei Dir der Mail Traffic geloggt wird, ich kann ja net hellsehen, wie das Teil bei Dir heisst ;)

und sollte in dem Log die Mail keine Erwaehnung finden, kannst Du davon aussgehen, dass die nie Deinen Server erreicht hat, demzufolge das Problem woanders zu suchen ist. (Vielleicht geht das Mail-Routing ueber Peking und dauert entsprechend laenger *G*)

EDIT:
Ups .. reply net ganz gelesen ;)

grep mal nach der Mail Adresse vom Absender

tjabo
Posts: 59
Joined: 2004-09-13 20:16

Re: MAIL-Empfang

Post by tjabo » 2006-10-25 17:19

danke, aber maybe lags echt am mx record, dieser ist nun drinnen, also sollte das ganze hoffentlich laufen :)

mfg
tjabo

wenn nicht meld ich mich klarerweise nochmals