CGI Awstats geht nicht

Apache, Lighttpd, nginx, Cherokee
umbroboy
Posts: 258
Joined: 2005-05-11 11:49

CGI Awstats geht nicht

Post by umbroboy »

Hallo,

leider bekomm ich awstats in deinem anderen verzeichnis ausser das standart verzeichnis nicht zum laufen.

Ich verzweifel jetzt langsam.

Laut setup file wollte er es unter /usr/local/awstats haben.

wenn ich http://www.domain.de/awstats macht funktioniert es auch.

Nur wollte ich das passwort schützen und habe schon ein eigenes verzeichs gemacht wie folgt:

Code: Select all

/var/www/admin/awstats
Hier zu zeigt ein Symlink auf

Code: Select all

/usr/local/awstats/cgi-bin
Dieser part ist in der httpd.conf von apache2 drin:

Code: Select all

Alias /awstatsclasses "/usr/local/awstats/wwwroot/classes/"
Alias /awstatscss "/usr/local/awstats/wwwroot/css/"
Alias /awstatsicons "/usr/local/awstats/wwwroot/icon/"
ScriptAlias /awstats/ "/usr/local/awstats/wwwroot/cgi-bin/"


Alias /var/www/admin/awstatsclasses "/usr/local/awstats/wwwroot/classes/"
Alias /var/www/admin/awstatscss "/usr/local/awstats/wwwroot/css/"
Alias /var/www/admin/awstatsicons "/usr/local/awstats/wwwroot/icon/"
ScriptAlias /var/www/admin/awstats/ "/usr/local/awstats/wwwroot/cgi-bin/"
#
# This is to permit URL access to scripts/files in AWStats directory.
#
<Directory "/usr/local/awstats/wwwroot">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

meine default sieht noch so aus:
Den oberen part mit den Ipnummern hab ich weggelassen.

Code: Select all

	<Directory />
		Options FollowSymLinks
		AllowOverride All
	</Directory>
	<Directory /var/www/>
		Options -Indexes FollowSymLinks MultiViews ExecCGI
		AllowOverride All
		Order allow,deny
		allow from all
		# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
#         RedirectMatch ^/$ /apache2-default/
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride All
		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined
	ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

	<Directory "/usr/local/awstats">
	Options +ExecCGI FollowSymLinks -MultiViews +SymLinksIfOwnerMatch
	AddHandler cgi-script .cgi .pl
	AllowOverride None
	Order allow,deny
	Allow from all
</Directory>

	<Location "/var/www/admin/awstats">
	Options +ExecCGI FollowSymLinks -MultiViews +SymLinksIfOwnerMatch
	SetHandler cgi-script
	AddHandler cgi-script .cgi .pl
	AllowOverride None
	Order allow,deny
	Allow from all
	</Location>

	<Directory "/var/www/admin/awstats">
	Options +ExecCGI FollowSymLinks -MultiViews +SymLinksIfOwnerMatch
	SetHandler cgi-script
	AddHandler cgi-script .cgi .pl
	AllowOverride None
	Order allow,deny
	Allow from all
</Directory>
	 
</VirtualHost>
So und nun meine fehlermeldung:


[Sun Oct 15 23:14:23 2006] [error] [client 62.245.163.53] Options ExecCGI is off in this directory: /var/www/admin/awstats/awstats.pl

aber dies option ist doch gesetzt bei den directorys oder auch bei der location.

ich versteh es ned...
:?

Viele Grüße
marcus
umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: CGI Awstats geht nicht

Post by umbroboy »

so hab den fehler gefunden.

Die option +ExecCGI geht nur ohne dem Plus zeichen.

viele grüße