Mod_Gzip funktioniert nicht auf der ganzen Seite

Apache, Lighttpd, nginx, Cherokee
Anonymous
 

Mod_Gzip funktioniert nicht auf der ganzen Seite

Post by Anonymous »

Hallo,

bei meiner Seite Limundo habe ich
Gzip aktiviert.
Alles läuft perfekt.

Gzip funktioniert auf alle Seiten, bis auf das Forum.

Folgendes ist eingestellt:

Code: Select all

  mod_gzip_on                   Yes
  mod_gzip_minimum_file_size    500
  mod_gzip_maximum_file_size    300000
  mod_gzip_min_http             1000
  mod_gzip_can_negotiate        No
  mod_gzip_add_header_count     Yes
  mod_gzip_keep_workfiles       No
  mod_gzip_temp_dir             /tmp
  mod_gzip_maximum_inmem_size   60000
  mod_gzip_min_http             1000
  mod_gzip_dechunk              Yes
  mod_gzip_item_include         file       .html$
  mod_gzip_item_include         file       .htm$ 
  mod_gzip_item_include         file       .phtml$ 
  mod_gzip_item_include         file       .php3$ 
  mod_gzip_item_include         file       .php4$ 
  mod_gzip_item_include         file       .pl$
  mod_gzip_item_include         file       .php$
  mod_gzip_item_include         file       .pl$
  mod_gzip_item_include         handler    ^cgi-script$
  mod_gzip_item_include         mime       ^text/html$
  mod_gzip_item_include         mime       ^text/plain$
  mod_gzip_item_include         mime       ^httpd/unix-directory$
  mod_gzip_item_exclude         mime       ^image/
  mod_gzip_item_exclude         file       .js$
  mod_gzip_item_exclude         file       .css$
Es handelt sich um einen dedicated Server.

Meine einzige Erklärung:
das Forum ist in einem Unterordner ist,
http://www.limundo.com/limundocafe, kann dadurch vielleicht gzip nicht darauf ansprechen?

Vielen Dank im voraus für die schnelle Antwort
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53
 

Re: Mod_Gzip funktioniert nicht auf der ganzen Seite

Post by Roger Wilco »

Vermutlich benutzt Vanilla einfach nicht die entsprechenden PHP Funktionen...
Anonymous
 

Re: Mod_Gzip funktioniert nicht auf der ganzen Seite

Post by Anonymous »

Also liege ich mit meiner Vermutung falsch, und Gzip ist für den ganzen Server aktiviert.

Wenn ich etwas an der httpd.conf verändere, muss ich dann den ganzen Server neu starten, oder gitb es eine elegantere (sprich: schneller)
Methode.
Denn so ist der Server so ca. 10-15 minuten nicht ansprechbar.
wayne
Posts: 10
Joined: 2006-10-15 01:22
 

Re: Mod_Gzip funktioniert nicht auf der ganzen Seite

Post by wayne »

Für die httpd.conf muss nur der Apache neu gestartet werden. Meist

apachectl restart:

wenn das nicht geht:

/pfad/zu/apache/bin/httpd -k restart


Wenn der Apache selbst 15 Minuten zum starten braucht, hast Du ganz andere Probleme als gzip ;)