mal wieder Fehler 500, aber NUR BEI USERDIR

Apache, Lighttpd, nginx, Cherokee
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

mal wieder Fehler 500, aber NUR BEI USERDIR

Post by cybi82 »

Hi
hab mal wieder ein kleines Problem.
Ich hab mir nun Subdomains mittels V-Hosts auf meinem server eingerichtet. Diese funktionieren auch einwandfrei.
Jedoch klappen seit dem die Zugriffsberechtigungen bei Seitenaufrufen mittes UserDir nicht mehr korrekt...
html-Dateien werden noch korrekt angezeigt, aber PHP klappt nicht mehr. Bekomm immer den altbekannten Fehler 500 :(

Hier einmal meine vhost.de.conf

Code: Select all

<VirtualHost 123.456.789.012:80>
    ServerAdmin webmaster@DOMAIN.de
    ServerName DOMAIN.de
    ServerAlias www.DOMAIN.de

    DocumentRoot  /home/DOMAIN/public_html


    ErrorLog /var/log/apache2/DOMAIN.de-error_log
    CustomLog /var/log/apache2/DOMAIN.de-access_log combined

    <Directory "/home/DOMAIN/public_html">
	Options FollowSymLinks
	AllowOverride All
	Order allow,deny
	Allow from all
    </Directory>

</VirtualHost>
Dann meine default-server.conf

Code: Select all

<VirtualHost *:80>
    ServerAdmin webmaster@DOMAIN.de
    ServerName DOMAIN.de

    ErrorLog /var/log/apache2/DOMAIN.de-error_log
    CustomLog /var/log/apache2/DOMAIN.de-access_log combined

    <IfModule mod_userdir.c>
			UserDir /home/*/public_html
			Include /etc/apache2/mod_userdir.conf
    </IfModule>
</VirtualHost>


<Directory "/home/DOMAIN/public_html">
	Options FollowSymLinks
	AllowOverride All
	Order allow,deny
	Allow from all
</Directory>

Alias /icons/ "/usr/share/apache2/icons/"

<Directory "/usr/share/apache2/icons">
	Options Indexes MultiViews
	AllowOverride None
	Order allow,deny
	Allow from all
</Directory>

<Directory "/srv/www/cgi-bin">
	AllowOverride None
	Options +ExecCGI -Includes
	Order allow,deny
	Allow from all
</Directory>

 <IfModule mod_userdir.c>
	UserDir public_html
	Include /etc/apache2/mod_userdir.conf
	<Directory /home/*/public_html>
	    AllowOverride FileInfo AuthConfig Limit Indexes
	    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
	    <Limit GET POST OPTIONS PROPFIND>
	        Order allow,deny
       	 Allow from all
	    </Limit>
	</Directory>
    </IfModule>

Include /etc/apache2/conf.d/*.conf
Include /etc/apache2/conf.d/apache2-manual?conf


und abschließend noch mein error-log bei einem Aufruf wie zb "http://DOMAIN.de/~USERNAME"

Code: Select all

[Fri Oct 06 11:05:18 2006] [error] [client 217.91.76.71] File does not exist: /home/USERNAME/public_html/css, referer: http://DOMAIN.de/~USERNAME/
[Fri Oct 06 11:05:18 2006] [error] [client 217.91.76.71] Premature end of script headers: index.php, referer: http://DOMAIN.de/~USERNAME/
[Fri Oct 06 11:05:18 2006] [error] [client 217.91.76.71] Error in suphp.c on line 244: Script is not in document root, referer: http://DOMAIN.de/~USERNAME/
[Fri Oct 06 11:05:18 2006] [error] [client 217.91.76.71] File does not exist: /home/DOMAIN/public_html/favicon.ico

was mach ich falsch?
wieso sucht (wenn ich das überhaupt richtig deute) mein php in meinem DOMAIN-Home anstelle in dem des Users USERNAME?

danke schon mal im vorraus[/code]
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: mal wieder Fehler 500, aber NUR BEI USERDIR

Post by Roger Wilco »

Cybi82 wrote:

Code: Select all

[Fri Oct 06 11:05:18 2006] [error] [client 217.91.76.71] Error in suphp.c on line 244: Script is not in document root, referer: http://DOMAIN.de/~USERNAME/
Eigentlich eindeutig. Lies die Dokumentation von SuPHP. Insbesondere die Option handle_userdir sollte für dich relevant sein.
Cybi82 wrote:was mach ich falsch?
wieso sucht (wenn ich das überhaupt richtig deute) mein php in meinem DOMAIN-Home anstelle in dem des Users USERNAME?
Nicht PHP, sondern SuPHP...
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: mal wieder Fehler 500, aber NUR BEI USERDIR

Post by cybi82 »

hmm, thx. aber... ich hab suPHP 0.5... und wenn ich das nu richtig recherchiert hab, gibts die einstellung erst ab 0.6 right?

Hab mal versucht das zu updaten, aber da will er zb ein Paket names httpd-mmn haben... was ich wiederrum nicht finde.

Gibts ne möglichkeit diese Einstellung auch ohne die suPHP.conf zu konfigurieren? (also mit der alten Version)

greetz
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: mal wieder Fehler 500, aber NUR BEI USERDIR

Post by Roger Wilco »

Cybi82 wrote:Gibts ne möglichkeit diese Einstellung auch ohne die suPHP.conf zu konfigurieren? (also mit der alten Version)
Nein, da es diese Option erst seit SuPHP 0.6 gibt.