mod_fastcgi und phpmyadmin, die alter 500er Laier...

Apache, Lighttpd, nginx, Cherokee
melchior
Posts: 4
Joined: 2006-10-01 17:47

mod_fastcgi und phpmyadmin, die alter 500er Laier...

Post by melchior »

Hallo,

habe hier ein Problem das mir schon seit gestern Kopfschmerzen bereitet. Boardsuche und Google bringen micht nicht weiter. Es geht nur um phpmyadmin, ich krieg es einfach nicht zum laufen. Ich bekomme immer die Fehlermeldung 500...

In der Config von phpmyadmin hab ich cookie als auth angegeben, damit hatten viele Leute auch Probleme, nur um den Fehler mal auszuschließen.

system: apache2 mit mod_fastcgi
phpmyadmin: liegt in /usr/share/phpmyadmin

/usr/share/phpmyadmin ist auf /var/www/phpmyadmin und /var/www/omoo/web/phpmyadmin ver-soft-linked.

zum testen gibts noch:
/usr/share/test ist auf /var/www/omoo/web/test ver-soft-linked. Darin liegt ne test.php

Als owner von phpmyadmin und test ist der suexec user testweise mit 777 eingetragen.

Greife ich jetzt auf http://192.168.178.22/phpmyadmin zu, so bekomm ich nen 500er. Wenn ich auf http://192.168.178.22/test zugreife wird die Datei angezeigt.

Weiss wirklich nicht mehr weiter :( Hocke hier schon mir roten Augen und kann nicht mehr denken, will aber umbedingt wissen warum das net geht. Habe echt jetzt alle Möglichkeiten durch, jedenfalls die die ich kenne. Hier mal die config und log

Da ich ansonsten mit php und fcgi keine Probs habe, verschone ich euch vorerst mal mit den configs ...


viele Grüße!
Melchior

aktuelle site-enabled:

Code: Select all

<VirtualHost *:80>
        ServerAdmin me@domain.de
        ServerName domain.de
        ServerAlias www.domain.de

        DocumentRoot /var/www/omoo/web/
        DirectoryIndex index.php index.html index.htm
        SuexecUserGroup www-omoo www-omoo

        <Directory />
                Options FollowSymLinks
                AllowOverride None
                allow from all
        </Directory>

       Alias /phpmyadmin/ /usr/share/phpmyadmin/
        <Directory /usr/share/phpmyadmin>
                Options FollowSymLinks
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        <Directory /var/www/omoo/web>
                Options FollowSymLinks
                AllowOverride AuthConfig
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /var/www/php-fcgi-scripts/omoo/
        <Directory /var/www/php-fcgi-scripts/omoo>
                AllowOverride None
                Options +ExecCGI -MultiViews -Indexes
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On


        Alias /icons/ "/usr/share/apache2/icons/"
        <Directory "/usr/share/apache2/icons">
                Options Indexes MultiViews
                AllowOverride None
                Order allow,deny
                Allow from all
        </Directory>
</VirtualHost>

error-log-apache

Code: Select all

[Sun Oct 01 20:48:57 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
[Sun Oct 01 20:48:57 2006] [notice] FastCGI: wrapper mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
[Sun Oct 01 20:48:57 2006] [notice] FastCGI: process manager initialized (pid 21003)
[Sun Oct 01 20:48:57 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/omoo/php-fcgi-starter" (uid 1001, gid 1001) started (pid 21005)
[Sun Oct 01 20:48:57 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_fastcgi/2.4.2 configured -- resuming normal operations
[Sun Oct 01 20:48:59 2006] [alert] [client 192.168.178.200] /var/www/omoo/web/phpmyadmin/.htaccess: DirectoryIndex not allowed here
[Sun Oct 01 20:48:59 2006] [alert] [client 192.168.178.200] /var/www/omoo/web/phpmyadmin/.htaccess: DirectoryIndex not allowed here
[/code]
flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: mod_fastcgi und phpmyadmin, die alter 500er Laier...

Post by flo »

Du setzt im Verzeichnis "web" einen AllowOverride AuthConfig - in der .htaccess versuchst Du, den DirectoryIndex anzupassen - die Alte Leier also - Logs, die nicht gelesen werden.

flo.
melchior
Posts: 4
Joined: 2006-10-01 17:47

Re: mod_fastcgi und phpmyadmin, die alter 500er Laier...

Post by melchior »

argh, ich habs.

Habe jetzt mal in allen directories Allow Override auf All gesetzt, also weiss schon mal wo der wurm drin war.

Naja, vielleicht hilft der Thread ja denjenigen, die das selbe Problem haben :)

gruß
rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: mod_fastcgi und phpmyadmin, die alter 500er Laier...

Post by rootsvr »

Alles auf 777 setzen und AllowOverride all ist nen guter Tip für alle bei denen was nicht geht *sarkasmus*
melchior
Posts: 4
Joined: 2006-10-01 17:47

Re: mod_fastcgi und phpmyadmin, die alter 500er Laier...

Post by melchior »

*ggg* wusste, dass das auf jeden Fall jemand schreibt.

Iss nur zum Testen, wird natürlich alles wieder umgestellt.
gruß