phpmyadmin nicht über browser aufrufbar.!?

Apache, Lighttpd, nginx, Cherokee
joil
Posts: 20
Joined: 2006-07-30 15:44
Location: Aachen

phpmyadmin nicht über browser aufrufbar.!?

Post by joil »

hallo zusammen,

ich habe auf meinen debian3.1sarge 64bit über apt-get install phpmyadmin, phpmyadmin isntalliert... soweit alles wunederbar.. (phpmyamdin liegt jetzt in (/usr/share/phpmyadmin) und es hat mir automatisch einen softlink in /var/www erstellt.. jedoch will ich phpmyadmin nur für einen vhost sichtbar machen.. also: link in das entsprechende web-verzeichnis des vhost cerschoben.. aber: wenn ich den vhost über den browser öffne sehe ich die dateiliste mit allen dateien und ordnern im verzeichnis aber nicht phpmyadmin.. !?

auch wenn ich selbst nochmal manuell einen neuen link zu phpmyadmin erstelle klappts nicht.

testweise hab ich einen link nach /usr/share erstellt..--> klappt wunederbar aber wenn ich jetzt die dateiliste von /usr/share im browser durchgucke fehlt phpmyadmin schon wieder!!!

der ordner existiert aber..

wie kann ich den link bzw. den phpmyadmin ordner denn evtl sichtbar und "zugreifbar" machen??

p.s. benutze apache 2.0.55 und php5.1.6 als fastcgi... dazu mysql 4.1
User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: phpmyadmin nicht über browser aufrufbar.!?

Post by daemotron »

Du brauchst für den vhost die Direktive

Code: Select all

<Directory "/pfad/zu/vhost">
  ...  
  Options +FollowSymLinks
  ...
</Directory>
Sicherer ist dann allerdings noch die Variante mit SymLinksIfOwnerMatch (siehe http://httpd.apache.org/docs/2.0/mod/core.html#options)
joil
Posts: 20
Joined: 2006-07-30 15:44
Location: Aachen

Re: phpmyadmin nicht über browser aufrufbar.!?

Post by joil »

ahh super vielen dank!!!

lag an der /etc/apache2/conf.d/phpmyadmin.conf..

da musst ich eifnach noch den pfad anpassen, sodass der phpmyamdin link die option AllowOverride All hat...

aber dein hinweis hat mich erst drauf gebracht nochmal danke!!