benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Apache, Lighttpd, nginx, Cherokee
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

Hi
hab seit gestern bei Strato einen neuen Suse Linux 9.3 Dedicated-Server. Bisher waren meine Pages bei Alturo auf nem 9.1er System gehostet. Die machen aber nu dicht und ich braucht ne alternative.

Hab nun mal den ersten User angelegt und mittels ftp die page wieder ins public_html des neuen benutzers hochgeladen.

bei meiner alten maschiene konnt ich diese dann mit folgender syntax im browser erreichen:
"http://domainname.de/~benutzername"

das klappt nun nicht mehr... bei alturo musst ich da nix für machen, daher hab ich keine idee wo ich suchen sollte.

die httpd.conf hab ich ma durchforstet... da find ich nix. vhosts hab ich noch keine... ham aber auhc nix damit zu tun oder?

greetz
Cybi
User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by daemotron »

cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

hmm, danke, aber...

Code: Select all

<IfModule mod_userdir.c>

    UserDir disabled root

    UserDir enabled
    UserDir /home/*/public_html


    <Directory /home/*/public_html>

        AllowOverride FileInfo AuthConfig Limit Indexes
        Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec

        <Limit GET POST OPTIONS PROPFIND>
            Order allow,deny
            Allow from all
        </Limit>

        <LimitExcept GET POST OPTIONS PROPFIND>
            Order deny,allow
            Deny from all
        </LimitExcept>

    </Directory>

</IfModule>
so siehts bei mir aus un will immer noch nicht :(
(apache is neu gestartet, aber... tut sich garnix)

bekomm immer noch den Fehler:
Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 404
User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by daemotron »

Ist denn mod_userdir überhaupt geladen? (siehe Apache-Doku)
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

wenn ichs richtig sehe, ja


default-server.conf

Code: Select all

#
# Global configuration that will be applicable for all virtual hosts, unless
# deleted here, or overriden elswhere.
#


DocumentRoot "/usr/local/visas/public_html/"

#
# Configure the DocumentRoot
#
<Directory "/usr/local/visas/public_html/">
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs-2.0/mod/core.html#options
    # for more information.
    Options FollowSymLinks
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    AllowOverride All
    # Controls who can get stuff from this server.
    Order allow,deny
    Allow from all
</Directory>

# Aliases: aliases can be added as needed (with no limit). The format is
# Alias fakename realname
#
# Note that if you include a trailing / on fakename then the server will
# require it to be present in the URL.  So "/icons" isn't aliased in this
# example, only "/icons/".  If the fakename is slash-terminated, then the
# realname must also be slash terminated, and if the fakename omits the
# trailing slash, the realname must also omit it.
#
# We include the /icons/ alias for FancyIndexed directory listings.  If you
# do not use FancyIndexing, you may comment this out.
#
Alias /icons/ "/usr/share/apache2/icons/"

<Directory "/usr/share/apache2/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>


# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the client.
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.
#
#ScriptAlias /cgi-bin/ "/srv/www/cgi-bin/"

# "/srv/www/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "/srv/www/cgi-bin">
    AllowOverride None
    Options +ExecCGI -Includes
    Order allow,deny
    Allow from all
</Directory>

# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
# To disable it, simply remove userdir from the list of modules in APACHE_MODULES
# in /etc/sysconfig/apache2.
#
<IfModule mod_userdir.c>
    # Note that the name of the user directory ("public_html") cannot simply be
    # changed here, since it is a compile time setting. The apache package
    # would have to be rebuilt. You could work around by deleting
    # /usr/sbin/suexec, but then all scripts from the directories would be
    # executed with the UID of the webserver.
    UserDir public_html
    # The actual configuration of the directory is in
    # /etc/apache2/mod_userdir.conf.
    Include /etc/apache2/mod_userdir.conf
    # You can, however, change the ~ if you find it awkward, by mapping e.g.
    # http://www.example.com/users/karl-heinz/ --> /home/karl-heinz/public_html/
    #AliasMatch ^/users/([a-zA-Z0-9-_.]*)/?(.*) /home/$1/public_html/$2
</IfModule>


# Include all *.conf files from /etc/apache2/conf.d/.
#
# This is mostly meant as a place for other RPM packages to drop in their
# configuration snippet.
#
# You can comment this out here if you want those bits include only in a
# certain virtual host, but not here.
#
Include /etc/apache2/conf.d/*.conf

# The manual... if it is installed ('?' means it won't complain)
Include /etc/apache2/conf.d/apache2-manual?conf

rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by rootsvr »

Da steht nicht das es aktiviert ist..

gibt es eine Zeile die so ausschaut:
LoadModule userdir_module modules/mod_userdir.so

?
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

hmm... ich find keine.
in welcher file sollte die denn stehen?

(sry für die nooby-fragen... bei dem alturo-server klappte das "leider" schon...)
duergner
Posts: 923
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by duergner »

[x] Du willst endlich die Apache Doku lesen!
rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by rootsvr »

Nooby fragen sind immer schlecht.. vor allem hier.

Ich hab kein SuSE, deshalb kann ich dir da nicht helfen, angeblich gibt es ein "a2enmod" was man nutzen kann..

versuch mal

Code: Select all

a2enmod mod_userdir
Und danch geh deinen PC kennenlernen :evil:
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

danke für die hilfe.
ich weis dass hier keine noobs erwünscht sind, so viel hab ich schon mitbekommen...
ganz unbetucht bin ich ja auch nicht. bin selbst anwendungsentwickler, nur mit linux hab ich vor n paar monaten erst angefangen...

aber desshalb brauchste ma nit direkt überheblich werden hier...
nur weil du über linux mehr weist als ich bist du noch lange kein gott. also komm mal wieder runter
rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by rootsvr »

Ich war imho garnicht überheblich, das sieht dann ganz anders aus..
Außerdem steht das mit den noobs exakt so in den Foren Regeln (nicht von mir) und im Endeffekt leiden im schlimmsten Fall alle anderen Netznutzer und schlechten/unwissenden/unerfahrenen Administratoren.

Zu Deinem Anwendungsentwickler: Ich frag auch nicht Schumi das er mir den Wagen repariert, seine Autokenntnisse hätten nichts mit meinen Bedürfnissen zu tun.

Ich bin bei weitem auch nicht allwissend, glaube aber das ich meine Konfiguration (weitestgehend) durchschaut habe.

Was ich halt nicht verstehe: jeder braucht (glaubt zu brauchen) nen Rootserver/vServer und die wenigstens haben Ahnung, Interesse oder Muße ihren Server vernünftig zu administrieren. Hauptsache geht, hauptsache cool. Die meisten kämen mit nem großen Webspaceaccount gut aus, und müßten sich nicht noch um so nen Kram kümmern.
Sie kümmern sich ja auch nicht drum, am Ende heulen sie hier rum, mein Server ist gehackt was soll ich tun, nichts geht mehr, ich hab keine Ahnung.. super und auf meiner Kiste seh ich die Brute Force Angriffe von seinem Server.
Aber Geiz ist geil und es gibt immer noch ein paar dumme die einem alles vorbeten, dann muß man nichtmal mehr Anleitungen lesen oder selber suchen.

Dein Problem (mod_userdir aktiviren) läßt sich zumindest mit minimaler Übertragungssleistung im ersten von google gefundenen Link lösen (nehm ich an)
http://www.google.com/search?hs=014&hl= ... =Suche&lr=
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

also.... der Ansatz war richtig.
Das Modul UserDir war nicht geladen.
auch wenn ich hier so doof angeblökt wurde trotz entschuldigung werd ich trotzdem mal für nachfolgende mit dem selben Problem die Lösung hier posten.


in der Datei /etc/apache2/sysconfig.d/loadmodule.conf
kann man sehen, welche module geladen wurden.
(ändern braucht/sollte man nichts. Datei wird bei apache2 start neu generiert)

Steht "userDir" nicht mit aufgeführt, fehlen folgende Einträge/Konfigurationen

1. um das Modul zu laden tragen Sie in der Datei /etc/sysconfig/apache2 in die folgende Zeile noch den Modulnamen "userdir" ein

Code: Select all

 
APACHE_MODULES="access actions alias auth auth_dbm autoindex cgi dir [b]userdir[/b] expires include log_config mime negotiation setenvif ssl suexec mod_suphp php4"


2. diese beiden Zeilen in der Datei /etc/apache2/mod_userdir.conf einfügen um den Aufruf für jeden User (ausser root) zu aktivieren.

Code: Select all

 
  UserDir disabled root
  
  UserDir /home/*/public_html

mfg
Cybi
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

@rootsvr:

jo, der google-link wärs gewesen. gut.. anderes modul aber damit hätt ichs auch auf anhieb hinbekommen.
Dass ich mich nicht drum kümmer bzw es nicht brauche ist ne Unterstellung welche ich verneine. Bei nem Webspace hätt ich keinerlei möglichkeiten für Crons etc. auf die ich jedoch angewiesen bin. (automatische aktualisierung=sync mit Lieferant von Webshop-DB zum Beispiel)
Sicherheitsaspekte sind mir mit sicherheit nicht unwichtig. Ich bin mir jedoch auch bewusst, dass ich noch lange nicht genug darüber weis. Aber ich denke dass beide Seiten mehr davon hätten, wenn nicht dauernd direkt gemotzt wird. Ich mein nicht, dass ihr alles haar klein erklären sollt, aber nur weils howtos und anleitungen gibt, heists doch nit dass die jeder findet, bzw kennt.

der letzte link mit 2 sätzen hätte gereicht. ;)

wie auch immer... nu gehts

nu kommt zwar fehler 500
aber das hab ich eben schon irgendwo in verbindung mit strato gelesen :-P
rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by rootsvr »

Cybi82 wrote: Ich mein nicht, dass ihr alles haar klein erklären sollt, aber nur weils howtos und anleitungen gibt, heists doch nit dass die jeder findet, bzw kennt.
Ich nutze kein Suse, bin nicht bei Strato und hab kein mod_userdir im Einsatz, trotzdem finde ich den Link.. bin ich ein Google-Gott(tm)?

SCNR
cybi82
Posts: 36
Joined: 2005-12-12 12:09
Location: wermelskirchen

Re: benutzerspezifisches public_html ansprechen mittels ~ in url geht nicht (STRATO)

Post by cybi82 »

:)
wer weis
aber ich hab vorher wirklich gescuht... und warscheinlich dann wohl nach den falschen stichworten. :(
naja. nu läuft alles.
den 500er fehler hab ich auch weg (ohne suPHP auszutragen ;) )