fcgid unter SuSE?

Apache, Lighttpd, nginx, Cherokee
einherjer
Posts: 24
Joined: 2002-06-05 05:11
Location: München

fcgid unter SuSE?

Post by einherjer »

Hi,

hatte unter 9.1 eine recht gut laufende Konfiguration mit mod_fcgi, mehrere vhosts mit jeweils eigener php.ini, suexec

Jetzt stell ich aber fest das neue SuSE Versionen scheinbar fcgid mitbringen.

Lt. den Angaben auf http://fastcgi.coremail.cn/configuration.htm#suPHP bring ich das aber nicht zum laufen...

Verwendet das schon jemand in einer ähnlichen Konfiguration?
Ich finde auch nirgens Hinweise darauf die man nun jedem vhost seine eigene php.ini unterjubelt was schon aufgrund der jeweils eigenen Session, tmp und basedir Pfade wünschenswert wäre.

Damit das es nur mehr php5 gibt kann ich ja vielleicht leben ;-)

Derzeit enden meine Versuche mit

Code: Select all

Warning: SuexecUserGroup directive requires SUEXEC wrapper.
in rcapache2.out und

Code: Select all

[Tue Sep 12 10:52:55 2006] [error] (13)Permission denied: mod_fcgid: couldn't bind unix domain socket /srv/www/logs/fcgidsock/32013.17
[Tue Sep 12 10:52:55 2006] [warn] (13)Permission denied: mod_fcgid: spawn process /home/alterkon/public_html/htdocs/test.php error
in default_error_log
einherjer
Posts: 24
Joined: 2002-06-05 05:11
Location: München

Re: fcgid unter SuSE?

Post by einherjer »

Mittlerweile hab ich apache zumindest soweit das er suexec wieder einbindet - er will /usr/sbin/suexec2 gerne setuid root haben.

Trotzdem werden noch immer keine php scripts ausgeführt sondern ein Fehler 500 ausgegeben und zum download angeboten...

suexec.log sagt jetzt

Code: Select all

[2006-09-13 10:40:29]: uid: (1006/alterkon) gid: (1006/1006) cmd: php_fcgi
[2006-09-13 10:40:29]: command not in docroot (/home/user/public_html/htdocs/fcgi-bin/php_fcgi)
suexec2 -V

Code: Select all

-D AP_DOC_ROOT="/srv/www"
 -D AP_GID_MIN=96
 -D AP_HTTPD_USER="wwwrun"
 -D AP_LOG_EXEC="/var/log/apache2/suexec.log"
 -D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
 -D AP_UID_MIN=96
 -D AP_USERDIR_SUFFIX="public_html"
der vhost jetzt so

Code: Select all

<VirtualHost *:80>
ServerName vhost.de
SuexecUserGroup user user
ScriptAlias /fcgi-bin/ /home/user/public_html/htdocs/fcgi-bin/
AddType application/x-httpd-fastphp .php
Action application/x-httpd-fastphp /fcgi-bin/php_fcgi
<Location /fgci-bin/>
Options +ExecCGI
SetHandler fastcgi-script
</Location>
DocumentRoot /home/user/public_html/htdocs
ErrorLog /var/log/apache2/user_error_log
LogLevel warn
CustomLog /var/log/apache2/user_log "combined"
AccessFileName .htaccess
ServerSignature Off
Alias /error/ /usr/share/apache2/error/
Alias /icons/ /usr/share/apache2/icons/
Alias /awstatsclasses /home/user/public_html/htdocs/statistics/classes/
Alias /awstatscss /home/user/public_html/htdocs/statistics/css/
Alias /awstatsicons /home/user/public_html/htdocs/statistics/icon/
ScriptAlias /awstats/ /home/user/public_html/htdocs/statistics/cgi-bin/
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
RewriteCond %{ENV:REDIRECT_STATUS} !=200
RewriteRule /fcgi-bin/php_fcgi - [F]
<Directory />
AllowOverride None
</Directory>
<Directory "/home/user/public_html/htdocs">
AllowOverride AuthConfig
Order allow,deny
Allow from all
Options -MultiViews -Indexes
</Directory>
DirectoryIndex index.html index.htm index.php
<Directory "/home/user/public_html/htdocs/cgi-bin">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>
<Directory "/home/user/public_html/htdocs/fcgi-bin">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
und das script so

Code: Select all

#!/bin/sh

PHPRC="/home/user/public_html/conf"
export PHPRC
PHP_FCGI_CHILDREN=2
export PHP_FCGI_CHILDREN
PHP_FCGI_MAX_REQUESTS=5000
export PHP_FCGI_MAX_REQUESTS
export FCGI_WEB_SERVER_ADDRS=127.0.0.1,81.169.131.237
exec /srw/www/cgi-bin/php5
Sorry, aber ich brings ned ans laufen und hab keine Idee mehr....
Der Rotz ging ja vorher auch...
rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: fcgid unter SuSE?

Post by rootsvr »

Ich tippe mal drauf das der einkompilierte docroot Pfad in der SuExec /var/www/ nicht mit /home/user/public_html übereinstimmt..

geht es wenn Du das Userdir nach /var/www/ verschiebst?
einherjer
Posts: 24
Joined: 2002-06-05 05:11
Location: München

Re: fcgid unter SuSE?

Post by einherjer »

Unter /srw/www gibts nen symlink ~htdocs der nach /home führt

Und das php fcgi liegt ja eigentlich unter /srv/www/cgi?

Müsste am Abend mal schauen welcher docroot unter 9.1 drin war bzw. was passiert wenn ich nen vhost in /srv/www anlege.

Was mich auch verwundert ist das der 500er nicht angezeigt wird sondern die html Datei mit dem Fehler drin zum Download angeboten wird...

Scheinbar hat das noch keiner unter ner neueren SuSE am laufen :-(
einherjer
Posts: 24
Joined: 2002-06-05 05:11
Location: München

Re: fcgid unter SuSE?

Post by einherjer »

es läuft wieder so halbwegs....

aus der vhost fliegen die Zeilen:
FastCgiSuexec on
FastCgiWrapper /usr/sbin/suexec2

/usr/sbin/suexec2 bekommt 4755 und aus /srv/www wird ////home
(grausame Lösung....)

in der php.ini und im Startscript noch Dateinamen (srv/www/cgi-bin/php5) bzw. extensions Verzeichnis anpassen

Weit entfernt von perfekt und sauber, bringt aber erstmal wieder buntes Bild