[Problem]Debian / fastcgi / php / Apache2

Apache, Lighttpd, nginx, Cherokee
bodo
Posts: 99
Joined: 2002-12-29 11:55
Location: Nürnberg

[Problem]Debian / fastcgi / php / Apache2

Post by bodo »

Ich habe auf meinem Testsystem das howto
http://www.debianhowto.de/doku.php/de:h ... 2_php-fcgi
probiert, bekomme aber immer nur einen 403 error...

Meine logs:

/var/log/apache2/error.log

Code: Select all

[Sat Sep 02 14:25:49 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
[Sat Sep 02 14:25:49 2006] [notice] FastCGI: wrapper mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
[Sat Sep 02 14:25:49 2006] [notice] FastCGI: process manager initialized (pid 10384)
[Sat Sep 02 14:25:49 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/default/php-fcgi-starter" (uid 1003, gid 1001) started (pid 10385)
[Sat Sep 02 14:25:49 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_fastcgi/mod_fastcgi-SNAP-0404142202 configured -- resuming normal operations
[Sat Sep 02 14:25:53 2006] [error] [client xxx.xxx.xxx.xxx] (13)Permission denied: access to / denied
/var/log/apache2/suexec.log

Code: Select all

[2006-09-02 14:25:49]: uid: (default/default) gid: (ftpuser/ftpuser) cmd: php-fcgi-starter
webroot

Code: Select all

R:/var/www/default/domain/html# ls -la
total 8
drwxr-xr-x  2 default ftpuser 112 Sep  2 11:17 .
drwxr-xr-x  6 default ftpuser 144 Sep  2 09:53 ..
-rwxrwxrwx  1 default ftpuser   6 Sep  2 10:33 index.html
-rwx------  1 default ftpuser  16 Sep  2 11:17 index.php
/etc/apache2/sites-available/default

Code: Select all

NameVirtualHost *:80
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName domain.tld
        ServerAlias www.domain.tld
        SuexecUserGroup default ftpuser
        DocumentRoot /var/www/default/domain/html
        DirectoryIndex index.php index.html index.htm
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/default/domain/html>
                Options FollowSymLinks
                AllowOverride AuthConfig
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /var/www/php-fcgi-scripts/default/
        <Directory "/var/www/php-fcgi-scripts/default">
                AllowOverride None
                Options +ExecCGI -MultiViews -Indexes
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On
</VirtualHost>
Ich seh glaub ich den Wald vor lauter Bäumen nicht... kann mir jemand einen Tipp geben?
cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: [Problem]Debian / fastcgi / php / Apache2

Post by cirox »

Hallo,

irgendie komm ich mit Deinem default-vhost oder was das ist nicht klar, außerdem hast du in einem log einmal uid 1003 oder so und noch ne andere gid.

Setz die Rechte bitte nochmal richtig und achte drauf, dass Dein suexec wrapper, oder wie der heisst ;-) unter /usr/lib/apache.... die Rechte 4755 hat. (ls -l /usr/lib/apache2/suexec2)

Du legst einfach einen vhost an, meinetwegen unter /var/www/web1 und in der fastcgi.conf nimmst Du immer einen user/group zum Ausführen. Auch hier nochmal howto durchgehen und Rechte überprüfen.

gruß cirox
croc
Posts: 71
Joined: 2005-09-16 15:30
Location: Leipzig

Re: [Problem]Debian / fastcgi / php / Apache2

Post by croc »

Der Fehler kam bei mir auch, bei der ersten Installation und ich war mir sicher alles richtig gemacht zu haben.
Wenn du versuchst den Fehler zu finden, wirds echt schwierig. Das kann Stunden dauern.
Ein 2. Installationsversuch sollte dich da ein bisschen schneller voranbringen, wobei du wirklich jede Zeile des Howto's lesen solltest, während der Installation.
bodo
Posts: 99
Joined: 2002-12-29 11:55
Location: Nürnberg

Re: [Problem]Debian / fastcgi / php / Apache2

Post by bodo »

es geht jetzt, ich habe in

Code: Select all

/var/www/default/

Code: Select all

chown default.www-data /var/www/default
gemacht, jetzt gehts.