Problem mit vhosts

Apache, Lighttpd, nginx, Cherokee
rooter
Posts: 6
Joined: 2006-08-29 19:57

Problem mit vhosts

Post by rooter »

Hallo,

Also habe folgendes Problem und brauche dringend Hilfe:

Ich habe mir unter Suse 9.3 bei Webmin unter Apache vhosts eingerichtet. Die Domain zeigt bereits auf die IP. Jedoch wenn ich jetzt die Domain aufrufe, erscheint Error 403.

Man kann das Verzeichnis aber mit der IP-Adresse aufrufen. (Index Dokument besteht und Zugriffsrechte sind gesetzt).

aus dem Error-Log:

[Tue Aug 29 19:54:09 2006] [error] [client xx.xx.xx.xxx] Directory index forbidden by rule: /srv/www/htdocs/

Wäre klasse wenn ihr mir helfen könntet!!

danke
rooter
sledge0303
Posts: 695
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Problem mit vhosts

Post by sledge0303 »

Musst auch mit DirectoryIndex definieren in der httpd.conf
rooter
Posts: 6
Joined: 2006-08-29 19:57

Re: Problem mit vhosts

Post by rooter »

sledge0303 wrote:Musst auch mit DirectoryIndex definieren in der httpd.conf
Die Dateiendung .html ist ja bereits dabei,

Was meinst du bitte genau?
sledge0303
Posts: 695
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Problem mit vhosts

Post by sledge0303 »

Was meinst du bitte genau?
z.B.

DirectoryIndex index.htm index.html index.php ...
Liegt im Webroot eines dieser Verzeichnisse, wird dieses bei Aufruf des Hosts geöffnet. http://yourhost.de
Steht die Datei nicht im Index mit drin, ist der Aufruf nur mit http://yourhost.de/irgendetwas.php möglich.
rooter
Posts: 6
Joined: 2006-08-29 19:57

Re: Problem mit vhosts

Post by rooter »

wenn ich http://www.yourhost.de/index.php aufrufe kommt "Objekt nicht gefunden",

und wenn ich http://www.yourhost.de aufrufe kommt eben 403

index.php ist bei directoryindex dabei!!

Was soll ich tun??
rooter
Posts: 6
Joined: 2006-08-29 19:57

Re: Problem mit vhosts

Post by rooter »

Habe jetzt bemerkt dass bei jeder Domain auf das Standardverzeichnis /srv/www/htdocs verwiesen wird.


Liegt es also an einer Einstellung des virtuellen Servers? Port oder so? Bei Adresse habe ich die IP, Port beliebig, bei Server-Name die Domain.
rooter
Posts: 6
Joined: 2006-08-29 19:57

Re: Problem mit vhosts

Post by rooter »

Kann mir denn niemand helfen?? Die vhosts funktioniern einfach nicht!!
thorsten
Posts: 561
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: Problem mit vhosts

Post by thorsten »

Du hast 3 Möglichkeiten:
a) poste deine $%#&| config - wie sollen wir erahnen was du bisher gemacht hast?!
b) such dir ein Forum für SuSE Anfänger und bitte dort geduldige User dir die Grundlagen beizubringen.
c) RTFM (Read The Fine Manual)