merkwürdige Mailserverprobleme...

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
theepoch
Posts: 11
Joined: 2006-04-16 00:21
Location: Solingen

merkwürdige Mailserverprobleme...

Post by theepoch » 2006-08-25 19:20

Hallo,
ich brauche mal bitte Rat und / oder Hilfe! Ich habe nach der Anleitung "ISP-ähnlicher Email Service mit Debian-Sarge und Postfix 2.1" in der Version wie sie auf "http://www.debianhowto.de" steht, die Dienst für einen Mailserver eingerichtet.

Mein Problem ist folgendes:
Laut allen Checks und Tests wie sie im Tut beschrieben sind, läuft alles gut bis zu der Stelle wo man mit (telnet servername 25) eine Mail verschicken soll. Hierbei komme ich nicht über den Punkt "mail from:<test@myserver> " hier beginnt einfach eine neue telnet Zeile und man kann die Verbindung nur noch abwürgen. Connecte ich mit meinem Thunderbird Client zu dem Server bekomme ich nach dem ich die Zertifikate akzeptiert habe (das klappt bis dahin) die Meldung:
"Fehler beim senden des Passwortes. Der Mailserver xxx antwortet: Maildir: No such file or directory"
Wenn ich im syslog nachschaue ist da nur der Eintrag zu finden, dass ein Client zum Server connected hat, aber KEINE Fehlermeldung!

Ich mache das mit dem Mailserver leider zum ersten mal und habe leider jetzt auch keine Idee was los sein könnte!

Danke für evt. Hilfe!

Fabian

PS: Passwörter sind auf jeden Fall richtig und ich habe auch keine Tippfehler in die Konfig.-files und SQL Tabellen eingegeben (alles jetzt schon x mal gecheckt Wink ).

elias5000
Posts: 66
Joined: 2006-08-18 14:35
Location: Berlin

Re: merkwürdige Mailserverprobleme...

Post by elias5000 » 2006-08-25 19:37

TheEPOCH wrote:Maildir: No such file or directory
Dieses Problem klingt eher nach IMAP-Server als nach SMTP-Server. Offenbar existiert das Maildir des Users, den du benutzt, nicht.

theepoch
Posts: 11
Joined: 2006-04-16 00:21
Location: Solingen

Re: merkwürdige Mailserverprobleme...

Post by theepoch » 2006-08-25 20:16

Mhh... ich weiss es nicht.
Auf jeden Fall ist Thunderbird in diesem Testfall auf POP3 gestellt und der Fehler tritt auch jeden Fall beim abhohlen der Mails auf (also Servertechnisch ein "courier" Problem)

Innerhalb des Tutorials stellt sich das so dar, dass ein Benutzer (also ein auf dem Server angelgter Benutzer) für das Mailhandling verantwortlich ist (User. vmail). Dieser Benutzer handelt über einen mySQl Benutzer, wiederum andere virtuelle Benutzer die aber dann letztendlich die Benutzer sind, die über das Mailsystem angemeldet werden (also letzendlich die End-User der Mailaccounts).

Ich hoffe ich hab das richtig verstanden und grade auch richtig erklärt... :-)

tobix
Posts: 7
Joined: 2006-08-15 14:28
Location: Frankfurt

Re: merkwürdige Mailserverprobleme...

Post by tobix » 2006-08-26 01:22

Wenn Du schon einen User in der DB angelegt hast, schick mal eine Mail an die Adresse. Dabei wird dann die Ordnerstruktur auf der HDD erzeugt, dann kannst Du auch Mails verschicken :)

Am einfachsten ist es, Du lässt an alle neu angelegten Postfächer (User) automatisch eine Mail schicken.

Ich habe sowas, z.B. per Webfrontend gemacht.

Gruß, Tobi