Apache2, rewrite-rules und jede menge Probs

Apache, Lighttpd, nginx, Cherokee
mk丨breaker
Posts: 6
Joined: 2006-08-24 08:50

Apache2, rewrite-rules und jede menge Probs

Post by mk丨breaker »

Moin ihrs :)

Nachdem ich vom Lampp (Windows) auf Apache2, php4, mysql (debian dediziert) umgestiegen bin, fangen bei mir auch gleich die Probleme an :
Ich habe vom Webspace meiner HP (Host Europe, debian) ein DB-Backup gemacht und bei mir auf LAN-Server (debian dediziert) importiert, danach die Webseite auf LAN-Server aufgerufen und das 1. Problem entdeckt :

Image

Nach kurzer Suche hier im Forum bin ich dann auf das gestossen :
http://www.rootforum.org/forum/viewtopic.php?t=36343

Zusätzlich habe ich noch die Apache2.conf nach einer Anleitung im Host-Europe-KIS modifiziert (AddDefaultCharSet = UTF-8).

Nachdem ich sql & apache neugestartet habe waren zwar die falschen Umlaute im Text weg, allerdings tauchten an anderen Stelle kleine Karos aauf (obwohl dort garkein Text oder sowas vorhanden ist, sondern nur ein <Space> ist, werden dort falsche Zeichen dargestellt) :

Nachdem ich die komplette UML neugestartet habe, war wieder das 1. Problem vorhanden (Mit dem Umlauten), langsam bin ich mit meiner Weisheit echt am ende, zumal es sich ja hier nur um 1 er vielen Probleme handelt.

2. Problem : Wie bereits beschrieben, habe ich Apache 2 installiert, um jetzt auch die Rewrite-Rules nutzen zu können, habe ich "a2enmod rewrite" per Konsole (ssh) eingegeben, die Meldung besagte, das "mod_rewrite" nun installiert wäre (was mir auch per php-info => apache2_handler bestätigt wird,- trotzdem läuft es nicht :

Image

Irgendwas muß ich bei der Konfig übersehen haben....nur was ? (Die Webseite, die da laufen soll, ist ein 1:1-Backup vom Webspace => http://www.benutzerfehler.de )....unter Windows (Lampp) lief sie auch immer ohne Probs..nur jetzt unter debian nichtmehr
mk丨breaker
Posts: 6
Joined: 2006-08-24 08:50

Re: Apache2, rewrite-rules und jede menge Probs

Post by mk丨breaker »

*ping* ....kann keiner helfen ? :cry:
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: Apache2, rewrite-rules und jede menge Probs

Post by Roger Wilco »

Problem 1: Charset der MySQL-Datenbank anpassen. AddDefaultCharset ist böse und sollte nicht benutzt werden.

Problem 2: AllowOverride korrekt gesetzt? Im error_log nachgesehen? Und liefere eine bessere Fehlerbeschreibung.

Problem 3: Nicht jeder liefert hier kostenfreien 24/7-Support. Du kannst dir vor einem Bump gerne auch mal 2 Tage Zeit lassen.
mk丨breaker
Posts: 6
Joined: 2006-08-24 08:50

Re: Apache2, rewrite-rules und jede menge Probs

Post by mk丨breaker »

Ok, Danke dir :)

Ich bin gerade am erneutemn Setup der Web-Klamotte dran..irgendwas lief da derb schief, ich melde mich dann nochmal ;)
jamiewolf
Posts: 43
Joined: 2003-01-12 05:09

Re: Apache2, rewrite-rules und jede menge Probs

Post by jamiewolf »

Also ich hatte es seiner Zeit beim Umsteig so gemacht.
  • Einen Dump der alten DB machen.
  • Den Dump konvertieren auf das Charset UTF-8, oder was auch immer du nutzt (bei mir Latin-1-german1)
  • Dump einspielen
  • Einstellungen in der my.cnf nicht vergessen
und voil la fertig ist das Suppenhuhn.

Gruß JamieWolf


p.s. Noch was, wenn man auf UTF-8 umstellt sollte auch der Header der Seite entsprechend so gestaltet sein, dass der Browser als default encoding UTF-8 nimmt, sonst gibt es auf der letzten Meile Probleme!!
mk丨breaker
Posts: 6
Joined: 2006-08-24 08:50

Re: Apache2, rewrite-rules und jede menge Probs

Post by mk丨breaker »

Das Prob ist, das ich regelmäßig Backups von verschiedenen Domains einspielen muß (sind alle latin-1).

In der Mysql-Conf (my.cnf) habe ich keiner derartigen Punkt gesehen, deshalb werde ich wohl auch das Prob haben, das ein falscher Standard eingestellt ist, der mir beim importieren den Dump versaut.

Kannst du mir mal bitte den entsprechenden Eintrag posten ?

Das hier habe ich zwar auch schon versucht, klappt aber irgendwie überhaupt nicht : http://www.rootforum.org/forum/viewtopic.php?t=36343