Postfix, SysCP und auxprop wollen nicht..

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
stefan
Posts: 10
Joined: 2006-06-09 12:15

Postfix, SysCP und auxprop wollen nicht..

Post by stefan » 2006-08-15 10:51

Hi,

ich habe seit einigen Tagen, bzw. seit dem letztem "upgrade" unter debian das folgende Problem.

Ich kann keine Mails mehr verschicken, da ich immer "Relay Access denied erhalte", da nach dem Update auf Sasl 2.1.19 "auxprop" nicht mehr enthalten ist und ich mich somit nicht mehr über die SQL Db authentifizieren kann..

Jetzt kann ich nur noch an den localhost Mails verschicken..

Hat zufällig einer eine Lösung für dieses Problem?

danke und gruß

Stefan

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Postfix, SysCP und auxprop wollen nicht..

Post by sledge0303 » 2006-08-15 13:35

Schau mal nach ob MySQL/PgSQL Unterstützung nach dem Upgrade noch vorhanden sind. Was wurde denn geupgraded, Postfix?

Code: Select all

postconf -m
sagt dir was unterstützt wird.

Code: Select all

ps aux | grep authdaemond
dort muss dann sowas wie "authdaemond.mysql" oder "authdaemond.psql" stehen.
Hast du dein Mailproggie auch so eingestellt, dass der sich beim Absenden einer Mail authentifizieren muss?

stefan
Posts: 10
Joined: 2006-06-09 12:15

Re: Postfix, SysCP und auxprop wollen nicht..

Post by stefan » 2006-08-15 13:45

Schau mal nach ob MySQL/PgSQL Unterstützung nach dem Upgrade noch vorhanden sind. Was wurde denn geupgraded, Postfix?

Code: Select all

postconf -m

Code: Select all

 postconf -m
static
cidr
nis
dbm
regexp
environ
proxy
btree
unix
hash
tcp
mysql
sdbm
sagt dir was unterstützt wird.

Code: Select all

ps aux | grep authdaemond

Code: Select all

ps aux | grep authdaemond
root     18424  0.0  0.0  1680  484 ?        S    10:48   0:00 /usr/sbin/courierlogger -pid=/var/run/courier/authdaemon/pid -start /usr/lib/courier/authlib/authdaemond.mysql
root     18425  0.0  0.0  2364  648 ?        S    10:48   0:00 /usr/lib/courier/authlib/authdaemond.mysql
root     18426  0.0  0.0  2404 1036 ?        S    10:48   0:00 /usr/lib/courier/authlib/authdaemond.mysql
root     18427  0.0  0.0  2404 1036 ?        S    10:48   0:00 /usr/lib/courier/authlib/authdaemond.mysql
root     18428  0.0  0.0  2404 1036 ?        S    10:48   0:00 /usr/lib/courier/authlib/authdaemond.mysql
root     18429  0.0  0.0  2404 1036 ?        S    10:48   0:00 /usr/lib/courier/authlib/authdaemond.mysql
root     18430  0.0  0.0  2404 1036 ?        S    10:48   0:00 /usr/lib/courier/authlib/authdaemond.mysql
root      6124  0.0  0.0  1560  536 pts/0    R+   13:34   0:00 grep authdaemond
dort muss dann sowas wie "authdaemond.mysql" oder "authdaemond.psql" stehen.
Hast du dein Mailproggie auch so eingestellt, dass der sich beim Absenden einer Mail authentifizieren muss?
>> jup

Es wurde libsasl & postfix geupgradet.

Das steht übrigens in der Log, da afaik nich auf die SQL Db zugegrifefn werden kann..

Aug 15 13:37:34 xxx postfix/smtpd[7203]: warning: xxx: SASL LOGIN authentication failed