[gelöst] authpam Problem mit courier-imap

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
acronis
Posts: 49
Joined: 2005-06-17 06:41

[gelöst] authpam Problem mit courier-imap

Post by acronis » 2006-08-11 23:32

Hallo gentoorianer,

ich habe ein kleines Problem mit postfix und courier-imap. Eher mit courier
Jedesmal, wenn ich meine mails abrufen möchte, kommt folgendes:

Das komische ist aber, dass das Problem erst nach der Version courier-imap-4.0.1-r2 auftritt.

Code: Select all

Aug 10 21:47:27 server pop3d: Connection, ip=[::ffff:85.178.xx.xx]
Aug 10 21:47:28 server authdaemond: received auth request, service=pop3, authtype=login
Aug 10 21:47:28 server authdaemond: authpam: trying this module
Aug 10 21:47:28 server authdaemond: authpam: sysusername=web1p1, sysuserid=<null>, sysgroupid=502, homedir=/home/mail/web1p1, address=web1p1, fullname=, maildir=<null>, quota=<null>, options=<null>
Aug 10 21:47:28 server authdaemond: authpam: clearpasswd=<null>, passwd=x
Aug 10 21:47:28 server authdaemond: pam_service=pop3, pam_username=web1p1
Aug 10 21:47:29 server authdaemond: pam_authenticate failed, result 7
Aug 10 21:47:29 server authdaemond: authpam: REJECT - try next module
Aug 10 21:47:29 server authdaemond: FAIL, all modules rejected
Aug 10 21:47:29 server pop3d: LOGIN FAILED, user=web1p1, ip=[::ffff:85.178.xx.xx]
Aug 10 21:47:34 server pop3d: LOGOUT, ip=[::ffff:85.178.xx.xx]
Aug 10 21:47:34 server pop3d: Disconnected, ip=[::ffff:85.178.xx.xx]
Weiß zufällig jemand Rat? Soll ich mal die configs posten?

Danke in Voraus!

Gruß
Last edited by acronis on 2006-08-15 19:09, edited 1 time in total.

acronis
Posts: 49
Joined: 2005-06-17 06:41

Re: [gelöst] authpam Problem mit courier-imap

Post by acronis » 2006-08-15 19:08

Ha! Ich habe die Lösung gefunden!

Es lag nicht an courier, sondern an PAM

/etc/pam.d/imap und pop folgendes eintragen:

Code: Select all

auth            required       pam_unix.so      nullok
account         required       pam_unix.so
password        required       pam_unix.so
session         required       pam_unix.so
nun funktioniert es!